aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gdal
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-06-10 02:29:39 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-06-10 02:29:39 +0800
commit1aa75d1db1ba85e896950eb0acdad08d7419c623 (patch)
treee301d03fe807afa89aeec63104e220347d752dd2 /graphics/gdal
parent041d8dd2d55902d24699995cf0ccfaef5cca3d5b (diff)
downloadfreebsd-ports-gnome-1aa75d1db1ba85e896950eb0acdad08d7419c623.tar.gz
freebsd-ports-gnome-1aa75d1db1ba85e896950eb0acdad08d7419c623.tar.zst
freebsd-ports-gnome-1aa75d1db1ba85e896950eb0acdad08d7419c623.zip
- Remove LDFLAGS
- Move CPPFLAGS to ICONV_CPPFLAGS
Diffstat (limited to 'graphics/gdal')
-rw-r--r--graphics/gdal/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/graphics/gdal/Makefile b/graphics/gdal/Makefile
index 886c656fffc9..05a26d5a08d9 100644
--- a/graphics/gdal/Makefile
+++ b/graphics/gdal/Makefile
@@ -43,8 +43,6 @@ CONFIGURE_ARGS= --datadir=${DATADIR} \
--with-threads=yes \
--without-libtool
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE} -lpthread
MAKE_JOBS_UNSAFE= yes
MAKEFILE= GNUmakefile
USE_LDCONFIG= yes
@@ -84,6 +82,7 @@ HDF5_CONFIGURE_ON= --with-hdf5=${LOCALBASE}
HDF5_LIB_DEPENDS= libhdf5.so:${PORTSDIR}/science/hdf5
ICONV_CONFIGURE_OFF= --with-libiconv-prefix=no
ICONV_CONFIGURE_ON= ${ICONV_CONFIGURE_ARG}
+ICONV_CPPFLAGS= -I${LOCALBASE}/include
ICONV_LDFLAGS= -L${ICONV_PREFIX}/lib ${ICONV_LIB}
ICONV_USES= iconv
JASPER_CONFIGURE_OFF= --with-jasper=no