aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gephex
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
committermiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
commitbce9b81f9d6099820f3839d7809d6b08c1d2ae7b (patch)
treef5dd7c3a8dbebad79bdb5e844aeb69c59a9fd12c /graphics/gephex
parent2eea5f1d2e44418020f8f4db08d40bea6915b6e8 (diff)
downloadfreebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.gz
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.zst
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Diffstat (limited to 'graphics/gephex')
-rw-r--r--graphics/gephex/Makefile10
-rw-r--r--graphics/gephex/files/patch-configure.ac2
2 files changed, 5 insertions, 7 deletions
diff --git a/graphics/gephex/Makefile b/graphics/gephex/Makefile
index 0f92f24cf30f..64edc5a961c1 100644
--- a/graphics/gephex/Makefile
+++ b/graphics/gephex/Makefile
@@ -25,11 +25,10 @@ CONFIGURE_ARGS= --without-V4L --without-ASOUNDLIB --without-LINUX_JOYSTICK \
--without-FFMPEG --without-AVIFILE --without-MPEG3 \
--without-LIBPNG --without-SDL --without-SDL_IMAGE \
--without-SDL_TTF --without-AALIB --disable-static \
- --with-qt-libdir="${X11BASE}/lib" \
- --with-qt-incdir="${X11BASE}/include" \
- --with-qt-bindir="${X11BASE}/bin"
+ --with-qt-libdir="${LOCALBASE}/lib" \
+ --with-qt-incdir="${LOCALBASE}/include" \
+ --with-qt-bindir="${LOCALBASE}/bin"
USE_QT_VER= 3
-USE_XLIB= yes
WANT_SDL= yes
USE_LDCONFIG= yes
LDCONFIG_DIRS= %%PREFIX%%/lib/${PORTNAME}-${PORTVERSION:R}
@@ -64,7 +63,7 @@ WITH_MPEG3= yes
WITH_PNG= yes
.endif
-.if exists(${X11BASE}/lib/libGL.so) && !defined(WITHOUT_GL)
+.if exists(${LOCALBASE}/lib/libGL.so) && !defined(WITHOUT_GL)
WITH_GL= yes
.endif
@@ -172,7 +171,6 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|; \
- s|%%X11BASE%%|${X11BASE}|; \
s|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/configure.ac
@${REINPLACE_CMD} -e 's|%%PORTDOCS%%|${DO_DOCS}|' ${WRKSRC}/Makefile.am
diff --git a/graphics/gephex/files/patch-configure.ac b/graphics/gephex/files/patch-configure.ac
index 4d981a0194cf..9b59a1308efa 100644
--- a/graphics/gephex/files/patch-configure.ac
+++ b/graphics/gephex/files/patch-configure.ac
@@ -17,7 +17,7 @@
# optional libraries
+ac_save_CFLAGS="$CFLAGS"
-+CFLAGS="${CFLAGS} -I%%X11BASE%%/include"
++CFLAGS="${CFLAGS} -I%%LOCALBASE%%/include"
+
CHECK_EXTRA_LIB([GL],
[AC_CHECK_HEADER([GL/glx.h],have_gl=yes,have_gl=no)],