aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/giftool
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-06-13 05:42:32 +0800
committerbapt <bapt@FreeBSD.org>2012-06-13 05:42:32 +0800
commitf5eba1acd02cb57a7650fe6c33b912240f6ab8ab (patch)
tree785d921da1883d2c1df77c5add82a844e2ae090b /graphics/giftool
parenteb2a7f0a6ba691b8505dc2684f14abff26a76009 (diff)
downloadfreebsd-ports-gnome-f5eba1acd02cb57a7650fe6c33b912240f6ab8ab.tar.gz
freebsd-ports-gnome-f5eba1acd02cb57a7650fe6c33b912240f6ab8ab.tar.zst
freebsd-ports-gnome-f5eba1acd02cb57a7650fe6c33b912240f6ab8ab.zip
Conver to new options framework
Diffstat (limited to 'graphics/giftool')
-rw-r--r--graphics/giftool/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/graphics/giftool/Makefile b/graphics/giftool/Makefile
index 6ffed97b66c2..62de15e830e2 100644
--- a/graphics/giftool/Makefile
+++ b/graphics/giftool/Makefile
@@ -21,24 +21,26 @@ NO_WRKSUBDIR= yes
ALL_TARGET= giftool
MAKE_ARGS= CFLAGS="${CFLAGS}"
-OPTIONS= RETVALUE "Return value patch" on \
- MALLOCSIZE "Improve malloc size" on
+OPTIONS_DEFINE= RETVALUE MALLOCSIZE DOCS
+OPTIONS_DEFAULT= RETVALUE MALLOCSIZE
+RETVALUE_DESC= Return value patch
+MALLOCSIZE_DESC= Improve malloc size
PLIST_FILES= bin/${PORTNAME}
PORTDOCS= COPYRIGHT README
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_RETVALUE)
+.if ${PORT_OPTIONS:MRETVALUE}
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-aa
.endif
-.if defined(WITH_MALLOCSIZE)
+.if ${PORT_OPTIONS:MMALLOCSIZE}
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ab
.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/giftool ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
.endif
@@ -46,4 +48,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>