aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gimp-app/Makefile
diff options
context:
space:
mode:
authorerich <erich@FreeBSD.org>1997-10-16 04:18:02 +0800
committererich <erich@FreeBSD.org>1997-10-16 04:18:02 +0800
commit9bde89330220d20af352db9e8005a3643bc1f643 (patch)
tree0f227c5795081a5f9bbc0a41674a15e32c7859ab /graphics/gimp-app/Makefile
parent464de419d395527d4b4ca4d65e21e9d5c553b134 (diff)
downloadfreebsd-ports-gnome-9bde89330220d20af352db9e8005a3643bc1f643.tar.gz
freebsd-ports-gnome-9bde89330220d20af352db9e8005a3643bc1f643.tar.zst
freebsd-ports-gnome-9bde89330220d20af352db9e8005a3643bc1f643.zip
upgrade to 0.99.14 (I hope this works)
Diffstat (limited to 'graphics/gimp-app/Makefile')
-rw-r--r--graphics/gimp-app/Makefile34
1 files changed, 22 insertions, 12 deletions
diff --git a/graphics/gimp-app/Makefile b/graphics/gimp-app/Makefile
index 67dd07babf4b..791c571a8225 100644
--- a/graphics/gimp-app/Makefile
+++ b/graphics/gimp-app/Makefile
@@ -1,38 +1,48 @@
-# New ports collection makefile for: GIMP
-# Version required: 0.99.7
+# New ports collection makefile for: Gimp
+# Version required: 0.99.13
# Date created: Mon Nov 18 21:28:43 CST 1996
# Whom: erich@FreeBSD.org
#
-# $Id: Makefile,v 1.9 1997/05/01 18:25:44 erich Exp $
+# $Id: Makefile,v 1.10 1997/07/14 22:19:04 erich Exp $
#
-VERSION= 0.99.10
-DATA_VERSION= 0.99.9
-DISTNAME= gimp-${VERSION}
+VERSION= 0.99.14
+
+DISTNAME= gimp-${VERSION}
DISTFILES= ${DISTNAME}.tar.gz
-DISTFILES+= gimp-data-${DATA_VERSION}.tar.gz
+DISTFILES+= gimp-data-min-${VERSION}.tar.gz \
+ gimp-data-extras-${VERSION}.tar.gz \
+ gimptcl-1.0.tar.gz
+
CATEGORIES= graphics
-MASTER_SITES= ftp://ftp.xcf.berkeley.edu/pub/gimp/developers/
+MASTER_SITES= ftp://ftp.cs.umn.edu/pub/gimp/gimp/devel/${VERSION}/ \
+ ftp://ftp.gimp.org/pub/gimp/devel/${VERSION}/ \
+ http://www.freebsd.org/~erich/
MAINTAINER= erich@FreeBSD.org
-#LIB_DEPENDS+= png\\.0\\.[7-9]:${PORTSDIR}/graphics/png
+LIB_DEPENDS+= gtk\\.1\\.0:${PORTSDIR}/x11/gtk
+LIB_DEPENDS+= png\\.0\\.[7-9]:${PORTSDIR}/graphics/png
LIB_DEPENDS+= jpeg\\.7\\.:${PORTSDIR}/graphics/jpeg
LIB_DEPENDS+= tiff\\.3\\.:${PORTSDIR}/graphics/tiff
LIB_DEPENDS+= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm
+LIB_DEPENDS+= mpeg\\.1\\.2:${PORTSDIR}/graphics/mpeg-lib
+LIB_DEPENDS+= tk80\\.1\\.:${PORTSDIR}/x11/tk80
USE_X11= yes
GNU_CONFIGURE= yes
-
USE_GMAKE= yes
+CONFIGURE_ENV= CPPFLAGS=-I/usr/local/include LIBS=-L/usr/local/lib
DATASTUFF= brushes palettes gradients patterns
post-install:
- cd ${WRKDIR}/gimp-data-${DATA_VERSION}; \
+ cd ${WRKDIR}/gimp-data-min-${VERSION}; \
+ tar -cf - --exclude '*Makefile*' ${DATASTUFF} |\
+ (cd ${PREFIX}/share/gimp/${VERSION}; tar -xvf -)
+ cd ${WRKDIR}/gimp-data-extras-${VERSION}; \
tar -cf - --exclude '*Makefile*' ${DATASTUFF} |\
(cd ${PREFIX}/share/gimp/${VERSION}; tar -xvf -)
-
.include <bsd.port.mk>