aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/giram
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2007-06-13 19:38:35 +0800
committerdanfe <danfe@FreeBSD.org>2007-06-13 19:38:35 +0800
commit68a7eb4cdc06203ed30c99352911a9c1843fd050 (patch)
tree50725d139d5cdcbe1915b1b8d61d56a465eb0304 /graphics/giram
parent83915190c42917e5839d3c43142fc5ed20227680 (diff)
downloadfreebsd-ports-gnome-68a7eb4cdc06203ed30c99352911a9c1843fd050.tar.gz
freebsd-ports-gnome-68a7eb4cdc06203ed30c99352911a9c1843fd050.tar.zst
freebsd-ports-gnome-68a7eb4cdc06203ed30c99352911a9c1843fd050.zip
- Fix the build with recent GCC [1]
- Convert to OPTIONS - Put MANx section apart from build-related knobs Reported by: pointyhat [1]
Diffstat (limited to 'graphics/giram')
-rw-r--r--graphics/giram/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/graphics/giram/Makefile b/graphics/giram/Makefile
index 42d8ff805bf5..ba6979eb044a 100644
--- a/graphics/giram/Makefile
+++ b/graphics/giram/Makefile
@@ -29,7 +29,10 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_ARGS= --datadir="${PREFIX}/lib" \
--with-tutorial-path="${DOCSDIR}" \
--with-lib3ds-prefix="${LOCALBASE}"
-MAN1= giram.1
+
+OPTIONS= POVRAY31 "Build against POV-Ray 3.1" off
+
+.include <bsd.port.pre.mk>
.if defined(WITH_POVRAY31)
BUILD_DEPENDS+= povray:${PORTSDIR}/graphics/povray31
@@ -39,10 +42,15 @@ BUILD_DEPENDS+= povray:${PORTSDIR}/graphics/povray
RUN_DEPENDS+= povray:${PORTSDIR}/graphics/povray
.endif
+MAN1= giram.1
+
+post-patch:
+ @${REINPLACE_CMD} -e '36s,static ,,' ${WRKSRC}/src/tools/tool_disc.c
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/samples/*.pov ${EXAMPLESDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>