aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gnomeiconedit
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-12-19 18:59:24 +0800
committersobomax <sobomax@FreeBSD.org>2001-12-19 18:59:24 +0800
commit74cc6597b8fcdd9786ef763c6f989c97d4e18303 (patch)
treeaba3a315f2ff5751f0705b795c49fd4068ae9ee2 /graphics/gnomeiconedit
parent661e51186751162f8e49594b9c9d76b789acb2dd (diff)
downloadfreebsd-ports-gnome-74cc6597b8fcdd9786ef763c6f989c97d4e18303.tar.gz
freebsd-ports-gnome-74cc6597b8fcdd9786ef763c6f989c97d4e18303.tar.zst
freebsd-ports-gnome-74cc6597b8fcdd9786ef763c6f989c97d4e18303.zip
- Fix gdk-pixbuf-related problems;
- link in dynamic libgnomeprint instead of static one. Submitted by: bento
Diffstat (limited to 'graphics/gnomeiconedit')
-rw-r--r--graphics/gnomeiconedit/files/patch-src::Makefile.in23
-rw-r--r--graphics/gnomeiconedit/files/patch-src::widgets::Makefile.in14
2 files changed, 37 insertions, 0 deletions
diff --git a/graphics/gnomeiconedit/files/patch-src::Makefile.in b/graphics/gnomeiconedit/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..c0e2e07a4997
--- /dev/null
+++ b/graphics/gnomeiconedit/files/patch-src::Makefile.in
@@ -0,0 +1,23 @@
+
+$FreeBSD$
+
+--- src/Makefile.in 2001/12/19 10:47:52 1.1
++++ src/Makefile.in 2001/12/19 10:54:53
+@@ -118,7 +118,7 @@
+
+ bin_PROGRAMS = gnome-iconedit $(COMPONENT)
+
+-INCLUDES = -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -DGNOMEDATADIR=\""$(datadir)"\" -I$(includedir) -I$(top_srcdir) -I$(top_srcdir)/src/widgets $(GNOME_INCLUDEDIR)
++INCLUDES = $(GDK_PIXBUF_CFLAGS) -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -DGNOMEDATADIR=\""$(datadir)"\" -I$(includedir) -I$(top_srcdir) -I$(top_srcdir)/src/widgets $(GNOME_INCLUDEDIR)
+
+
+ CORBA_GENERATED = Iconedit.h Iconedit-stubs.c Iconedit-skels.c Iconedit-common.c
+@@ -130,7 +130,7 @@
+ gnome_iconedit_SOURCES = app.c $(CORBA_GENERATED) corba.c menus.c iconedit.c palette.c grid.c view.c mode.c edit.c io.c pastebuffer.c layers.c art_rgba.c art_rgba.h app.h menus.h iconedit.h palette.h grid.h view.h edit.h io.h pastebuffer.h layers.h corba.h art_misc.h
+
+
+-@USE_GNOME_PRINT_TRUE@print_libs = $(GNOME_PRINT_PREFIX)/lib/libgnomeprint.a
++@USE_GNOME_PRINT_TRUE@print_libs = -lgnomeprint
+
+ gnome_iconedit_LDADD = widgets/libwidgets.a $(GNOME_LIBDIR) $(GNOMEUI_LIBS) $(GNORBA_LIBS) -lgdk_pixbuf -lz -lpng -lXpm -lxml -lz $(OAF_LIBS) $(print_libs)
+
diff --git a/graphics/gnomeiconedit/files/patch-src::widgets::Makefile.in b/graphics/gnomeiconedit/files/patch-src::widgets::Makefile.in
new file mode 100644
index 000000000000..44c2442d71c3
--- /dev/null
+++ b/graphics/gnomeiconedit/files/patch-src::widgets::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/widgets/Makefile.in 2001/12/19 10:46:38 1.1
++++ src/widgets/Makefile.in 2001/12/19 10:47:05
+@@ -110,7 +110,7 @@
+ ZVT_LIBS = @ZVT_LIBS@
+ l = @l@
+
+-INCLUDES = -I$(top_srcdir) -I$(includedir) $(GNOME_INCLUDEDIR) -DG_LOG_DOMAIN=\"GNOME-IconEditor\" -g -Wall -Wmissing-prototypes -Wmissing-declarations
++INCLUDES = $(GDK_PIXBUF_CFLAGS) -I$(top_srcdir) -I$(includedir) $(GNOME_INCLUDEDIR) -DG_LOG_DOMAIN=\"GNOME-IconEditor\" -g -Wall -Wmissing-prototypes -Wmissing-declarations
+
+
+ noinst_LIBRARIES = libwidgets.a