aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/graphite2
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-02-16 06:54:13 +0800
committerbapt <bapt@FreeBSD.org>2012-02-16 06:54:13 +0800
commit6abefe8942ed9bb2e9e2d902406f87763f5fbc2f (patch)
tree61cd9e4ee95d5bcbd334dc0bf61df795698c46ca /graphics/graphite2
parentc20a2693a1edfe9eb63a4c2d853747cbb8f0a981 (diff)
downloadfreebsd-ports-gnome-6abefe8942ed9bb2e9e2d902406f87763f5fbc2f.tar.gz
freebsd-ports-gnome-6abefe8942ed9bb2e9e2d902406f87763f5fbc2f.tar.zst
freebsd-ports-gnome-6abefe8942ed9bb2e9e2d902406f87763f5fbc2f.zip
- update to 1.1.0
Diffstat (limited to 'graphics/graphite2')
-rw-r--r--graphics/graphite2/Makefile12
-rw-r--r--graphics/graphite2/distinfo4
-rw-r--r--graphics/graphite2/files/patch-gr2fonttest__gr2FontTest.cpp11
3 files changed, 6 insertions, 21 deletions
diff --git a/graphics/graphite2/Makefile b/graphics/graphite2/Makefile
index d28be7cc6bc8..0a75af05cff7 100644
--- a/graphics/graphite2/Makefile
+++ b/graphics/graphite2/Makefile
@@ -6,25 +6,21 @@
#
PORTNAME= graphite2
-PORTVERSION= 1.0.3
-PORTREVISION= 1
+PORTVERSION= 1.1.0
CATEGORIES= graphics print
MASTER_SITES= SF/silgraphite/${PORTNAME}
EXTRACT_SUFX= .tgz
-MAINTAINER= office@FreeBSD.org
+MAINTAINER= bapt@FreeBSD.org
COMMENT= Rendering capabilities for complex non-Roman writing systems
-USE_GNOME= gnomehack
USE_CMAKE= yes
USE_ICONV= yes
USE_LDCONFIG= yes
LDFLAGS+= -L${LOCALBASE}/lib -liconv
post-patch:
- @${REINPLACE_CMD} -e 's,/pkgconfig,data/pkgconfig,g' \
- ${WRKSRC}/CMakeLists.txt
- @${REINPLACE_CMD} -e 's,$${GRAPHITE_API_MAJOR}.$${GRAPHITE_API_MINOR}.$${GRAPHITE_API_AGE},$${GRAPHITE_API_MAJOR},g' \
- ${WRKSRC}/src/CMakeLists.txt
+ @${REINPLACE_CMD} -e 's,/pkgconfig,data/pkgconfig,g' ${WRKSRC}/CMakeLists.txt
+ @${REINPLACE_CMD} -e 's/.$${GRAPHITE_API_REVISION}.$${GRAPHITE_API_AGE}//g' ${WRKSRC}/src/CMakeLists.txt
.include <bsd.port.mk>
diff --git a/graphics/graphite2/distinfo b/graphics/graphite2/distinfo
index e59e75c1dc3f..2960e0645715 100644
--- a/graphics/graphite2/distinfo
+++ b/graphics/graphite2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (graphite2-1.0.3.tgz) = 643c5307a3fdc31754a18c8c1398d4036a107e4bdc03d9a265fcadfc85d4a07a
-SIZE (graphite2-1.0.3.tgz) = 4352127
+SHA256 (graphite2-1.1.0.tgz) = 8cc93715e052c0d811dfaee3f7d3ca284eb48c3190352291a1650632c174f6d1
+SIZE (graphite2-1.1.0.tgz) = 4466441
diff --git a/graphics/graphite2/files/patch-gr2fonttest__gr2FontTest.cpp b/graphics/graphite2/files/patch-gr2fonttest__gr2FontTest.cpp
deleted file mode 100644
index 249407c65e25..000000000000
--- a/graphics/graphite2/files/patch-gr2fonttest__gr2FontTest.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./gr2fonttest/gr2FontTest.cpp.orig 2011-09-22 17:30:02.000000000 +0200
-+++ ./gr2fonttest/gr2FontTest.cpp 2012-01-22 10:24:33.468384204 +0100
-@@ -176,7 +176,7 @@
- #ifdef WIN32
- const char * pText = reinterpret_cast<char*>(pIn);
- #else
-- char * pText = reinterpret_cast<char*>(pIn);
-+ const char * pText = reinterpret_cast<char*>(pIn);
- #endif
- // It seems to be necessary to include the trailing null to prevent
- // stray characters appearing with utf16