aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gstreamer1-plugins-opencv
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2017-07-22 19:35:44 +0800
committerkwm <kwm@FreeBSD.org>2017-07-22 19:35:44 +0800
commitb373042cff9de15198cd2ef10fdd8b8b22cbf3e2 (patch)
treedb8ae1482499741d4dbb123637dac45579f28eb5 /graphics/gstreamer1-plugins-opencv
parent403761e2fb7c7b8dca331d78f774541fc003b24d (diff)
downloadfreebsd-ports-gnome-b373042cff9de15198cd2ef10fdd8b8b22cbf3e2.tar.gz
freebsd-ports-gnome-b373042cff9de15198cd2ef10fdd8b8b22cbf3e2.tar.zst
freebsd-ports-gnome-b373042cff9de15198cd2ef10fdd8b8b22cbf3e2.zip
Update GStreamer1 ports to 1.12.2.
Rework the adding of dependancies in Mk/bsd.gstreamer.mk. Previous when using USE_GSTREAMER[1] it would just add the request modules to BUILD/RUN_DEPENDS. This caused the qa script to complain because the old code didn't implicit depend on the gstreamer1 and gstreamer1-plugins[-bad] ports for the libraries they carried, even if they where present via the plugins! The new code adds implicit depends on these ports so USE_GSTREAMER[1] using ports have all the libraries included. * The mad mp3 plugin was removed, mpg123 plugin also provides mp3 decoding. Switch over ports that used the gstreamer1 mad plugin. * gtksink plugin renamed -> gtk * Hook up the sndio plugin into the framework * Add some indirect dependacies where needed * Reorder the plugin list in bsd.gstreamer.mk so only one plugin per line. When changing plugins it doesn't result in multiple lines being changed. * Remove mentions in bsd.gstreamer.mk of plugins mentions that where removed. * Depend on libunwind on i386/amd64, GStreamer links to it if it is present. PR: 220753 Exp-run by: antoine@
Diffstat (limited to 'graphics/gstreamer1-plugins-opencv')
-rw-r--r--graphics/gstreamer1-plugins-opencv/Makefile4
-rw-r--r--graphics/gstreamer1-plugins-opencv/pkg-plist8
2 files changed, 11 insertions, 1 deletions
diff --git a/graphics/gstreamer1-plugins-opencv/Makefile b/graphics/gstreamer1-plugins-opencv/Makefile
index 9fe2b6b045fc..a1ed0400ccd3 100644
--- a/graphics/gstreamer1-plugins-opencv/Makefile
+++ b/graphics/gstreamer1-plugins-opencv/Makefile
@@ -1,6 +1,6 @@
# $FreeBSD$
-PORTREVISION= 2
+PORTREVISION= 0
CATEGORIES= graphics
COMMENT= GStreamer opencv real time computer vision plugin
@@ -13,4 +13,6 @@ MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
# Clang has issues with Overloaded stuff inside OpenCV
CXXFLAGS+= -Wno-overloaded-virtual
+PLIST= ${.CURDIR}/pkg-plist
+
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/gstreamer1-plugins-opencv/pkg-plist b/graphics/gstreamer1-plugins-opencv/pkg-plist
new file mode 100644
index 000000000000..aa761c8259ae
--- /dev/null
+++ b/graphics/gstreamer1-plugins-opencv/pkg-plist
@@ -0,0 +1,8 @@
+include/gstreamer-%%VERSION%%/gst/opencv/gstopencvutils.h
+include/gstreamer-%%VERSION%%/gst/opencv/gstopencvvideofilter.h
+lib/gstreamer-%%VERSION%%/libgstopencv.so
+lib/libgstopencv-%%VERSION%%.so
+lib/libgstopencv-%%VERSION%%.so.0
+lib/libgstopencv-%%VERSION%%.so.%%SOVERSION%%
+share/gst-plugins-bad/%%VERSION%%/opencv_haarcascades/fist.xml
+share/gst-plugins-bad/%%VERSION%%/opencv_haarcascades/palm.xml