aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/icoutils
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-08-29 07:30:05 +0800
committerMartin Wilke <miwi@FreeBSD.org>2009-08-29 07:30:05 +0800
commitcf48c3cb4f7818dc01288a47575b51451e12fa42 (patch)
tree03c59c19b4de9fbf50fad46599a39ae8502d1323 /graphics/icoutils
parent811085b6cd96b6d0b569f2e3990d9821a491f746 (diff)
downloadfreebsd-ports-gnome-cf48c3cb4f7818dc01288a47575b51451e12fa42.tar.gz
freebsd-ports-gnome-cf48c3cb4f7818dc01288a47575b51451e12fa42.tar.zst
freebsd-ports-gnome-cf48c3cb4f7818dc01288a47575b51451e12fa42.zip
- Update to 0.28.0
PR: 138277 Submitted by: Ports Fury
Diffstat (limited to 'graphics/icoutils')
-rw-r--r--graphics/icoutils/Makefile4
-rw-r--r--graphics/icoutils/distinfo6
-rw-r--r--graphics/icoutils/files/patch-icotool__Makefile.in15
-rw-r--r--graphics/icoutils/files/patch-icotool__win32-endian.c41
-rw-r--r--graphics/icoutils/files/patch-wrestool__Makefile.in12
5 files changed, 5 insertions, 73 deletions
diff --git a/graphics/icoutils/Makefile b/graphics/icoutils/Makefile
index 3bcd09d6f9cc..2fe5f2d3f3d1 100644
--- a/graphics/icoutils/Makefile
+++ b/graphics/icoutils/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= icoutils
-PORTVERSION= 0.27.0
+PORTVERSION= 0.28.0
CATEGORIES= graphics
MASTER_SITES= SAVANNAH
@@ -16,9 +16,9 @@ COMMENT= Convert/extract images in Microsoft Windows(R) icon/cursor files
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
RUN_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
-USE_GETTEXT= yes
USE_PERL5_RUN= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-nls
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/graphics/icoutils/distinfo b/graphics/icoutils/distinfo
index 89bb6fb1e094..d00fa5758009 100644
--- a/graphics/icoutils/distinfo
+++ b/graphics/icoutils/distinfo
@@ -1,3 +1,3 @@
-MD5 (icoutils-0.27.0.tar.gz) = e0ec22c83290317a04110a3d05d1c7ac
-SHA256 (icoutils-0.27.0.tar.gz) = 848456fdfddfdefde30946ff60658b3af544623dcde2118c75aa583a0bdf46a9
-SIZE (icoutils-0.27.0.tar.gz) = 489729
+MD5 (icoutils-0.28.0.tar.gz) = 8b28053a5b6c2fd900d73a7aeed0cdb3
+SHA256 (icoutils-0.28.0.tar.gz) = c02f0249ed937f108ae337a86a8c3564ea6c8c2282d61665109f206e757b5f69
+SIZE (icoutils-0.28.0.tar.gz) = 500481
diff --git a/graphics/icoutils/files/patch-icotool__Makefile.in b/graphics/icoutils/files/patch-icotool__Makefile.in
deleted file mode 100644
index 072d2caa2c91..000000000000
--- a/graphics/icoutils/files/patch-icotool__Makefile.in
+++ /dev/null
@@ -1,15 +0,0 @@
---- icotool/Makefile.in.orig 2009-06-30 03:14:01.000000000 +0900
-+++ icotool/Makefile.in 2009-07-07 01:32:50.000000000 +0900
-@@ -559,9 +559,10 @@
- win32.h
-
- icotool_LDADD = \
-- @PNG_LIBS@ \
- ../common/libcommon.a \
-- ../lib/libgnu.a
-+ ../lib/libgnu.a \
-+ @PNG_LIBS@ \
-+ @LIBINTL@
-
- man_MANS = \
- icotool.1
diff --git a/graphics/icoutils/files/patch-icotool__win32-endian.c b/graphics/icoutils/files/patch-icotool__win32-endian.c
deleted file mode 100644
index a33bc5b6fdb5..000000000000
--- a/graphics/icoutils/files/patch-icotool__win32-endian.c
+++ /dev/null
@@ -1,41 +0,0 @@
---- icotool/win32-endian.c.orig Sun Nov 27 18:43:33 2005
-+++ icotool/win32-endian.c Sun Nov 27 21:05:48 2005
-@@ -17,6 +17,10 @@
- * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
- */
-
-+#if (defined(__unix__) || defined(unix)) && !defined(USG)
-+#include <sys/param.h>
-+#endif
-+
- #include <config.h>
- #include "win32-endian.h"
-
-@@ -27,6 +31,27 @@
- #define bswap_16(x) NXSwapShort(x)
- #define bswap_32(x) NXSwapInt(x)
- #define bswap_64(x) NXSwapLongLong(x)
-+#elif defined(__FreeBSD__) && (__FreeBSD_version >= 470000)
-+# include <sys/endian.h>
-+# if (__FreeBSD_version >= 500000)
-+# define bswap_16(x) bswap16(x)
-+# define bswap_32(x) bswap32(x)
-+# define bswap_64(x) bswap64(x)
-+# else
-+# define bswap_16(x) be16toh(x)
-+# define bswap_32(x) be32toh(x)
-+# define bswap_64(x) \
-+ x = ((((x) & 0xff00000000000000) >> 56) | \
-+ (((x) & 0x00ff000000000000) >> 40) | \
-+ (((x) & 0x0000ff0000000000) >> 24) | \
-+ (((x) & 0x000000ff00000000) >> 8) | \
-+ (((x) & 0x00000000ff000000) << 8) | \
-+ (((x) & 0x0000000000ff0000) << 24) | \
-+ (((x) & 0x000000000000ff00) << 40) | \
-+ (((x) & 0x00000000000000ff) << 56))
-+# endif /* >= 4.7-R || >= 5.0-CURRENT */
-+#else
-+# include "common/byteswap.h"
- #endif
-
- #define BSWAP16(x) ((x) = bswap_16(x))
diff --git a/graphics/icoutils/files/patch-wrestool__Makefile.in b/graphics/icoutils/files/patch-wrestool__Makefile.in
deleted file mode 100644
index 889a0392e1b2..000000000000
--- a/graphics/icoutils/files/patch-wrestool__Makefile.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- wrestool/Makefile.in.orig 2009-06-30 03:14:01.000000000 +0900
-+++ wrestool/Makefile.in 2009-07-07 01:33:24.000000000 +0900
-@@ -558,7 +558,8 @@
-
- wrestool_LDADD = \
- ../common/libcommon.a \
-- ../lib/libgnu.a
-+ ../lib/libgnu.a \
-+ @LIBINTL@
-
- man_MANS = \
- wrestool.1