aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ilmbase
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2012-09-20 22:37:41 +0800
committerswills <swills@FreeBSD.org>2012-09-20 22:37:41 +0800
commit3a680c9044ff07b115ad4d8db953a7523b044535 (patch)
treeedc179b6e34baf1d0b68992afcbcdf03fa6f1b62 /graphics/ilmbase
parentde49a99949a3c717805edce2894ffb1c5aa5d47e (diff)
downloadfreebsd-ports-gnome-3a680c9044ff07b115ad4d8db953a7523b044535.tar.gz
freebsd-ports-gnome-3a680c9044ff07b115ad4d8db953a7523b044535.tar.zst
freebsd-ports-gnome-3a680c9044ff07b115ad4d8db953a7523b044535.zip
- Update to 1.0.2
- Convert to OptionsNG
Diffstat (limited to 'graphics/ilmbase')
-rw-r--r--graphics/ilmbase/Makefile11
-rw-r--r--graphics/ilmbase/distinfo4
-rw-r--r--graphics/ilmbase/files/patch-IlmThread-IlmThreadPool.cpp43
-rw-r--r--graphics/ilmbase/files/patch-configure47
4 files changed, 55 insertions, 50 deletions
diff --git a/graphics/ilmbase/Makefile b/graphics/ilmbase/Makefile
index e705d228f6d3..094ef0f2e96e 100644
--- a/graphics/ilmbase/Makefile
+++ b/graphics/ilmbase/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ilmbase
-PORTVERSION= 1.0.1
-PORTREVISION= 1
+PORTVERSION= 1.0.2
CATEGORIES= graphics devel
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= openexr
@@ -17,19 +16,21 @@ COMMENT= ILM Base libraries a.k.a. Half, IlmThread, Imath, and Iex
CONFLICTS= OpenEXR-1.[0-4].*
-OPTIONS= THREAD "Enable multithreaded file I/O support" on
+OPTIONS_DEFINE= THREAD
+OPTIONS_DEFAULT= THREAD
+THREAD_DESC= Enable multithreaded file I/O support
USE_GNOME= pkgconfig
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool
-regression test check: build
+regression-test regression test check: build
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
.include <bsd.port.pre.mk>
-.if defined(WITH_THREAD)
+.if ${PORT_OPTIONS:MTHREAD}
CONFIGURE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
.else
diff --git a/graphics/ilmbase/distinfo b/graphics/ilmbase/distinfo
index 13c4c77462ab..2ba9b81aac6b 100644
--- a/graphics/ilmbase/distinfo
+++ b/graphics/ilmbase/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ilmbase-1.0.1.tar.gz) = 4f14fc7b26a37a391ec5f979697148e6774bc36bc052de26e40ffabe401e397d
-SIZE (ilmbase-1.0.1.tar.gz) = 463275
+SHA256 (ilmbase-1.0.2.tar.gz) = 2e5cda799ffdfca9b1a16bb120d49c74a39af1457ef22f968918c6200ba62e44
+SIZE (ilmbase-1.0.2.tar.gz) = 496540
diff --git a/graphics/ilmbase/files/patch-IlmThread-IlmThreadPool.cpp b/graphics/ilmbase/files/patch-IlmThread-IlmThreadPool.cpp
deleted file mode 100644
index 56630ef346cf..000000000000
--- a/graphics/ilmbase/files/patch-IlmThread-IlmThreadPool.cpp
+++ /dev/null
@@ -1,43 +0,0 @@
---- IlmThread/IlmThreadPool.cpp.orig 2006-12-09 06:59:36.000000000 +0900
-+++ IlmThread/IlmThreadPool.cpp 2007-10-07 23:29:07.000000000 +0900
-@@ -247,7 +247,7 @@
- // an error like: "pure virtual method called"
- //
-
-- for (int i = 0; i < numThreads; i++)
-+ for (unsigned int i = 0; i < numThreads; i++)
- {
- taskSemaphore.post();
- threadSemaphore.wait();
-@@ -364,19 +364,19 @@
-
- Lock lock (_data->threadMutex);
-
-- if (count > _data->numThreads)
-+ if ((unsigned int)count > _data->numThreads)
- {
- //
- // Add more threads
- //
-
-- while (_data->numThreads < count)
-+ while (_data->numThreads < (unsigned int)count)
- {
- _data->threads.push_back (new WorkerThread (_data));
- _data->numThreads++;
- }
- }
-- else if (count < _data->numThreads)
-+ else if ((unsigned int)count < _data->numThreads)
- {
- //
- // Wait until all existing threads are finished processing,
-@@ -389,7 +389,7 @@
- // Add in new threads
- //
-
-- while (_data->numThreads < count)
-+ while (_data->numThreads < (unsigned int)count)
- {
- _data->threads.push_back (new WorkerThread (_data));
- _data->numThreads++;
diff --git a/graphics/ilmbase/files/patch-configure b/graphics/ilmbase/files/patch-configure
new file mode 100644
index 000000000000..ecb43fbaafa3
--- /dev/null
+++ b/graphics/ilmbase/files/patch-configure
@@ -0,0 +1,47 @@
+--- configure.orig 2012-09-19 00:48:14.000000000 +0000
++++ configure 2012-09-19 00:51:54.000000000 +0000
+@@ -20384,25 +20384,25 @@
+ osx_arch=default
+ fi;
+
+- if test "${osx_arch}" != default ; then
+- osx_arch_flags="-arch ${osx_arch// / -arch }"
+- CXXFLAGS="$CXXFLAGS $osx_arch_flags"
+-
+- if test "$enable_dependency_tracking" != no ; then
+- osx_arch_array=( ${osx_arch} )
+- if test ${#osx_arch_array[@]} -gt 1 ; then
+- { { echo "$as_me:$LINENO: error: building multiple OS X architectures requires --disable-dependency-tracking.
+-Please re-run configure with these options:
+- --enable-osx-arch=\"${osx_arch}\" --disable-dependency-tracking
+- " >&5
+-echo "$as_me: error: building multiple OS X architectures requires --disable-dependency-tracking.
+-Please re-run configure with these options:
+- --enable-osx-arch=\"${osx_arch}\" --disable-dependency-tracking
+- " >&2;}
+- { (exit 1); exit 1; }; }
+- fi
+- fi
+- fi
++# if test "${osx_arch}" != default ; then
++# osx_arch_flags="-arch ${osx_arch// / -arch }"
++# CXXFLAGS="$CXXFLAGS $osx_arch_flags"
++#
++# if test "$enable_dependency_tracking" != no ; then
++# osx_arch_array=( ${osx_arch} )
++# if test ${#osx_arch_array[@]} -gt 1 ; then
++# { { echo "$as_me:$LINENO: error: building multiple OS X architectures requires --disable-dependency-tracking.
++#Please re-run configure with these options:
++# --enable-osx-arch=\"${osx_arch}\" --disable-dependency-tracking
++# " >&5
++#echo "$as_me: error: building multiple OS X architectures requires --disable-dependency-tracking.
++#Please re-run configure with these options:
++# --enable-osx-arch=\"${osx_arch}\" --disable-dependency-tracking
++# " >&2;}
++# { (exit 1); exit 1; }; }
++# fi
++# fi
++# fi
+
+ # Check whether --enable-osx-sdk or --disable-osx-sdk was given.
+ if test "${enable_osx_sdk+set}" = set; then