aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/imageindex
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2014-03-04 00:37:04 +0800
committernemysis <nemysis@FreeBSD.org>2014-03-04 00:37:04 +0800
commit5e6b17ee28fc3150198fa33fda5c63d81fbc8872 (patch)
tree2d962d4e87e7ad1ce174227e3e82a177deebba2d /graphics/imageindex
parentabd76b47f062e5c6378c3d16998a30a1643c7658 (diff)
downloadfreebsd-ports-gnome-5e6b17ee28fc3150198fa33fda5c63d81fbc8872.tar.gz
freebsd-ports-gnome-5e6b17ee28fc3150198fa33fda5c63d81fbc8872.tar.zst
freebsd-ports-gnome-5e6b17ee28fc3150198fa33fda5c63d81fbc8872.zip
- Remove leading article from COMMENT
- Use LIB_DEPENDS for graphics/jpeg - Change RUN_DEPENDS for graphics/ImageMagick and multimedia/mplayer - Support STAGEDIR - Add DOCS Option - Change typo | ;' to |' PR: ports/177322 Submitted by: nemysis (self) Approved by: maintainer timeout (11 months)
Diffstat (limited to 'graphics/imageindex')
-rw-r--r--graphics/imageindex/Makefile28
1 files changed, 12 insertions, 16 deletions
diff --git a/graphics/imageindex/Makefile b/graphics/imageindex/Makefile
index 205bb096132e..bfec0b17433a 100644
--- a/graphics/imageindex/Makefile
+++ b/graphics/imageindex/Makefile
@@ -9,31 +9,27 @@ MASTER_SITES= http://www.edwinh.org/imageindex/release/ \
http://www.reynoldsnet.org/imageindex/release/
MAINTAINER= johnjen@reynoldsnet.org
-COMMENT= A digital photo gallery tool
+COMMENT= Digital photo gallery tool
-RUN_DEPENDS= \
- ${LOCALBASE}/bin/Magick-config:${PORTSDIR}/graphics/ImageMagick \
- ${LOCALBASE}/bin/wrjpgcom:${PORTSDIR}/graphics/jpeg \
- ${LOCALBASE}/bin/mplayer:${PORTSDIR}/multimedia/mplayer \
- p5-Image-Info>=0:${PORTSDIR}/graphics/p5-Image-Info
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
+RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick \
+ mplayer:${PORTSDIR}/multimedia/mplayer \
+ p5-Image-Info>=0:${PORTSDIR}/graphics/p5-Image-Info
USES= perl5
USE_PERL5= run
-MAKE_ARGS+= PERLPATH=${PERL}
+MAKE_ARGS+= PERLPATH=${PERL} PREFIX=${STAGEDIR}${PREFIX}
-PLIST_FILES= bin/imageindex bin/autocaption
+PLIST_FILES= bin/imageindex bin/autocaption \
+ man/man1/imageindex.1.gz
PORTDOCS= README
+OPTIONS_DEFINE= DOCS
-MAN1= imageindex.1
-
-NO_STAGE= yes
post-patch:
- ${REINPLACE_CMD} -e 's|share/man|man| ;' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|share/man|man|' ${WRKSRC}/Makefile
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>