aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/inkscape/Makefile
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2014-10-20 17:12:19 +0800
committerkwm <kwm@FreeBSD.org>2014-10-20 17:12:19 +0800
commit59f2c1e09d95bddff854d825e9a3ab9c16875505 (patch)
tree4f5f11587c1561aa77afa7f70617a486da507d9b /graphics/inkscape/Makefile
parent028382a56c30dfab2894ae2caac913734f1e99fe (diff)
downloadfreebsd-ports-gnome-59f2c1e09d95bddff854d825e9a3ab9c16875505.tar.gz
freebsd-ports-gnome-59f2c1e09d95bddff854d825e9a3ab9c16875505.tar.zst
freebsd-ports-gnome-59f2c1e09d95bddff854d825e9a3ab9c16875505.zip
Update to 0.48.5.
Adobe Illustrator SVG files containing entities can be loaded again Support for Poppler 0.26 Support for Boehm-GC 7.4.0 and later Several crash bugs were fixed Remove the gnomevfs option. Install all available manpages.
Diffstat (limited to 'graphics/inkscape/Makefile')
-rw-r--r--graphics/inkscape/Makefile14
1 files changed, 3 insertions, 11 deletions
diff --git a/graphics/inkscape/Makefile b/graphics/inkscape/Makefile
index 6873279cab8c..5fa4a4cb6087 100644
--- a/graphics/inkscape/Makefile
+++ b/graphics/inkscape/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= inkscape
-PORTVERSION= 0.48.4
-PORTREVISION= 8
+PORTVERSION= 0.48.5
CATEGORIES= graphics gnome
MASTER_SITES= SF
MASTER_SITE_SUBDIR=${PORTNAME:tl}/${PORTNAME:tl}/${PORTVERSION}
@@ -29,16 +28,16 @@ GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS= --without-gnome-vfs
python_OLD_CMD?=/usr/bin/env python
python_CMD?= ${LOCALBASE}/bin/python2
SHEBANG_FILES= cxxtest/cxxtestgen.pl share/extensions/*.p[lm] \
share/extensions/*.py
-OPTIONS_DEFINE= GNOMEVFS POPPLER
+OPTIONS_DEFINE= POPPLER
OPTIONS_DEFAULT=POPPLER
POPPLER_DESC= PDF preview rendering
-GNOMEVFS_DESC= Use gnomevfs for loading files
.include <bsd.port.options.mk>
@@ -47,13 +46,6 @@ _CCVERSION!= ${CC} --version
CPPFLAGS+= -Wno-mismatched-tags
.endif
-.if ${PORT_OPTIONS:MGNOMEVFS}
-USE_GNOME+= gnomevfs2
-CONFIGURE_ARGS+= --with-gnome-vfs
-.else
-CONFIGURE_ARGS+= --without-gnome-vfs
-.endif
-
.if ${PORT_OPTIONS:MPOPPLER}
LIB_DEPENDS+= libpoppler-glib.so:${PORTSDIR}/graphics/poppler-glib
CONFIGURE_ARGS+= --enable-poppler-cairo