aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/inkscape
diff options
context:
space:
mode:
authorbland <bland@FreeBSD.org>2003-11-17 12:03:39 +0800
committerbland <bland@FreeBSD.org>2003-11-17 12:03:39 +0800
commit2e890be8dabad411d1d932305abb9903874de868 (patch)
tree6e8f90ad950eedee3bb6b6b939423beccc0912b8 /graphics/inkscape
parentefd0b18cb77063cc1807ffa23749d4836009b630 (diff)
downloadfreebsd-ports-gnome-2e890be8dabad411d1d932305abb9903874de868.tar.gz
freebsd-ports-gnome-2e890be8dabad411d1d932305abb9903874de868.tar.zst
freebsd-ports-gnome-2e890be8dabad411d1d932305abb9903874de868.zip
Add inkscape 0.35, a program seeks to become a full featured open
source SVG editor.
Diffstat (limited to 'graphics/inkscape')
-rw-r--r--graphics/inkscape/Makefile35
-rw-r--r--graphics/inkscape/distinfo1
-rw-r--r--graphics/inkscape/files/patch-configure28
-rw-r--r--graphics/inkscape/files/patch-src::dialogs::stroke-style.c19
-rw-r--r--graphics/inkscape/files/patch-src::interface.c33
-rw-r--r--graphics/inkscape/files/patch-src::main.c20
-rw-r--r--graphics/inkscape/files/patch-src::xml::repr-io.c14
-rw-r--r--graphics/inkscape/pkg-descr9
-rw-r--r--graphics/inkscape/pkg-plist216
9 files changed, 375 insertions, 0 deletions
diff --git a/graphics/inkscape/Makefile b/graphics/inkscape/Makefile
new file mode 100644
index 000000000000..4ca2afc2a50e
--- /dev/null
+++ b/graphics/inkscape/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: inkscape
+# Date created: 17 Nov 2003
+# Whom: Alexander Nedotsukov <bland@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= inkscape
+PORTVERSION= 0.35
+CATEGORIES= graphics gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A program seeks to become a full featured open source SVG editor
+
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_GNOME= gnomeprefix gnomehack libglade2 libartlgpl2 libgnomeprintui
+USE_REINPLACE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --with-popt
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+MAN1= inkscape.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|g' \
+ ${WRKSRC}/src/helper/action.c \
+ ${WRKSRC}/src/libarikkei/arikkei-token.c
+
+.include <bsd.port.mk>
diff --git a/graphics/inkscape/distinfo b/graphics/inkscape/distinfo
new file mode 100644
index 000000000000..6845a3b0958b
--- /dev/null
+++ b/graphics/inkscape/distinfo
@@ -0,0 +1 @@
+MD5 (inkscape-0.35.tar.gz) = 5c91e4bf26f7894c794b430fcce1a70f
diff --git a/graphics/inkscape/files/patch-configure b/graphics/inkscape/files/patch-configure
new file mode 100644
index 000000000000..a3c7f3eae335
--- /dev/null
+++ b/graphics/inkscape/files/patch-configure
@@ -0,0 +1,28 @@
+--- configure.orig Fri Jun 20 11:55:40 2003
++++ configure Fri Jun 20 11:57:22 2003
+@@ -3094,6 +3094,9 @@
+ echo "${ECHO_T}$am_cv_CC_dependencies_compiler_type" >&6
+ CCDEPMODE=depmode=$am_cv_CC_dependencies_compiler_type
+
++_CPPFLAGS="$CPPFLAGS"
++CPPFLAGS="$CPPFLAGS `gnome-config --cflags print`"
++
+
+
+ if
+@@ -3168,6 +3171,7 @@
+ fi
+
+
++CPPFLAGS="$_CPPFLAGS"
+
+ ac_ext=c
+ ac_cpp='$CPP $CPPFLAGS'
+@@ -15765,6 +15769,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/graphics/inkscape/files/patch-src::dialogs::stroke-style.c b/graphics/inkscape/files/patch-src::dialogs::stroke-style.c
new file mode 100644
index 000000000000..1e81fa7945c5
--- /dev/null
+++ b/graphics/inkscape/files/patch-src::dialogs::stroke-style.c
@@ -0,0 +1,19 @@
+--- src/dialogs/stroke-style.c.orig Sun Nov 16 22:49:08 2003
++++ src/dialogs/stroke-style.c Sun Nov 16 22:50:27 2003
+@@ -537,6 +537,7 @@
+ {
+ GtkWidget *spw, *f, *t, *l, *hb, *sb, *us, *tb, *px, *ds;
+ GtkObject *a;
++ SPDesktop *desktop;
+
+ spw = sp_widget_new_global (INKSCAPE);
+
+@@ -678,7 +679,7 @@
+ gtk_signal_connect (GTK_OBJECT (spw), "change_selection", GTK_SIGNAL_FUNC (sp_stroke_style_line_change_selection), NULL);
+ gtk_signal_connect (GTK_OBJECT (spw), "attr_changed", GTK_SIGNAL_FUNC (sp_stroke_style_line_attr_changed), NULL);
+
+- SPDesktop *desktop = inkscape_active_desktop();
++ desktop = inkscape_active_desktop();
+ sp_stroke_style_line_update (SP_WIDGET (spw), desktop ? SP_DT_SELECTION (desktop) : NULL);
+ // sp_stroke_style_line_update (SP_WIDGET (spw), SP_ACTIVE_DESKTOP ? SP_DT_SELECTION (SP_ACTIVE_DESKTOP) : NULL);
+
diff --git a/graphics/inkscape/files/patch-src::interface.c b/graphics/inkscape/files/patch-src::interface.c
new file mode 100644
index 000000000000..59537af08739
--- /dev/null
+++ b/graphics/inkscape/files/patch-src::interface.c
@@ -0,0 +1,33 @@
+--- src/interface.c.orig Sun Nov 16 22:55:27 2003
++++ src/interface.c Sun Nov 16 22:57:29 2003
+@@ -299,10 +299,12 @@
+ SP_VERB_LAST
+ };
+
++ GtkWidget *item_recent, *menu_recent;
++
+ sp_ui_menu_append (fm, file_verbs_one);
+
+- GtkWidget *item_recent = sp_ui_menu_append_item (fm, NULL, _("Open Recent"), NULL, NULL);
+- GtkWidget *menu_recent = gtk_menu_new ();
++ item_recent = sp_ui_menu_append_item (fm, NULL, _("Open Recent"), NULL, NULL);
++ menu_recent = gtk_menu_new ();
+ sp_menu_append_recent_documents (GTK_WIDGET (menu_recent));
+ gtk_menu_item_set_submenu (GTK_MENU_ITEM (item_recent), menu_recent);
+
+@@ -472,11 +474,13 @@
+ static void
+ sp_ui_populate_main_menu(GtkWidget *m)
+ {
++ GtkWidget *item_recent, *menu_recent;
++
+ sp_ui_menu_append_item (GTK_MENU (m), GTK_STOCK_NEW, _("New"), G_CALLBACK(sp_file_new), NULL);
+ sp_ui_menu_append_item (GTK_MENU (m), GTK_STOCK_OPEN, _("Open"), G_CALLBACK(sp_file_open_dialog), NULL);
+
+- GtkWidget *item_recent = sp_ui_menu_append_item (GTK_MENU (m), NULL, _("Open Recent"), NULL, NULL);
+- GtkWidget *menu_recent = gtk_menu_new ();
++ item_recent = sp_ui_menu_append_item (GTK_MENU (m), NULL, _("Open Recent"), NULL, NULL);
++ menu_recent = gtk_menu_new ();
+
+ sp_menu_append_recent_documents (GTK_WIDGET (menu_recent));
+ gtk_menu_item_set_submenu (GTK_MENU_ITEM (item_recent), menu_recent);
diff --git a/graphics/inkscape/files/patch-src::main.c b/graphics/inkscape/files/patch-src::main.c
new file mode 100644
index 000000000000..7e0e3b8d5982
--- /dev/null
+++ b/graphics/inkscape/files/patch-src::main.c
@@ -0,0 +1,20 @@
+--- src/main.c.orig Sun Apr 15 16:27:51 2001
++++ src/main.c Thu May 30 23:14:44 2002
+@@ -17,7 +17,7 @@
+ #include <tree.h> /* libxml */
+
+ #ifdef __FreeBSD__
+-#include <floatingpoint.h>
++#include <ieeefp.h>
+ #endif
+
+ #include "sodipodi-private.h"
+@@ -357,7 +357,7 @@
+
+ }
+
+-#ifdef __FreeBSD__
++#if defined(__FreeBSD__) && defined(__i386__)
+ fpresetsticky(FP_X_DZ|FP_X_INV);
+ fpsetmask(FP_X_DZ|FP_X_INV);
+ #endif
diff --git a/graphics/inkscape/files/patch-src::xml::repr-io.c b/graphics/inkscape/files/patch-src::xml::repr-io.c
new file mode 100644
index 000000000000..78e3fdb9dd4d
--- /dev/null
+++ b/graphics/inkscape/files/patch-src::xml::repr-io.c
@@ -0,0 +1,14 @@
+
+$FreeBSD: /tmp/pcvs/ports/graphics/inkscape/files/Attic/patch-src::xml::repr-io.c,v 1.1 2003-11-17 04:03:39 bland Exp $
+
+--- src/xml/repr-io.c 2001/11/22 15:20:50 1.1
++++ src/xml/repr-io.c 2001/11/22 15:21:18
+@@ -1,6 +1,8 @@
+ #define SP_REPR_IO_C
+
++#ifdef HAVE_MALLOC_H
+ #include <malloc.h>
++#endif
+ #include <string.h>
+ #include <stdio.h>
+ #include "repr.h"
diff --git a/graphics/inkscape/pkg-descr b/graphics/inkscape/pkg-descr
new file mode 100644
index 000000000000..fbd13814724d
--- /dev/null
+++ b/graphics/inkscape/pkg-descr
@@ -0,0 +1,9 @@
+Inkscape seeks to become a full featured open source SVG editor.
+Derived from the highly popular Sodipodi codebase, Inkscape strives
+to build full XML, SVG, and CSS2 compliance.
+
+Features include alpha blending, node editing, svg-to-png export,
+and more. Project aims for capabilities similar to Illustrator,
+CorelDraw, Visio, etc.
+
+WWW: http://www.inkscape.org
diff --git a/graphics/inkscape/pkg-plist b/graphics/inkscape/pkg-plist
new file mode 100644
index 000000000000..8b3c03f6418c
--- /dev/null
+++ b/graphics/inkscape/pkg-plist
@@ -0,0 +1,216 @@
+bin/inkscape
+lib/inkscape/extensions/SpSVG.pm
+lib/inkscape/extensions/ill2svg.pl
+lib/inkscape/extensions/roundhole
+lib/inkscape/extensions/svg_dropshadow
+share/gnome/applications/inkscape.desktop
+share/gnome/inkscape/about.svg
+share/gnome/inkscape/add.xpm
+share/gnome/inkscape/add_xml_element_node.xpm
+share/gnome/inkscape/add_xml_text_node.xpm
+share/gnome/inkscape/al_bottom_in.xpm
+share/gnome/inkscape/al_bottom_out.xpm
+share/gnome/inkscape/al_center_hor.xpm
+share/gnome/inkscape/al_center_ver.xpm
+share/gnome/inkscape/al_left_in.xpm
+share/gnome/inkscape/al_left_out.xpm
+share/gnome/inkscape/al_right_in.xpm
+share/gnome/inkscape/al_right_out.xpm
+share/gnome/inkscape/al_top_in.xpm
+share/gnome/inkscape/al_top_out.xpm
+share/gnome/inkscape/align_bc.xpm
+share/gnome/inkscape/align_bl.xpm
+share/gnome/inkscape/align_br.xpm
+share/gnome/inkscape/align_cc.xpm
+share/gnome/inkscape/align_cl.xpm
+share/gnome/inkscape/align_cr.xpm
+share/gnome/inkscape/align_tc.xpm
+share/gnome/inkscape/align_tl.xpm
+share/gnome/inkscape/align_tr.xpm
+share/gnome/inkscape/angle_180.xpm
+share/gnome/inkscape/angle_270.xpm
+share/gnome/inkscape/angle_90.xpm
+share/gnome/inkscape/angle_any.xpm
+share/gnome/inkscape/arrows_hor.xpm
+share/gnome/inkscape/arrows_ver.xpm
+share/gnome/inkscape/cap_butt.xpm
+share/gnome/inkscape/cap_round.xpm
+share/gnome/inkscape/cap_square.xpm
+share/gnome/inkscape/clear.xpm
+share/gnome/inkscape/create_new.xpm
+share/gnome/inkscape/curve.xpm
+share/gnome/inkscape/cusp.xpm
+share/gnome/inkscape/del.xpm
+share/gnome/inkscape/delete_xml_attribute.xpm
+share/gnome/inkscape/delete_xml_node.xpm
+share/gnome/inkscape/dimension_hor.xpm
+share/gnome/inkscape/dimension_ver.xpm
+share/gnome/inkscape/div.xpm
+share/gnome/inkscape/draw_arc.xpm
+share/gnome/inkscape/draw_dynahand.xpm
+share/gnome/inkscape/draw_freehand.xpm
+share/gnome/inkscape/draw_node.xpm
+share/gnome/inkscape/draw_pen.xpm
+share/gnome/inkscape/draw_rect.xpm
+share/gnome/inkscape/draw_select.xpm
+share/gnome/inkscape/draw_spiral.xpm
+share/gnome/inkscape/draw_star.xpm
+share/gnome/inkscape/draw_text.xpm
+share/gnome/inkscape/draw_zoom.xpm
+share/gnome/inkscape/dt_active.xpm
+share/gnome/inkscape/dt_inactive.xpm
+share/gnome/inkscape/duplicate.xpm
+share/gnome/inkscape/duplicate_xml_node.xpm
+share/gnome/inkscape/edge_down.xpm
+share/gnome/inkscape/edge_up.xpm
+share/gnome/inkscape/edit_copy.xpm
+share/gnome/inkscape/edit_cut.xpm
+share/gnome/inkscape/edit_delete.xpm
+share/gnome/inkscape/edit_duplicate.xpm
+share/gnome/inkscape/edit_paste.xpm
+share/gnome/inkscape/edit_redo.xpm
+share/gnome/inkscape/edit_undo.xpm
+share/gnome/inkscape/ellipse.xpm
+share/gnome/inkscape/extensions/roundhole.xpm
+share/gnome/inkscape/file_export.xpm
+share/gnome/inkscape/file_import.xpm
+share/gnome/inkscape/file_new.xpm
+share/gnome/inkscape/file_open.xpm
+share/gnome/inkscape/file_print.xpm
+share/gnome/inkscape/file_print_preview.xpm
+share/gnome/inkscape/file_save.xpm
+share/gnome/inkscape/file_save_as.xpm
+share/gnome/inkscape/fill.xpm
+share/gnome/inkscape/fill_fractal.xpm
+share/gnome/inkscape/fill_gradient.xpm
+share/gnome/inkscape/fill_none.xpm
+share/gnome/inkscape/fill_pattern.xpm
+share/gnome/inkscape/fill_radial.xpm
+share/gnome/inkscape/fill_solid.xpm
+share/gnome/inkscape/flip_hor.xpm
+share/gnome/inkscape/flip_ver.xpm
+share/gnome/inkscape/font.xpm
+share/gnome/inkscape/forward.xpm
+share/gnome/inkscape/freehand.xpm
+share/gnome/inkscape/guide_dialog.png
+share/gnome/inkscape/icons.svg
+share/gnome/inkscape/join.xpm
+share/gnome/inkscape/join_bevel.xpm
+share/gnome/inkscape/join_miter.xpm
+share/gnome/inkscape/join_round.xpm
+share/gnome/inkscape/line.xpm
+share/gnome/inkscape/line_dashed.xpm
+share/gnome/inkscape/line_doubled.xpm
+share/gnome/inkscape/line_full.xpm
+share/gnome/inkscape/lock_aspect_no.xpm
+share/gnome/inkscape/lock_aspect_yes.xpm
+share/gnome/inkscape/move.xpm
+share/gnome/inkscape/node.xpm
+share/gnome/inkscape/node_break.xpm
+share/gnome/inkscape/node_curve.xpm
+share/gnome/inkscape/node_cusp.xpm
+share/gnome/inkscape/node_delete.xpm
+share/gnome/inkscape/node_insert.xpm
+share/gnome/inkscape/node_join.xpm
+share/gnome/inkscape/node_line.xpm
+share/gnome/inkscape/node_smooth.xpm
+share/gnome/inkscape/node_symetric.xpm
+share/gnome/inkscape/object_align.xpm
+share/gnome/inkscape/object_fill.xpm
+share/gnome/inkscape/object_flip_hor.xpm
+share/gnome/inkscape/object_flip_ver.xpm
+share/gnome/inkscape/object_font.xpm
+share/gnome/inkscape/object_layout.xpm
+share/gnome/inkscape/object_reset.xpm
+share/gnome/inkscape/object_rotate.xpm
+share/gnome/inkscape/object_stroke.xpm
+share/gnome/inkscape/object_tocurve.xpm
+share/gnome/inkscape/object_trans.xpm
+share/gnome/inkscape/origin.xpm
+share/gnome/inkscape/properties_fill.xpm
+share/gnome/inkscape/properties_layout.xpm
+share/gnome/inkscape/properties_stroke.xpm
+share/gnome/inkscape/quit_nope.xpm
+share/gnome/inkscape/quit_yep.xpm
+share/gnome/inkscape/rect.xpm
+share/gnome/inkscape/reread.xpm
+share/gnome/inkscape/rotate.xpm
+share/gnome/inkscape/rotate_left.xpm
+share/gnome/inkscape/rotate_right.xpm
+share/gnome/inkscape/scale.xpm
+share/gnome/inkscape/scale_hor.xpm
+share/gnome/inkscape/scale_ver.xpm
+share/gnome/inkscape/select.xpm
+share/gnome/inkscape/selection_bot.xpm
+share/gnome/inkscape/selection_break.xpm
+share/gnome/inkscape/selection_combine.xpm
+share/gnome/inkscape/selection_down.xpm
+share/gnome/inkscape/selection_group.xpm
+share/gnome/inkscape/selection_top.xpm
+share/gnome/inkscape/selection_ungroup.xpm
+share/gnome/inkscape/selection_up.xpm
+share/gnome/inkscape/seperate_tool.xpm
+share/gnome/inkscape/set.xpm
+share/gnome/inkscape/skew.xpm
+share/gnome/inkscape/skew_hor.xpm
+share/gnome/inkscape/skew_ver.xpm
+share/gnome/inkscape/smooth.xpm
+share/gnome/inkscape/stroke.xpm
+share/gnome/inkscape/sym.xpm
+share/gnome/inkscape/text.xpm
+share/gnome/inkscape/toback.xpm
+share/gnome/inkscape/tofront.xpm
+share/gnome/inkscape/toolbox_draw.xpm
+share/gnome/inkscape/toolbox_edit.xpm
+share/gnome/inkscape/toolbox_file.xpm
+share/gnome/inkscape/toolbox_node.xpm
+share/gnome/inkscape/toolbox_object.xpm
+share/gnome/inkscape/toolbox_select.xpm
+share/gnome/inkscape/toolbox_zoom.xpm
+share/gnome/inkscape/unknown.xpm
+share/gnome/inkscape/writing_mode_lr.xpm
+share/gnome/inkscape/writing_mode_tb.xpm
+share/gnome/inkscape/zoom.xpm
+share/gnome/inkscape/zoom_1_to_1.xpm
+share/gnome/inkscape/zoom_1_to_2.xpm
+share/gnome/inkscape/zoom_2_to_1.xpm
+share/gnome/inkscape/zoom_draw.xpm
+share/gnome/inkscape/zoom_in.xpm
+share/gnome/inkscape/zoom_out.xpm
+share/gnome/inkscape/zoom_page.xpm
+share/gnome/inkscape/zoom_select.xpm
+share/gnome/pixmaps/inkscape.png
+share/locale/am/LC_MESSAGES/inkscape.mo
+share/locale/az/LC_MESSAGES/inkscape.mo
+share/locale/be/LC_MESSAGES/inkscape.mo
+share/locale/ca/LC_MESSAGES/inkscape.mo
+share/locale/cs/LC_MESSAGES/inkscape.mo
+share/locale/da/LC_MESSAGES/inkscape.mo
+share/locale/de/LC_MESSAGES/inkscape.mo
+share/locale/el/LC_MESSAGES/inkscape.mo
+share/locale/es/LC_MESSAGES/inkscape.mo
+share/locale/et/LC_MESSAGES/inkscape.mo
+share/locale/fr/LC_MESSAGES/inkscape.mo
+share/locale/ga/LC_MESSAGES/inkscape.mo
+share/locale/gl/LC_MESSAGES/inkscape.mo
+share/locale/hu/LC_MESSAGES/inkscape.mo
+share/locale/it/LC_MESSAGES/inkscape.mo
+share/locale/ja/LC_MESSAGES/inkscape.mo
+share/locale/nl/LC_MESSAGES/inkscape.mo
+share/locale/no/LC_MESSAGES/inkscape.mo
+share/locale/pl/LC_MESSAGES/inkscape.mo
+share/locale/pt/LC_MESSAGES/inkscape.mo
+share/locale/pt_BR/LC_MESSAGES/inkscape.mo
+share/locale/ru/LC_MESSAGES/inkscape.mo
+share/locale/sk/LC_MESSAGES/inkscape.mo
+share/locale/sl/LC_MESSAGES/inkscape.mo
+share/locale/sr/LC_MESSAGES/inkscape.mo
+share/locale/sr@Latn/LC_MESSAGES/inkscape.mo
+share/locale/sv/LC_MESSAGES/inkscape.mo
+share/locale/tr/LC_MESSAGES/inkscape.mo
+share/locale/uk/LC_MESSAGES/inkscape.mo
+share/locale/zh_CN/LC_MESSAGES/inkscape.mo
+@dirrm share/gnome/inkscape/extensions
+@dirrm share/gnome/inkscape
+@dirrm lib/inkscape/extensions
+@dirrm lib/inkscape