aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/k3d
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2013-08-18 00:27:24 +0800
committergerald <gerald@FreeBSD.org>2013-08-18 00:27:24 +0800
commit92621d361d009a9f1c5fbfe137cf9e878dbe34cf (patch)
treec1657d06d35b5f160b90b16620933ca757495766 /graphics/k3d
parent9e9651b8c9f8d3ec1375dfb2e0d48a491ad6c121 (diff)
downloadfreebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.tar.gz
freebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.tar.zst
freebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.zip
Replace USE_GCC=4.6+ and USE_GCC=4.4+ by USE_GCC=yes.
Right now this is a noop in the former case and a noop in the latter case unless lang/gcc44 has been installed explicitly. This puts a bit more emphasis on standardizing on a canonical version "current" GCC and makes it easier to update that canonical version by changing the default in Mk/bsd.gcc.mk and updating the lang/gcc port. That is, USE_GCC=yes means "use a decent/modern version of GCC" without having to worry about details. Approved by: portmgr (bdrewery)
Diffstat (limited to 'graphics/k3d')
-rw-r--r--graphics/k3d/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/graphics/k3d/Makefile b/graphics/k3d/Makefile
index edb627d9aea6..159d329919cf 100644
--- a/graphics/k3d/Makefile
+++ b/graphics/k3d/Makefile
@@ -37,7 +37,7 @@ USE_BZIP2= yes
USE_GL= glu
USE_GNOME= gtksourceview2
USE_DOS2UNIX= *.hpp
-USE_GCC= 4.6+
+USE_GCC= yes
USE_PYTHON= yes
USES= cmake:outsource gettext
CMAKE_ARGS= -DK3D_INTL_INCLUDE_DIRS:STRING="-I${LOCALBASE}/include" \