aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/libEGL
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-09-18 02:07:25 +0800
committerkwm <kwm@FreeBSD.org>2015-09-18 02:07:25 +0800
commitde6c33481611d149822bfb915757f0845f01d819 (patch)
treea430ad3dbd823ddb88d16ecc11a7a7035985cf79 /graphics/libEGL
parent668ef943969eb0ed94107ed0918f1ed3b789a4c2 (diff)
downloadfreebsd-ports-gnome-de6c33481611d149822bfb915757f0845f01d819.tar.gz
freebsd-ports-gnome-de6c33481611d149822bfb915757f0845f01d819.tar.zst
freebsd-ports-gnome-de6c33481611d149822bfb915757f0845f01d819.zip
Update Mesa port to 10.6.6 and add Clover.
Add beignet 1.1.0. Add clinfo, clblas, clfft and clrng. The major change is that all Mesa ports are now configured the same way. This fixes several problems and enables new features. The details are described in this blog post: http://blogs.freebsdish.org/graphics/2015/03/18/unifying-mesa-ports-configure/ The second important change is the OpenCL support. Mesa's implementation, Clover, is enabled as well as Beignet. Clover targets all Gallium drivers, only Radeon GPUs in our case. Beignet is for Intel GPUs starting with Ivy Bridge. Thanks to Johannes Dieterich, O. Hartman, and Koop Mast for their work on OpenCL! As a bonus, there are several OpenCL-based math ports added (clblas, clfft and clrng). For more information and known issues, please see https://wiki.freebsd.org/Graphics/OpenCL The third change is the removal of Mesa 9.1.7 which was installed on FreeBSD 9.3-RELEASE. There is now only one version of Mesa in the Ports tree (10.6.6) for all supported versions of FreeBSD. Other, smaller changes: * Include libosmesa into the Mesa framework; this changes libOSMesa shlib version. * bsd.mesalib.mk was renamed and split up in two files namely Makefile.common and Makefile.targets. So ports can overwrite variables set by Makefile.common and are used by Makefile.targets. * Some text in the pkg-descr files was wrong, clean it up. While here, update the WWW to the main mesa3d.org upstream page. * devel/clinfo was added, a glxinfo like program but for OpenCL. Non-x86 hardware reports are very welcome since we changed the framework quite a bit. Obtained from: Graphics team development repo.
Diffstat (limited to 'graphics/libEGL')
-rw-r--r--graphics/libEGL/Makefile43
-rw-r--r--graphics/libEGL/pkg-descr2
-rw-r--r--graphics/libEGL/pkg-plist2
3 files changed, 11 insertions, 36 deletions
diff --git a/graphics/libEGL/Makefile b/graphics/libEGL/Makefile
index bc8caf98dacb..1ef8fe5471b5 100644
--- a/graphics/libEGL/Makefile
+++ b/graphics/libEGL/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libEGL
PORTVERSION= ${MESAVERSION}
-PORTREVISION= ${LIBEGL_REVISION}
+PORTREVISION= 0
CATEGORIES= graphics
COMMENT= OpenEGL library
@@ -11,7 +11,8 @@ COMMENT= OpenEGL library
LIB_DEPENDS+= libpthread-stubs.so:${PORTSDIR}/devel/libpthread-stubs \
libexpat.so:${PORTSDIR}/textproc/expat2 \
libdevq.so:${PORTSDIR}/devel/libdevq \
- libdrm.so:${PORTSDIR}/graphics/libdrm
+ libdrm.so:${PORTSDIR}/graphics/libdrm \
+ libgbm.so:${PORTSDIR}/graphics/gbm
USE_XORG= x11 xau xcb xdmcp
@@ -20,38 +21,12 @@ USE_XORG+= glproto dri2proto xext xdamage xfixes presentproto \
xshmfence
.include <bsd.port.options.mk>
-.include "${.CURDIR}/../../graphics/libGL/bsd.mesalib.mk"
-
-.if defined(WITH_NEW_MESA)
-BUILD_WRKSRC= src/egl/drivers/dri2 src/egl/main
-INSTALL_WRKSRC= src/egl/drivers/dri2 src/egl/main
-.else
-BUILD_WRKSRC= ${WRKSRC}/src/egl
-INSTALL_WRKSRC= ${WRKSRC}/src/egl
-.endif
-
-.if defined(WITH_NEW_MESA)
-LIBEGL_REVISION= 0
-.else
-LIBEGL_REVISION= 5
-.endif
-
-.if defined(WITH_NEW_MESA)
-do-build: egl-do-build
-do-install: egl-do-install
-
-egl-do-build:
-. for dir in ${BUILD_WRKSRC}
- @(cd ${WRKSRC}/${dir}; ${DO_MAKE_BUILD} ${ALL_TARGET};)
-. endfor
-
-egl-do-install:
-. for dir in ${INSTALL_WRKSRC}
- @(cd ${WRKSRC}/${dir} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} \
- ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
-
-. endfor
-.endif
+.include "${.CURDIR}/../../graphics/libGL/Makefile.common"
+
+MESA_BUILD_WRKSRC= src/mapi src/gbm src/egl/drivers/dri2 src/egl/main
+MESA_INSTALL_WRKSRC= src/egl/drivers/dri2 src/egl/main
+
+.include "${.CURDIR}/../../graphics/libGL/Makefile.targets"
post-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/.mesa
diff --git a/graphics/libEGL/pkg-descr b/graphics/libEGL/pkg-descr
index f0ed995240bf..cab51aaa54db 100644
--- a/graphics/libEGL/pkg-descr
+++ b/graphics/libEGL/pkg-descr
@@ -1,3 +1,3 @@
This package contains the EGL utility library.
-WWW: http://www.freedesktop.org/Software/xorg
+WWW: http://mesa3d.org/
diff --git a/graphics/libEGL/pkg-plist b/graphics/libEGL/pkg-plist
index 795af9daa46b..0af82928692f 100644
--- a/graphics/libEGL/pkg-plist
+++ b/graphics/libEGL/pkg-plist
@@ -1,6 +1,6 @@
include/EGL/egl.h
include/EGL/eglext.h
-%%NEW%%include/EGL/eglextchromium.h
+include/EGL/eglextchromium.h
include/EGL/eglmesaext.h
include/EGL/eglplatform.h
include/KHR/khrplatform.h