aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/libGL
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-04-01 22:00:51 +0800
committermat <mat@FreeBSD.org>2016-04-01 22:00:51 +0800
commit148314483d3098c0d6a33944f1190842e671502f (patch)
tree78ceaf1b099c56a40c240ab46278cdf4ae9e7c01 /graphics/libGL
parent96cd8e4bc2d30db4bc3bbbf3fcdcc98121c879e0 (diff)
downloadfreebsd-ports-gnome-148314483d3098c0d6a33944f1190842e671502f.tar.gz
freebsd-ports-gnome-148314483d3098c0d6a33944f1190842e671502f.tar.zst
freebsd-ports-gnome-148314483d3098c0d6a33944f1190842e671502f.zip
Remove ${PORTSDIR}/ from dependencies, categories d, e, f, and g.
With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'graphics/libGL')
-rw-r--r--graphics/libGL/Makefile6
-rw-r--r--graphics/libGL/Makefile.common16
2 files changed, 11 insertions, 11 deletions
diff --git a/graphics/libGL/Makefile b/graphics/libGL/Makefile
index 2e5c78570ee6..4874a0824daa 100644
--- a/graphics/libGL/Makefile
+++ b/graphics/libGL/Makefile
@@ -8,9 +8,9 @@ CATEGORIES= graphics
COMMENT= OpenGL library that renders using GLX or DRI
-LIB_DEPENDS+= libdrm.so:${PORTSDIR}/graphics/libdrm \
- libglapi.so:${PORTSDIR}/graphics/libglapi \
- libexpat.so:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS+= libdrm.so:graphics/libdrm \
+ libglapi.so:graphics/libglapi \
+ libexpat.so:textproc/expat2
USE_XORG= glproto x11 xext xxf86vm xdamage xfixes dri2proto:both \
presentproto xshmfence
diff --git a/graphics/libGL/Makefile.common b/graphics/libGL/Makefile.common
index 4dd642c7bd5b..106785d76e42 100644
--- a/graphics/libGL/Makefile.common
+++ b/graphics/libGL/Makefile.common
@@ -28,8 +28,8 @@ DISTFILES= mesa-${MESADISTVERSION}${EXTRACT_SUFX}
MAINTAINER= x11@FreeBSD.org
-BUILD_DEPENDS+= makedepend:${PORTSDIR}/devel/makedepend
-LIB_DEPENDS+= libdevq.so:${PORTSDIR}/devel/libdevq
+BUILD_DEPENDS+= makedepend:devel/makedepend
+LIB_DEPENDS+= libdevq.so:devel/libdevq
USES+= compiler:c++11-lib gettext-tools gmake libtool \
pathfix pkgconfig python:2,build shebangfix tar:xz
@@ -47,7 +47,7 @@ PORTSCOUT= ignore:1
.endif
.if ${OSVERSION} < 1000033
-BUILD_DEPENDS+= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
+BUILD_DEPENDS+= ${LOCALBASE}/bin/flex:textproc/flex
CONFIGURE_ENV+= ac_cv_prog_LEX=${LOCALBASE}/bin/flex
.endif
@@ -92,7 +92,7 @@ CONFIGURE_ARGS+= --enable-gles2
${OSVERSION} >= 1002000 && ${ARCH} == i386))
# Disabled on 10.1-R i386 because of compile issues with libclc.
-BUILD_DEPENDS+= libclc>=0.0.r222830:${PORTSDIR}/devel/libclc
+BUILD_DEPENDS+= libclc>=0.0.r222830:devel/libclc
# We need the clang port too even if it is not used to compile because
# Clover needs some of the clang includes to build.
@@ -117,9 +117,9 @@ CONFIGURE_ARGS+= --disable-opencl
CONFIGURE_ARGS+= --enable-osmesa
# gallium
-BUILD_DEPENDS+= llvm${MESA_LLVM_VER}>=0:${PORTSDIR}/devel/llvm${MESA_LLVM_VER}
+BUILD_DEPENDS+= llvm${MESA_LLVM_VER}>=0:devel/llvm${MESA_LLVM_VER}
.if ${COMPONENT:Mdri} != "" || ${COMPONENT:Mclover} != "" || ${COMPONENT:Megl} != ""
-RUN_DEPENDS+= llvm${MESA_LLVM_VER}>=0:${PORTSDIR}/devel/llvm${MESA_LLVM_VER}
+RUN_DEPENDS+= llvm${MESA_LLVM_VER}>=0:devel/llvm${MESA_LLVM_VER}
.endif
CONFIGURE_ENV+= LLVM_CONFIG=${LOCALBASE}/bin/llvm-config${MESA_LLVM_VER}
@@ -134,7 +134,7 @@ CONFIGURE_ARGS+=--enable-texture-float
# only support on DragonFly. FreeBSD's drm doesn't support it.
.if ${OPSYS} == DragonFly && ${COMPONENT:Mdri} != ""
CONFIGURE_ARGS+=--enable-vdpau
-LIB_DEPENDS+= libvdpau.so:${PORTSDIR}/multimedia/libvdpau
+LIB_DEPENDS+= libvdpau.so:multimedia/libvdpau
PLIST_SUB+= VDPAU=""
.else
CONFIGURE_ARGS+=--disable-vdpau
@@ -187,6 +187,6 @@ PLIST_SUB+= ${_gd}_GDRIVER="@comment "
CONFIGURE_ARGS+=--with-gallium-drivers="${GALLIUM_DRIVERS:tl}"
.if ${OPSYS} == DragonFly
-LIB_DEPENDS+= libelf.so:${PORTSDIR}/devel/libelf
+LIB_DEPENDS+= libelf.so:devel/libelf
.endif