aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/libGL
diff options
context:
space:
mode:
authorzeising <zeising@FreeBSD.org>2013-05-25 22:37:02 +0800
committerzeising <zeising@FreeBSD.org>2013-05-25 22:37:02 +0800
commit715298b528f23a6a763e28623a4c98f1365c81ce (patch)
treecf13f962932aab3646f0af684b2923c4e0f0825b /graphics/libGL
parent0f8e632e50d273ba38d9d13f7e446a4a10d95cd4 (diff)
downloadfreebsd-ports-gnome-715298b528f23a6a763e28623a4c98f1365c81ce.tar.gz
freebsd-ports-gnome-715298b528f23a6a763e28623a4c98f1365c81ce.tar.zst
freebsd-ports-gnome-715298b528f23a6a763e28623a4c98f1365c81ce.zip
The FreeBSD x11 team proudly presents
an zeising, kwm, miwi, bapt, eadler production: Xorg 7.7 Starring: xserver 1.12.4 (new xorg only) Mesa 8.0.4, including libGL, libGLU and dri (new xorg only) libX11 1.5.0 libxcb 1.9 libdrm 2.4.42 (new xorg only) freeglut 2.8.1 Also starring: Updates to drivers and other libraries and utilities Additional notes: Change pkgconf to be a build dependency. Add a new USE_XORG, xcb, to depend on libxcb and update all ports to use this. Trim makefile headers. Take maintanership of x11/xcb-proto, ok'd by ashish. If you are running WITH_NEW_XORG=, you need to rebuild all installed drivers, see UPDATING for more information. Various fixes to make ports compile. PR: ports/177942 Exp-run by: miwi Approved by: portmgr (miwi) Thanks to all who helped testing!
Diffstat (limited to 'graphics/libGL')
-rw-r--r--graphics/libGL/Makefile2
-rw-r--r--graphics/libGL/bsd.mesalib.mk50
-rw-r--r--graphics/libGL/distinfo4
-rw-r--r--graphics/libGL/files/extra-configure24
-rw-r--r--graphics/libGL/files/extra-mach64_context.h21
-rw-r--r--graphics/libGL/files/extra-sis_context.h22
-rw-r--r--graphics/libGL/files/extra-src__mesa__drivers__dri__radeon__radeon_span.c15
-rw-r--r--graphics/libGL/pkg-plist4
8 files changed, 34 insertions, 108 deletions
diff --git a/graphics/libGL/Makefile b/graphics/libGL/Makefile
index 1557e3e82a88..012ac64369bf 100644
--- a/graphics/libGL/Makefile
+++ b/graphics/libGL/Makefile
@@ -1,4 +1,4 @@
-# Created by: anholt@FreeBSD.org
+# Created by: Eric Anholt <anholt@FreeBSD.org>
# $FreeBSD$
PORTNAME= libGL
diff --git a/graphics/libGL/bsd.mesalib.mk b/graphics/libGL/bsd.mesalib.mk
index d163e5a7dae7..6ccc9378f272 100644
--- a/graphics/libGL/bsd.mesalib.mk
+++ b/graphics/libGL/bsd.mesalib.mk
@@ -11,11 +11,9 @@
#
# - graphics/libGL
# - graphics/libGLU
-# - graphics/libGLw
# - graphics/dri
#
# $FreeBSD$
-#
.MAKE.FreeBSD_UL= yes
@@ -23,7 +21,7 @@ MESAVERSION= ${MESABASEVERSION}${MESASUBVERSION:C/^(.)/.\1/}
MESADISTVERSION=${MESABASEVERSION}${MESASUBVERSION:C/^(.)/-\1/}
.if defined(WITH_NEW_XORG)
-MESABASEVERSION= 7.11.2
+MESABASEVERSION= 8.0.5
# if there is a subversion, include the '-' between 7.11-rc2 for example.
MESASUBVERSION=
PLIST_SUB+= OLD="@comment " NEW=""
@@ -33,8 +31,8 @@ MESASUBVERSION=
PLIST_SUB+= OLD="" NEW="@comment "
.endif
-MASTER_SITES= ftp://ftp.freedesktop.org/pub/mesa/${MESABASEVERSION}/:mesa,glut
-DISTFILES= MesaLib-${MESADISTVERSION}${EXTRACT_SUFX}:mesa
+MASTER_SITES= ftp://ftp.freedesktop.org/pub/mesa/${MESABASEVERSION}/
+DISTFILES= MesaLib-${MESADISTVERSION}${EXTRACT_SUFX}
MAINTAINER?= x11@FreeBSD.org
BUILD_DEPENDS+= makedepend:${PORTSDIR}/devel/makedepend \
@@ -46,22 +44,19 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-MAKE_JOBS_UNSAFE= yes
+MAKE_JOBS_SAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+=--enable-gallium-llvm=no --without-gallium-drivers \
- --disable-egl --disable-glut
+ --disable-egl
.if defined(WITH_NEW_XORG)
EXTRA_PATCHES+= ${PATCHDIR}/extra-configure \
- ${PATCHDIR}/extra-mach64_context.h \
- ${PATCHDIR}/extra-sis_context.h \
${PATCHDIR}/extra-src-glsl_ir_constant_expression.cpp \
${PATCHDIR}/extra-src__gallium__include__pipe__p_config.h \
${PATCHDIR}/extra-src__mesa__drivers__dri__nouveau__nouveau_array.c \
- ${PATCHDIR}/extra-src__mesa__drivers__dri__nouveau__nouveau_render_t.c \
- ${PATCHDIR}/extra-src__mesa__drivers__dri__radeon__radeon_span.c
+ ${PATCHDIR}/extra-src__mesa__drivers__dri__nouveau__nouveau_render_t.c
.else
EXTRA_PATCHES+= ${PATCHDIR}/extra-configure-old \
${PATCHDIR}/extra-mach64_context.h-old \
@@ -69,12 +64,16 @@ EXTRA_PATCHES+= ${PATCHDIR}/extra-configure-old \
${PATCHDIR}/extra-src__mesa__x86-64__xform4.S \
${PATCHDIR}/extra-src__mesa__x86__glapi_x86.S \
${PATCHDIR}/extra-src__mesa__x86__read_rgba_span_x86.S
+CONFIGURE_ARGS+=--disable-glut --disable-glw
.endif
ALL_TARGET= default
-PATCHDIR= ${.CURDIR}/../../graphics/libGL/files
-WRKSRC= ${WRKDIR}/Mesa-${MESABASEVERSION}${MESASUBVERSION}
+MASTERDIR= ${.CURDIR}/../../graphics/libGL
+PATCHDIR= ${MASTERDIR}/files
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+WRKSRC= ${WRKDIR}/Mesa-${MESADISTVERSION}
.if !defined(ARCH)
ARCH!= uname -p
@@ -86,38 +85,25 @@ COMPONENT= ${PORTNAME:L:C/^lib//:C/mesa-//}
CONFIGURE_ARGS+= --disable-glu
.endif
-.if ${COMPONENT:Mglw} == ""
-CONFIGURE_ARGS+= --disable-glw
-.else
-CONFIGURE_ARGS+= --enable-motif
-.endif
-
.if ${COMPONENT:Mdri} == ""
CONFIGURE_ARGS+= --with-dri-drivers=no
+.else
+CONFIGURE_ARGS+= --with-dri-drivers="i915,i965,r200,radeon,swrast"
.endif
+.if !defined(WITH_NEW_XORG)
.if defined(WITHOUT_XCB)
CONFIGURE_ARGS+= --disable-xcb
.else
CONFIGURE_ARGS+= --enable-xcb
.endif
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|-ffast-math|${FAST_MATH}|' -e 's|x86_64|amd64|' \
- -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|[$$](INSTALL_LIB_DIR)/pkgconfig|${PREFIX}/libdata/pkgconfig|' \
${WRKSRC}/src/glu/Makefile \
- ${WRKSRC}/src/glw/Makefile \
${WRKSRC}/src/mesa/Makefile \
${WRKSRC}/src/mesa/drivers/dri/Makefile
-.if defined(WITH_NEW_XORG)
-# replace hardlinks with patched radeon_span.c
-.for i in r200 r300 r600
- @${CP} -fp ${WRKSRC}/src/mesa/drivers/dri/radeon/radeon_span.c \
- ${WRKSRC}/src/mesa/drivers/dri/${i}/
-.endfor
-.endif
-.if ${COMPONENT:Mglut} != ""
- @${REINPLACE_CMD} -e 's|[$$](INSTALL_LIB_DIR)/pkgconfig|${PREFIX}/libdata/pkgconfig|' \
- ${WRKSRC}/src/glut/glx/Makefile
-.endif
+
diff --git a/graphics/libGL/distinfo b/graphics/libGL/distinfo
index 106ab0bf5805..5ee9af26ab05 100644
--- a/graphics/libGL/distinfo
+++ b/graphics/libGL/distinfo
@@ -1,4 +1,4 @@
SHA256 (MesaLib-7.6.1.tar.bz2) = 701f0e4cb85d6298181651b780d1c0a439fadd02aad29ee6623fc05588bb8d44
SIZE (MesaLib-7.6.1.tar.bz2) = 4886995
-SHA256 (MesaLib-7.11.2.tar.bz2) = 57746aa8c60bc6f5596ec6c6c7274de40fa12edce5ec33fe899e704fa00b5357
-SIZE (MesaLib-7.11.2.tar.bz2) = 6257280
+SHA256 (MesaLib-8.0.5.tar.bz2) = 511b8da34f8e69ed24caf422964fb7ae747f3b1d8093f6b8aa2602164a475a5e
+SIZE (MesaLib-8.0.5.tar.bz2) = 5734571
diff --git a/graphics/libGL/files/extra-configure b/graphics/libGL/files/extra-configure
index fc1a68f41695..d1ae3b75e23d 100644
--- a/graphics/libGL/files/extra-configure
+++ b/graphics/libGL/files/extra-configure
@@ -1,42 +1,40 @@
---- configure.orig 2011-11-17 19:46:34.000000000 +0000
-+++ configure 2012-06-28 12:53:09.000000000 +0000
-@@ -7817,10 +7817,35 @@
- DEFINES="$DEFINES -DGLX_DIRECT_RENDERING"
- fi
+--- configure.orig 2012-07-10 17:30:46.000000000 +0200
++++ configure 2012-09-01 13:27:22.000000000 +0200
+@@ -9017,9 +9017,34 @@
+ DEFINES="$DEFINES -DPTHREADS -DUSE_EXTERNAL_DXTN_LIB=1"
+ DEFINES="$DEFINES -DIN_DRI_DRIVER -DHAVE_ALIAS"
- if test "x$DRI_DIRS" = "xyes"; then
-- DRI_DIRS="i810 i915 i965 mach64 mga nouveau r128 r200 r300 r600 \
-- radeon tdfx unichrome savage sis swrast"
+- DRI_DIRS="i915 i965 nouveau r200 radeon swrast"
- fi
+ case "$host_cpu" in
+ x86_64)
+ # i810 is missing because there is no x86-64 system where it
+ # could *ever* be used.
+ if test "x$DRI_DIRS" = "xyes"; then
-+ DRI_DIRS="i915 i965 mach64 mga nouveau r128 r200 r300 r600 \
-+ radeon savage tdfx unichrome sis swrast"
++ DRI_DIRS="i915 i965 nouveau r200 radeon swrast"
+ fi
+ ;;
+ i*86)
+ if test "x$DRI_DIRS" = "xyes"; then
-+ DRI_DIRS="i810 i915 i965 mach64 mga nouveau r128 r200 r300 \
-+ r600 radeon savage tdfx unichrome sis swrast"
++ DRI_DIRS="i915 i965 nouveau r200 radeon swrast"
+ fi
+ ;;
+ powerpc*)
+ # Build only the drivers for cards that exist on PowerPC.
+ # At some point MGA will be added, but not yet.
+ if test "x$DRI_DIRS" = "xyes"; then
-+ DRI_DIRS="mach64 r128 r200 r300 r600 radeon tdfx swrast"
++ DRI_DIRS="r200 radeon swrast"
+ fi
+ ;;
+ sparc*)
+ # Build only the drivers for cards that exist on SPARC.
+ if test "x$DRI_DIRS" = "xyes"; then
-+ DRI_DIRS="mach64 r128 r200 r300 r600 radeon swrast"
++ DRI_DIRS="r200 radeon swrast"
+ fi
+ ;;
+ esac
++
;;
gnu*)
DEFINES="$DEFINES -DUSE_EXTERNAL_DXTN_LIB=1 -DIN_DRI_DRIVER"
diff --git a/graphics/libGL/files/extra-mach64_context.h b/graphics/libGL/files/extra-mach64_context.h
deleted file mode 100644
index f844599bfa68..000000000000
--- a/graphics/libGL/files/extra-mach64_context.h
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/mesa/drivers/dri/mach64/mach64_context.h.orig 2011-05-13 01:47:18.000000000 +0200
-+++ src/mesa/drivers/dri/mach64/mach64_context.h 2011-07-27 09:59:53.000000000 +0200
-@@ -289,7 +289,7 @@
- /* ================================================================
- * Byte ordering
- */
--#if MESA_LITTLE_ENDIAN == 1
-+#if defined(MESA_LITTLE_ENDIAN) && MESA_LITTLE_ENDIAN == 1
- #define LE32_IN( x ) ( *(GLuint *)(x) )
- #define LE32_IN_FLOAT( x ) ( *(GLfloat *)(x) )
- #define LE32_OUT( x, y ) do { *(GLuint *)(x) = (y); } while (0)
-@@ -298,6 +298,9 @@
- #if defined(__OpenBSD__) || defined(__NetBSD__)
- #include <machine/endian.h>
- #define bswap_32 bswap32
-+#elif defined(__FreeBSD__)
-+#include <sys/endian.h>
-+#define bswap_32 bswap32
- #else
- #include <byteswap.h>
- #endif
diff --git a/graphics/libGL/files/extra-sis_context.h b/graphics/libGL/files/extra-sis_context.h
deleted file mode 100644
index 0e16f51c0a10..000000000000
--- a/graphics/libGL/files/extra-sis_context.h
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/mesa/drivers/dri/sis/sis_context.h.orig 2010-12-14 22:43:15.000000000 +0100
-+++ src/mesa/drivers/dri/sis/sis_context.h 2011-07-27 09:58:22.000000000 +0200
-@@ -400,10 +400,18 @@
- #define MMIO_READ(reg) *(volatile GLint *)(smesa->IOBase + (reg))
- #define MMIO_READf(reg) *(volatile GLfloat *)(smesa->IOBase + (reg))
-
--#if defined(__i386__) || defined(__x86_64__)
-+#if defined(__i386__) || defined(__x86_64__) || defined(__amd64__)
- #define MMIO_WMB() __asm __volatile("" : : : "memory")
- #elif defined(__ia64__)
- #define MMIO_WMB() __asm __volatile("mf" : : : "memory")
-+#elif defined(__powerpc__)
-+#define MMIO_WMB() __asm __volatile("eieio" : : : "memory")
-+#elif defined(__sparc64__)
-+/*
-+ * #StoreStore probably would be sufficient for this driver at the
-+ * time of this writing but we use #Sync for safety.
-+ */
-+#define MMIO_WMB() __asm __volatile("membar #Sync" : : : "memory")
- #else
- #error platform needs WMB
- #endif
diff --git a/graphics/libGL/files/extra-src__mesa__drivers__dri__radeon__radeon_span.c b/graphics/libGL/files/extra-src__mesa__drivers__dri__radeon__radeon_span.c
deleted file mode 100644
index 3a186e98d644..000000000000
--- a/graphics/libGL/files/extra-src__mesa__drivers__dri__radeon__radeon_span.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/mesa/drivers/dri/radeon/radeon_span.c.orig 2011-07-09 03:37:10.000000000 +0200
-+++ src/mesa/drivers/dri/radeon/radeon_span.c 2012-06-28 21:44:07.000000000 +0200
-@@ -55,7 +55,11 @@
- #include <byteswap.h>
- #define CPU_TO_LE16( x ) bswap_16( x )
- #define LE16_TO_CPU( x ) bswap_16( x )
--#endif /* __linux__ */
-+#elif defined(__FreeBSD__)
-+#include <sys/endian.h>
-+#define CPU_TO_LE16( x ) bswap16( x )
-+#define LE16_TO_CPU( x ) bswap16( x )
-+#endif
- #else
- #define CPU_TO_LE16( x ) ( x )
- #define LE16_TO_CPU( x ) ( x )
diff --git a/graphics/libGL/pkg-plist b/graphics/libGL/pkg-plist
index 3204b097462c..e24cff6cd396 100644
--- a/graphics/libGL/pkg-plist
+++ b/graphics/libGL/pkg-plist
@@ -3,11 +3,11 @@
include/GL/gl.h
include/GL/gl_mangle.h
include/GL/glext.h
-include/GL/glfbdev.h
+%%OLD%%include/GL/glfbdev.h
include/GL/glx.h
include/GL/glx_mangle.h
include/GL/glxext.h
-include/GL/mesa_wgl.h
+%%OLD%%include/GL/mesa_wgl.h
%%OLD%%include/GL/mglmesa.h
include/GL/osmesa.h
%%OLD%%include/GL/svgamesa.h