aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/libdv/Makefile
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2001-11-20 03:35:04 +0800
committerlioux <lioux@FreeBSD.org>2001-11-20 03:35:04 +0800
commit85006ea1e41dcac650f853ef4ca8bfb71e472d80 (patch)
tree42f8936105b1ff05f6c9fe7e2da0ec2a5c17f346 /graphics/libdv/Makefile
parent0281522a0929fe09188fb1ac10b4a5b6b2460ef8 (diff)
downloadfreebsd-ports-gnome-85006ea1e41dcac650f853ef4ca8bfb71e472d80.tar.gz
freebsd-ports-gnome-85006ea1e41dcac650f853ef4ca8bfb71e472d80.tar.zst
freebsd-ports-gnome-85006ea1e41dcac650f853ef4ca8bfb71e472d80.zip
New port libdv version 0.9: Quasar DV codec (libdv): software codec
for DV video encoding format Reviewed by: petef
Diffstat (limited to 'graphics/libdv/Makefile')
-rw-r--r--graphics/libdv/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/graphics/libdv/Makefile b/graphics/libdv/Makefile
new file mode 100644
index 000000000000..ba2f16bfdd01
--- /dev/null
+++ b/graphics/libdv/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: libdv
+# Date created: Sun Nov 18 19:42:02 BRST 2001
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libdv
+PORTVERSION= 0.9
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= lioux@FreeBSD.org
+
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ popt.0:${PORTSDIR}/devel/popt \
+ SDL-1.1.3:${PORTSDIR}/devel/sdl12
+
+USE_GTK= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include \
+ -I${X11BASE}/include `${GTK_CONFIG} --cflags` \
+ `${GDK_PIXBUF_CONFIG} --cflags`" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -L${X11BASE}/lib \
+ `${GTK_CONFIG} --libs` `${GDK_PIXBUF_CONFIG} --libs`"
+CONFIGURE_ARGS= --with-sdl-prefix="${LOCALBASE}"
+INSTALLS_SHLIB= yes
+
+MAN1= encodedv.1 playdv.1
+
+GDK_PIXBUF_CONFIG?=${X11BASE}/bin/gdk-pixbuf-config
+
+post-configure:
+ @find ${WRKSRC} -type f -name Makefile -exec \
+ ${PERL} -pi.orig -ne 's!-l(gdk|glib|gtk) !!g' {} \;
+
+post-install:
+.ifndef(NOPORTDOCS)
+.endif
+
+.include <bsd.port.mk>