aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/libecwj2
diff options
context:
space:
mode:
authorvsevolod <vsevolod@FreeBSD.org>2013-12-21 08:17:40 +0800
committervsevolod <vsevolod@FreeBSD.org>2013-12-21 08:17:40 +0800
commit292b974f5cf460efef95b30be80302961e694e71 (patch)
treeb03faa4c9bb4801f0cc300729ba8a83c81709b44 /graphics/libecwj2
parenta865f8cba3b4a3afb3813efa70c77cad840c2345 (diff)
downloadfreebsd-ports-gnome-292b974f5cf460efef95b30be80302961e694e71.tar.gz
freebsd-ports-gnome-292b974f5cf460efef95b30be80302961e694e71.tar.zst
freebsd-ports-gnome-292b974f5cf460efef95b30be80302961e694e71.zip
- Fix build with the recent clang/gcc [1]
- Support staging PR: 185042 [1] Submitted by: Christoph Moench-Tegeder <cmt at burggraben.net> [1] Approved by: maintainer [1]
Diffstat (limited to 'graphics/libecwj2')
-rw-r--r--graphics/libecwj2/Makefile4
-rw-r--r--graphics/libecwj2/files/patch-Source-C-NCSnet-NCScnet3-NCSProxy.h11
-rw-r--r--graphics/libecwj2/files/patch-Source-NCSBuildGnu-Makefile.in21
3 files changed, 28 insertions, 8 deletions
diff --git a/graphics/libecwj2/Makefile b/graphics/libecwj2/Makefile
index 7980ce91f458..0013b9b3f9ba 100644
--- a/graphics/libecwj2/Makefile
+++ b/graphics/libecwj2/Makefile
@@ -18,9 +18,9 @@ USE_ZIP= yes
USE_AUTOTOOLS= libtool autoconf
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-NO_STAGE= yes
+USES= gmake
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 800000
diff --git a/graphics/libecwj2/files/patch-Source-C-NCSnet-NCScnet3-NCSProxy.h b/graphics/libecwj2/files/patch-Source-C-NCSnet-NCScnet3-NCSProxy.h
new file mode 100644
index 000000000000..5a963dbeb168
--- /dev/null
+++ b/graphics/libecwj2/files/patch-Source-C-NCSnet-NCScnet3-NCSProxy.h
@@ -0,0 +1,11 @@
+--- Source/C/NCSnet/NCScnet3/NCSProxy.h.orig 2013-12-20 19:22:52.000000000 +0100
++++ Source/C/NCSnet/NCScnet3/NCSProxy.h 2013-12-20 19:23:26.000000000 +0100
+@@ -35,6 +35,7 @@
+ //#include <streambuf>
+ #include <iostream>
+ #include <sstream>
++#include <unistd.h>
+ #include <ctype.h>
+ #include <assert.h>
+ #include <string>
+
diff --git a/graphics/libecwj2/files/patch-Source-NCSBuildGnu-Makefile.in b/graphics/libecwj2/files/patch-Source-NCSBuildGnu-Makefile.in
index 68cbdd35d593..c4d5ae2a863f 100644
--- a/graphics/libecwj2/files/patch-Source-NCSBuildGnu-Makefile.in
+++ b/graphics/libecwj2/files/patch-Source-NCSBuildGnu-Makefile.in
@@ -1,5 +1,5 @@
---- Source/NCSBuildGnu/Makefile.in.orig 2006-08-29 11:57:09.000000000 +0400
-+++ Source/NCSBuildGnu/Makefile.in 2010-07-29 19:56:41.000000000 +0400
+--- Source/NCSBuildGnu/Makefile.in.orig 2006-08-29 08:57:09.000000000 +0100
++++ Source/NCSBuildGnu/Makefile.in 2013-12-21 00:03:30.000000000 +0000
@@ -246,22 +246,6 @@
../C/NCSEcw/shared_src/qmf_util.c \
../C/NCSEcw/shared_src/quantize.c \
@@ -96,7 +96,16 @@
@AMDEP_TRUE@ ./$(DEPDIR)/collapse_pyr.Plo \
@AMDEP_TRUE@ ./$(DEPDIR)/compress.Plo ./$(DEPDIR)/dynamiclib.Plo \
@AMDEP_TRUE@ ./$(DEPDIR)/ecw_open.Plo ./$(DEPDIR)/ecw_read.Plo \
-@@ -1321,22 +1262,6 @@
+@@ -1036,8 +977,6 @@
+ @list='$(lib_LIBRARIES)'; for p in $$list; do \
+ if test -f $$p; then \
+ p="`echo $$p | sed -e 's|^.*/||'`"; \
+- echo " $(RANLIB) $(DESTDIR)$(libdir)/$$p"; \
+- $(RANLIB) $(DESTDIR)$(libdir)/$$p; \
+ else :; fi; \
+ done
+
+@@ -1321,22 +1260,6 @@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/______lib_libecwj2_a-NCSWorldFile.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/______lib_libecwj2_a-NCScnet.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/______lib_libecwj2_a-build_pyr.Po@am__quote@
@@ -119,7 +128,7 @@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/______lib_libecwj2_a-collapse_pyr.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/______lib_libecwj2_a-compress.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/______lib_libecwj2_a-dynamiclib.Po@am__quote@
-@@ -1364,22 +1289,6 @@
+@@ -1364,22 +1287,6 @@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/______lib_libecwj2_a-unpack.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/______lib_libecwj2_a-util.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/build_pyr.Plo@am__quote@
@@ -142,7 +151,7 @@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/collapse_pyr.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/compress.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/dynamiclib.Plo@am__quote@
-@@ -1935,534 +1844,6 @@
+@@ -1935,534 +1842,6 @@
@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
@am__fastdepCC_FALSE@ $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(______lib_libecwj2_a_CPPFLAGS) $(CPPFLAGS) $(______lib_libecwj2_a_CFLAGS) $(CFLAGS) -c -o ______lib_libecwj2_a-unpack.lo `test -f '../C/NCSEcw/shared_src/unpack.c' || echo '$(srcdir)/'`../C/NCSEcw/shared_src/unpack.c
@@ -677,7 +686,7 @@
______lib_libecwj2_a-dynamiclib.o: ../C/NCSUtil/dynamiclib.c
@am__fastdepCC_TRUE@ if $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(______lib_libecwj2_a_CPPFLAGS) $(CPPFLAGS) $(______lib_libecwj2_a_CFLAGS) $(CFLAGS) -MT ______lib_libecwj2_a-dynamiclib.o -MD -MP -MF "$(DEPDIR)/______lib_libecwj2_a-dynamiclib.Tpo" \
@am__fastdepCC_TRUE@ -c -o ______lib_libecwj2_a-dynamiclib.o `test -f '../C/NCSUtil/dynamiclib.c' || echo '$(srcdir)/'`../C/NCSUtil/dynamiclib.c; \
-@@ -3288,534 +2669,6 @@
+@@ -3288,534 +2667,6 @@
@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
@am__fastdepCC_FALSE@ $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -c -o unpack.lo `test -f '../C/NCSEcw/shared_src/unpack.c' || echo '$(srcdir)/'`../C/NCSEcw/shared_src/unpack.c