aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/libggi/files
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2003-12-09 08:01:39 +0800
committerpav <pav@FreeBSD.org>2003-12-09 08:01:39 +0800
commit67cc439e7a4f899051257c6a2e42a67de82f9456 (patch)
treea138a7147b4ae12b6bcc34e5f368f949bba8a927 /graphics/libggi/files
parent5aa27907af8d9ffeb8a2b2bd68426f9be2d8bd69 (diff)
downloadfreebsd-ports-gnome-67cc439e7a4f899051257c6a2e42a67de82f9456.tar.gz
freebsd-ports-gnome-67cc439e7a4f899051257c6a2e42a67de82f9456.tar.zst
freebsd-ports-gnome-67cc439e7a4f899051257c6a2e42a67de82f9456.zip
- Enable xf86dga
- Get rid of libtool archives - Bump portrevision PR: ports/52380 Submitted by: Pedro F. Giffuni <giffunip@yahoo.com>
Diffstat (limited to 'graphics/libggi/files')
-rw-r--r--graphics/libggi/files/patch-configure.in174
-rw-r--r--graphics/libggi/files/patch-display-xf86dga-XF86VMode.c13
-rw-r--r--graphics/libggi/files/patch-ltmain.sh23
3 files changed, 210 insertions, 0 deletions
diff --git a/graphics/libggi/files/patch-configure.in b/graphics/libggi/files/patch-configure.in
new file mode 100644
index 000000000000..3576c99046ea
--- /dev/null
+++ b/graphics/libggi/files/patch-configure.in
@@ -0,0 +1,174 @@
+--- configure.in.orig Sun Aug 17 17:28:49 2003
++++ configure.in Sun Aug 17 17:29:44 2003
+@@ -30,6 +30,11 @@
+ dnl Common useable Targets
+ build_x_target="auto"
+ build_xlib_target="no"
++build_x_dbe_target="auto"
++build_x_evi_target="auto"
++build_x_shm_target="auto"
++build_x_xf86dga_target="auto"
++build_x_xf86vmode_target="auto"
+ build_file_target="auto"
+ build_kgi_target="no"
+ build_libkgi_target="no"
+@@ -276,6 +281,25 @@
+ linux/kdev_t.h linux/major.h glide.h glide/glide.h kgimon.h sys/un.h \
+ sys/socket.h netinet/in.h netdb.h windows.h ddraw.h vgl.h)
+
++
++dnl ========================================================================
++dnl Check header files dependencies.
++
++dnl Disable targets requiring non-existing headers
++if test "x$ac_cv_header_sys_shm_h" != "xyes"; then
++ build_x_shm_target="no"
++ build_ipc_target="no"
++dnl TODO:
++dnl Disable programs/demos/wrap.c here
++fi
++
++if test "x$ac_cv_header_sys_ipc_h" != "xyes"; then
++ build_ipc_target="no"
++dnl TODO:
++dnl Disable programs/demos/wrap.c here
++fi
++
++
+ dnl ========================================================================
+ dnl LibGII must be built
+
+@@ -349,6 +373,11 @@
+
+
+ dnl ========================================================================
++dnl Check function dependencies.
++
++dnl TODO: Disable targets requiring non-existing functions.
++
++dnl ========================================================================
+ dnl Checks whether to compile in various SWARs
+
+ if test "x$do_noswar" = "xyes"; then
+@@ -624,15 +653,18 @@
+
+
+ dnl This is necessary as there are plattforms, where
+-dnl $ac_x_includes does NOT belong to the default search
++dnl $(ac_)x_includes does NOT belong to the default search
+ dnl path. Darwin is such a system, for example.
+-dnl $ac_x_includes contains the right path to the X
++dnl $(ac_)x_includes contains the right path to the X
+ dnl includes (/usr/X11R6/include on most systems).
+
+ cflags_old="$CFLAGS"
+ cppflags_old="$CPPFLAGS"
+- CFLAGS="$CFLAGS -I$ac_x_includes"
+- CPPFLAGS="$CPPFLAGS -I$ac_x_includes"
++ if test -z "$x_includes" -o "x$x_includes" = "xNONE"; then
++ x_includes="$ac_x_includes"
++ fi
++ CFLAGS="$CFLAGS -I$x_includes"
++ CPPFLAGS="$CPPFLAGS -I$x_includes"
+
+ AC_CHECK_HEADERS(X11/extensions/xf86dga.h \
+ X11/extensions/Xdbe.h \
+@@ -642,6 +674,22 @@
+ CFLAGS="$cflags_old"
+ CPPFLAGS="$cppflags_old"
+
++ if test "x$ac_cv_header_X11_extensions_Xdbe_h" != "xyes"; then
++ build_x_dbe_target="no"
++ fi
++ if test "x$ac_cv_header_X11_extensions_XEVI_h" != "xyes"; then
++ build_x_evi_target="no"
++ fi
++ if test "x$ac_cv_header_X11_extensions_XShm_h" != "xyes"; then
++ build_x_shm_target="no"
++ fi
++ if test "x$ac_cv_header_X11_extensions_xf86dga_h" != "xyes"; then
++ build_x_xf86dga_target="no"
++ fi
++ if test "x$ac_cv_header_X11_extensions_xf86vmode_h" != "xyes"; then
++ build_x_xf86vmode_target="no"
++ fi
++
+ x_helper_xf86dga_libs=""
+ x_helper_xf86vm_libs=""
+
+@@ -649,7 +697,7 @@
+ x_helper_xf86dga_libs="-lXxf86dga_pic",
+ AC_CHECK_LIB(Xxf86dga, XF86DGAQueryVersion,
+ x_helper_xf86dga_libs="-lXxf86dga",
+- ac_cv_header_X11_extensions_xf86dga_h=no,
++ build_x_xf86dga_target=no,
+ [ $X_LIBS -lXext -lX11 $X_EXTRA_LIBS ]),
+ [ $X_LIBS -lXext -lX11 $X_EXTRA_LIBS ])
+
+@@ -657,7 +705,7 @@
+ x_helper_xf86vm_libs="-lXxf86vm_pic",
+ AC_CHECK_LIB(Xxf86vm, XF86VidModeSwitchToMode,
+ x_helper_xf86vm_libs="-lXxf86vm",
+- ac_cv_header_X11_extensions_xf86vmode_h=no,
++ build_x_xf86vmode_target=no,
+ [ $X_LIBS -lXext -lX11 $X_EXTRA_LIBS ]),
+ [ $X_LIBS -lXext -lX11 $X_EXTRA_LIBS ])
+ fi
+@@ -699,8 +747,10 @@
+
+ if test "x$build_kgi_target" != "xno"; then
+ AC_TRY_COMPILE([
+-#include "kgi/config.h"
+-#include <kgi/system.h>
++#ifndef __FreeBSD__
++# include "kgi/config.h"
++# include <kgi/system.h>
++#endif
+ #include <kgi/kgi.h>
+ ],[
+ kgi_u32_t i;
+@@ -827,7 +877,7 @@
+ AC_MSG_RESULT(yes)
+
+ AC_MSG_CHECKING(if we should build support for DoubleBuffer extension for x target)
+- if test "x$ac_cv_header_X11_extensions_Xdbe_h" != "xyes"; then
++ if test "x$build_x_dbe_target" = "xno"; then
+ AC_MSG_RESULT(no)
+ else
+ XSUBDIRS="$XSUBDIRS dbe"
+@@ -835,7 +885,7 @@
+ fi
+
+ AC_MSG_CHECKING(if we should build support for Extended Visual Information extension for x target)
+- if test "x$ac_cv_header_X11_extensions_XEVI_h" != "xyes"; then
++ if test "x$build_x_evi_target" = "xno"; then
+ AC_MSG_RESULT(no)
+ else
+ XSUBDIRS="$XSUBDIRS evi"
+@@ -843,7 +893,7 @@
+ fi
+
+ AC_MSG_CHECKING(if we should build support for MIT-SHM extension for x target)
+- if test "x$ac_cv_header_X11_extensions_XShm_h" != "xyes"; then
++ if test "x$build_x_shm_target" = "xno"; then
+ AC_MSG_RESULT(no)
+ else
+ XSUBDIRS="$XSUBDIRS shm"
+@@ -851,7 +901,7 @@
+ fi
+
+ AC_MSG_CHECKING(if we should build support for xf86dga extension for x target)
+- if test "x$ac_cv_header_X11_extensions_xf86dga_h" != "xyes"; then
++ if test "x$build_x_xf86dga_target" = "xno"; then
+ AC_MSG_RESULT(no)
+ else
+ XSUBDIRS="$XSUBDIRS dga"
+@@ -859,7 +909,7 @@
+ fi
+
+ AC_MSG_CHECKING(if we should build support for XF86 Vidmode extension for x target)
+- if test "x$ac_cv_header_X11_extensions_xf86vmode_h" != "xyes"; then
++ if test "x$build_x_xf86vmode_target" = "xno"; then
+ AC_MSG_RESULT(no)
+ else
+ XSUBDIRS="$XSUBDIRS vidmode"
diff --git a/graphics/libggi/files/patch-display-xf86dga-XF86VMode.c b/graphics/libggi/files/patch-display-xf86dga-XF86VMode.c
new file mode 100644
index 000000000000..79a51f583bc1
--- /dev/null
+++ b/graphics/libggi/files/patch-display-xf86dga-XF86VMode.c
@@ -0,0 +1,13 @@
+--- display/xf86dga/XF86VMode.c.orig Wed Jan 15 09:29:40 2003
++++ display/xf86dga/XF86VMode.c Tue Dec 9 00:20:08 2003
+@@ -36,6 +36,10 @@
+
+ /* THIS IS NOT AN X CONSORTIUM STANDARD */
+
++#include <sys/types.h>
++#include <sys/time.h>
++#include <unistd.h>
++
+ #define _POSIX_C_SOURCE 199309L
+ #if !defined (__OpenBSD__)
+ #define _POSIX_SOURCE
diff --git a/graphics/libggi/files/patch-ltmain.sh b/graphics/libggi/files/patch-ltmain.sh
new file mode 100644
index 000000000000..0c9089ac359a
--- /dev/null
+++ b/graphics/libggi/files/patch-ltmain.sh
@@ -0,0 +1,23 @@
+--- ltmain.sh.orig Wed Dec 18 06:19:10 2002
++++ ltmain.sh Sat Dec 21 02:44:34 2002
+@@ -973,6 +973,7 @@
+ ;;
+
+ -avoid-version)
++ build_old_libs=no
+ avoid_version=yes
+ continue
+ ;;
+@@ -4325,10 +4326,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"