aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/libgphoto2
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-07-25 20:02:55 +0800
committerpav <pav@FreeBSD.org>2004-07-25 20:02:55 +0800
commitde74e9dd27d1c362f44401d54c32b08e21d57a6d (patch)
tree8cdb31b6b0bf70b434c554f619e42c06c9803a0f /graphics/libgphoto2
parentc4f50529519e78dcfddb76b058e60200f7443587 (diff)
downloadfreebsd-ports-gnome-de74e9dd27d1c362f44401d54c32b08e21d57a6d.tar.gz
freebsd-ports-gnome-de74e9dd27d1c362f44401d54c32b08e21d57a6d.tar.zst
freebsd-ports-gnome-de74e9dd27d1c362f44401d54c32b08e21d57a6d.zip
- Fix downloading of full size pictures from camera on 64-bit platforms.
PR: ports/69521 Submitted by: Francois Tigeot <ftigeot@wolfpond.org> Obtained from: libgphoto2 CVS (rev. 1.68 of libgphoto2/gphoto2-filesys.c)
Diffstat (limited to 'graphics/libgphoto2')
-rw-r--r--graphics/libgphoto2/Makefile2
-rw-r--r--graphics/libgphoto2/files/patch-libgphoto2::gphoto2-filesys.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/graphics/libgphoto2/Makefile b/graphics/libgphoto2/Makefile
index 6bce08a87326..ce3538bf6621 100644
--- a/graphics/libgphoto2/Makefile
+++ b/graphics/libgphoto2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libgphoto2
PORTVERSION= 2.1.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gphoto
diff --git a/graphics/libgphoto2/files/patch-libgphoto2::gphoto2-filesys.c b/graphics/libgphoto2/files/patch-libgphoto2::gphoto2-filesys.c
new file mode 100644
index 000000000000..017bdec955b1
--- /dev/null
+++ b/graphics/libgphoto2/files/patch-libgphoto2::gphoto2-filesys.c
@@ -0,0 +1,11 @@
+--- libgphoto2/gphoto2-filesys.c.orig Sun Jan 18 20:46:59 2004
++++ libgphoto2/gphoto2-filesys.c Thu Jul 22 07:55:25 2004
+@@ -1920,7 +1920,7 @@
+ #elif HAVE_SYSCTL && (__FreeBSD__ || __NetBSD__ || __OpenBSD__ || __APPLE__ )
+
+ int mib[2] = { CTL_HW, HW_PHYSMEM };
+- int value;
++ unsigned long value;
+ size_t valuelen = sizeof(value);
+ *free=0;
+ if (sysctl(mib, 2 , &value, &valuelen, NULL, 0) == -1) {