aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/libosmesa/Makefile
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2011-04-12 23:27:29 +0800
committergahr <gahr@FreeBSD.org>2011-04-12 23:27:29 +0800
commit468b1d6cb4e506bd1bbebe9a0605f3260936cdfc (patch)
treee62a2a0b38542a3d03b1a3a23a36555f55fe1470 /graphics/libosmesa/Makefile
parent8696890813eb5a1fcabf6be6642965abc5c54863 (diff)
downloadfreebsd-ports-gnome-468b1d6cb4e506bd1bbebe9a0605f3260936cdfc.tar.gz
freebsd-ports-gnome-468b1d6cb4e506bd1bbebe9a0605f3260936cdfc.tar.zst
freebsd-ports-gnome-468b1d6cb4e506bd1bbebe9a0605f3260936cdfc.zip
- Update to 7.10.2
- Set as BROKEN only on amd64
Diffstat (limited to 'graphics/libosmesa/Makefile')
-rw-r--r--graphics/libosmesa/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/graphics/libosmesa/Makefile b/graphics/libosmesa/Makefile
index afbde6af07ec..39f441b167a5 100644
--- a/graphics/libosmesa/Makefile
+++ b/graphics/libosmesa/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libosmesa
-PORTVERSION= 7.10.1
+PORTVERSION= 7.10.2
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.freedesktop.org/pub/mesa/${PORTVERSION}/
DISTNAME= MesaLib-${PORTVERSION}
@@ -18,7 +18,8 @@ LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
talloc.2:${PORTSDIR}/devel/talloc
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/libxml2mod.so:${PORTSDIR}/textproc/py-libxml2 \
makedepend:${PORTSDIR}/devel/makedepend
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/libxml2mod.so:${PORTSDIR}/textproc/py-libxml2 \
+ makedepend:${PORTSDIR}/devel/makedepend
CONFLICTS= mesagl-mangled-*
@@ -31,7 +32,7 @@ USE_PYTHON_BUILD= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-driver=osmesa --with-osmesa-bits=32 \
--includedir=${PREFIX}/include/Mesa
-CFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include -fPIC
WRKSRC= ${WRKDIR}/Mesa-${PORTVERSION}
@@ -41,8 +42,8 @@ SHLIB_VERS= ${PORTVERSION:R:R}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 900000
-BROKEN= does not install on 9.X
+.if ${ARCH} == "amd64"
+BROKEN= Fails to build
.endif
do-install: