aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/librsvg2/Makefile
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-08-29 23:59:40 +0800
committerkwm <kwm@FreeBSD.org>2015-08-29 23:59:40 +0800
commit2265fd430a21de9dc20f9ee694afbd613ad5819b (patch)
treeadec99c159f393ebe35c165a5d4267190a773142 /graphics/librsvg2/Makefile
parent12caedc7311dfb37ba3805bb1d52d706a4b00865 (diff)
downloadfreebsd-ports-gnome-2265fd430a21de9dc20f9ee694afbd613ad5819b.tar.gz
freebsd-ports-gnome-2265fd430a21de9dc20f9ee694afbd613ad5819b.tar.zst
freebsd-ports-gnome-2265fd430a21de9dc20f9ee694afbd613ad5819b.zip
Update librsvg2 to 2.40.10.
Replace gtk20 dependancy with gdk-pixbuf2 and pango, and drop the gtk-engines2 run dependacy. Update ports to take the dependacy changes into account. PR: 202378 Exp-run by: antoine@
Diffstat (limited to 'graphics/librsvg2/Makefile')
-rw-r--r--graphics/librsvg2/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/graphics/librsvg2/Makefile b/graphics/librsvg2/Makefile
index 2807e6e84186..6970d45613b7 100644
--- a/graphics/librsvg2/Makefile
+++ b/graphics/librsvg2/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= librsvg
-PORTVERSION= 2.40.9
+PORTVERSION= 2.40.10
CATEGORIES= graphics gnome
MASTER_SITES= GNOME
PKGNAMESUFFIX= 2
@@ -14,23 +14,20 @@ COMMENT= Library for parsing and rendering SVG vector-graphic files
LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
libpng.so:${PORTSDIR}/graphics/png \
libcroco-0.6.so:${PORTSDIR}/textproc/libcroco
-RUN_DEPENDS= gtk-engines2>=2.7.5_1:${PORTSDIR}/x11-themes/gtk-engines2
USES= gettext gmake libtool pathfix pkgconfig tar:xz
-USE_GNOME= gnomeprefix libgsf gtk20 introspection:build
+USE_GNOME= gnomeprefix libgsf gdkpixbuf2 introspection:build libxml2 \
+ pango
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
-CONFIGURE_ARGS= --with-svgz \
- --disable-vala \
- --with-croco \
- --disable-Bsymbolic \
- --enable-gtk-theme
+CONFIGURE_ARGS= --disable-vala \
+ --disable-Bsymbolic
post-patch:
- @${REINPLACE_CMD} -e 's|GTK3_REQUIRED=3.[0-9].[0-9]|GTK3_REQUIRED=9.90.0|g' \
+ @${REINPLACE_CMD} -e 's|GTK3_REQUIRED=3.[0-9][0-9].[0-9]|GTK3_REQUIRED=9.90.0|g' \
${WRKSRC}/configure
.include <bsd.port.mk>