aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/librsvg2/Makefile
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2009-01-10 10:45:46 +0800
committermezz <mezz@FreeBSD.org>2009-01-10 10:45:46 +0800
commit867a335b88f91d457005fa0c7b3bb7c85c5fca14 (patch)
tree68af898c9a11dd756c516c49a6715cee75888e70 /graphics/librsvg2/Makefile
parent6f64cd00171c29c1c7cdfb1e40393e23fc35151d (diff)
downloadfreebsd-ports-gnome-867a335b88f91d457005fa0c7b3bb7c85c5fca14.tar.gz
freebsd-ports-gnome-867a335b88f91d457005fa0c7b3bb7c85c5fca14.tar.zst
freebsd-ports-gnome-867a335b88f91d457005fa0c7b3bb7c85c5fca14.zip
Add a new framework for browser plugins, USE_WEBPLUGINS. It is for which foo
plugins support one of web browsers and can take care of plist (depend on how you use it) at the same time. I have written a complete document and even show how it works in the www/firefox/Makefile.webplugins so be sure to read in there. If there is anything that isn't clear in the document, please feel free to ask and I will try my best to improvement it. FYI: GNOME 2.24 depends on this, so it's coming. BTW: It's based on www/linux-mplayer-plugin/Makefile.npapi with heavy modified. Approved by: portmgr
Diffstat (limited to 'graphics/librsvg2/Makefile')
-rw-r--r--graphics/librsvg2/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/graphics/librsvg2/Makefile b/graphics/librsvg2/Makefile
index cb1d4f798781..df15602807d8 100644
--- a/graphics/librsvg2/Makefile
+++ b/graphics/librsvg2/Makefile
@@ -3,11 +3,12 @@
# Whom: Ade Lovett <ade@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/graphics/librsvg2/Makefile,v 1.121 2008/03/04 18:51:53 kwm Exp $
+# $MCom: ports-stable/graphics/librsvg2/Makefile,v 1.3 2008/09/23 20:34:45 mezz Exp $
#
PORTNAME= librsvg2
PORTVERSION= 2.22.3
+PORTREVISION= 1
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -46,7 +47,10 @@ OPTIONS= MOZILLA_PLUGIN "Enable the SVG browser plug-in" no
.if defined(WITH_MOZILLA_PLUGIN)
USE_GECKO= firefox mozilla seamonkey xulrunner
+USE_WEBPLUGINS= gecko*
+WEBPLUGINS_FILES=libmozsvgdec.so
.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
+.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
CONFIGURE_ENV+= MOZILLA_CONFIG=no
CONFIGURE_ARGS+=--enable-mozilla-plugin=yes
@@ -61,6 +65,8 @@ post-patch:
.if defined(WITH_MOZILLA_PLUGIN)
@${REINPLACE_CMD} -e 's|mozilla-plugin|${GECKO}-plugin|g' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|[$$][(]libdir[)]/mozilla/plugins|${WEBPLUGINS_DIR}|g' \
+ ${WRKSRC}/moz-plugin/Makefile.in
.endif
.include <bsd.port.post.mk>