aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/libv3d
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-07-03 02:49:58 +0800
committerijliao <ijliao@FreeBSD.org>2002-07-03 02:49:58 +0800
commitf3dfd10129e25ccd9a5ce80b450e940b94587eb7 (patch)
tree504f4a93911f391ecf25dccf4378ec674eb0ba8b /graphics/libv3d
parent9e1d86002b2c73cda8927fcb5202e7309f24b3c8 (diff)
downloadfreebsd-ports-gnome-f3dfd10129e25ccd9a5ce80b450e940b94587eb7.tar.gz
freebsd-ports-gnome-f3dfd10129e25ccd9a5ce80b450e940b94587eb7.tar.zst
freebsd-ports-gnome-f3dfd10129e25ccd9a5ce80b450e940b94587eb7.zip
add libv3d 0.1.7
V3D IO Library
Diffstat (limited to 'graphics/libv3d')
-rw-r--r--graphics/libv3d/Makefile87
-rw-r--r--graphics/libv3d/distinfo1
-rw-r--r--graphics/libv3d/files/patch-platforms.ini24
-rw-r--r--graphics/libv3d/pkg-comment1
-rw-r--r--graphics/libv3d/pkg-descr6
-rw-r--r--graphics/libv3d/pkg-plist11
6 files changed, 130 insertions, 0 deletions
diff --git a/graphics/libv3d/Makefile b/graphics/libv3d/Makefile
new file mode 100644
index 000000000000..b70357f9fecd
--- /dev/null
+++ b/graphics/libv3d/Makefile
@@ -0,0 +1,87 @@
+# ex:ts=8
+# Ports collection makefile for: libv3d
+# Date Created: Jul 2, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libv3d
+PORTVERSION= 0.1.7
+CATEGORIES= graphics
+MASTER_SITES= ftp://wolfpack.twu.net/users/wolfpack/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_REINPLACE= yes
+USE_MESA= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= UNIX --prefix=${PREFIX}
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+
+MAN3= V3DGLInterpriteDelete.3 \
+ V3DGLInterpriteNew.3 \
+ V3DGLProcessModel.3 \
+ V3DGLProcessModelExtra.3 \
+ V3DGLResourceDelete.3 \
+ V3DGLResourceGetInterpritation.3 \
+ V3DGLResourceNew.3 \
+ V3DGLResourceNewFromModelData.3 \
+ V3DGLResourceSetInterpritation.3 \
+ V3DHFGetHeightFromWorldPosition.3 \
+ V3DHFLoadFromFile.3 \
+ V3DIntro.3 \
+ V3DLoadModel.3 \
+ V3DMHCreate.3 \
+ V3DMHDestroy.3 \
+ V3DMHHeightfieldBaseDirectoryGet.3 \
+ V3DMHHeightfieldBaseDirectorySet.3 \
+ V3DMHListDelete.3 \
+ V3DMHListDeleteAll.3 \
+ V3DMHListGetPtr.3 \
+ V3DMHListInsert.3 \
+ V3DMHTextureBaseDirectoryGet.3 \
+ V3DMHTextureBaseDirectorySet.3 \
+ V3DMPCreate.3 \
+ V3DMPDestroy.3 \
+ V3DMPDup.3 \
+ V3DMPFlipWinding.3 \
+ V3DMPGetNormal.3 \
+ V3DMPGetTexCoord.3 \
+ V3DMPGetTotal.3 \
+ V3DMPGetVertex.3 \
+ V3DMPListGetPtr.3 \
+ V3DMPListInsert.3 \
+ V3DMPUnitlizeNormal.3 \
+ V3DModelCreate.3 \
+ V3DModelDestroy.3 \
+ V3DModelDup.3 \
+ V3DModelListDelete.3 \
+ V3DModelListDeleteAll.3 \
+ V3DModelListGetPtr.3 \
+ V3DModelListInsert.3 \
+ V3DSaveModel.3 \
+ V3DTextureDestroy.3 \
+ V3DTextureLoadFromData1D.3 \
+ V3DTextureLoadFromData2D.3 \
+ V3DTextureLoadFromFile2D.3 \
+ V3DTextureLoadFromFile2DPreempt.3 \
+ V3DTexturePriority.3 \
+ V3DTextureSelect.3 \
+ V3DTextureSelectFrame.3 \
+ v3d_glinterprite_struct.3 \
+ v3d_glresource_struct.3 \
+ v3d_hf_options_struct.3 \
+ v3d_texture_ref_struct.3
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,make,${GMAKE},g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e "s,%%CFLAGS%%,${CFLAGS},g" \
+ -e "s,%%X11BASE%%,${X11BASE},g" \
+ -e "s,%%PTHREAD_CFLAGS%%,${PTHREAD_CFLAGS},g" \
+ -e "s,%%PTHREAD_LIBS%%,${PTHREAD_LIBS},g" \
+ ${WRKSRC}/libv3d/platforms.ini
+
+.include <bsd.port.mk>
diff --git a/graphics/libv3d/distinfo b/graphics/libv3d/distinfo
new file mode 100644
index 000000000000..bd509eb6e9ee
--- /dev/null
+++ b/graphics/libv3d/distinfo
@@ -0,0 +1 @@
+MD5 (libv3d-0.1.7.tgz) = 3492f56aa1b2d13c7c2be6736a4896a8
diff --git a/graphics/libv3d/files/patch-platforms.ini b/graphics/libv3d/files/patch-platforms.ini
new file mode 100644
index 000000000000..a007ada69494
--- /dev/null
+++ b/graphics/libv3d/files/patch-platforms.ini
@@ -0,0 +1,24 @@
+--- libv3d/platforms.ini.orig Wed Jul 3 02:37:49 2002
++++ libv3d/platforms.ini Wed Jul 3 02:42:55 2002
+@@ -23,8 +23,7 @@
+ Platform = UNIX
+ Description = For most any UNIX system
+ PREFIX = /usr/
+- CFLAGS = -Wall -O6 -funroll-loops -fomit-frame-pointer -ffast-math \
+--D__USE_BSD
++ CFLAGS = %%CFLAGS%% -D__USE_BSD
+ LIBS = -lm
+ LIB_DIR =
+ CC = cc
+@@ -65,8 +64,9 @@
+ PlatformFeature = opengl
+ Description = An implementation of OpenGL (ie Mesa3D)
+ MustExist = Yes
+- FeatureLIBS = -lGL -lGLU
+- FeatureLIB_DIR = -L/usr/X11R6/lib/
++ FeatureCFLAGS = -I%%X11BASE%%/include %%PTHREAD_CFLAGS%%
++ FeatureLIBS = -lGL -lGLU %%PTHREAD_LIBS%%
++ FeatureLIB_DIR = -L%%X11BASE%%/lib/
+ FeatureDepend = gl-lib
+ DependType = Library
+ MustExist = Yes
diff --git a/graphics/libv3d/pkg-comment b/graphics/libv3d/pkg-comment
new file mode 100644
index 000000000000..bf03fac8ef8a
--- /dev/null
+++ b/graphics/libv3d/pkg-comment
@@ -0,0 +1 @@
+V3D IO Library
diff --git a/graphics/libv3d/pkg-descr b/graphics/libv3d/pkg-descr
new file mode 100644
index 000000000000..9529cf541781
--- /dev/null
+++ b/graphics/libv3d/pkg-descr
@@ -0,0 +1,6 @@
+The V3D IO Library (commonly known as libv3d) is used by third party
+applications to read and write .v3d model files. You do need this library
+if you have other programs that depend on libv3d to read and write .v3d
+files.
+
+WWW: http://wolfpack.twu.net/Vertex/libv3d.html
diff --git a/graphics/libv3d/pkg-plist b/graphics/libv3d/pkg-plist
new file mode 100644
index 000000000000..43dd96544fab
--- /dev/null
+++ b/graphics/libv3d/pkg-plist
@@ -0,0 +1,11 @@
+include/v3d/v3d.h
+include/v3d/v3dfio.h
+include/v3d/v3dgl.h
+include/v3d/v3dhf.h
+include/v3d/v3dmh.h
+include/v3d/v3dmodel.h
+include/v3d/v3dmp.h
+include/v3d/v3dtex.h
+@dirrm include/v3d
+lib/libv3d.so
+lib/libv3d.so.0.1.7