aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/linux-c6-libGLU
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-09-06 03:23:42 +0800
committertijl <tijl@FreeBSD.org>2016-09-06 03:23:42 +0800
commit6255104baacfdd2c23e07550f90d2f9a7020ca87 (patch)
tree516db145d6cf5fd4d2666f811272aad577272ac5 /graphics/linux-c6-libGLU
parent016de2316ed16336a58b66dafd7f332614a041ac (diff)
downloadfreebsd-ports-gnome-6255104baacfdd2c23e07550f90d2f9a7020ca87.tar.gz
freebsd-ports-gnome-6255104baacfdd2c23e07550f90d2f9a7020ca87.tar.zst
freebsd-ports-gnome-6255104baacfdd2c23e07550f90d2f9a7020ca87.zip
- Replace Mk/bsd.linux-apps.mk and Mk/bsd.linux-rpm.mk with
Mk/Uses/linux.mk. - Replace USE_LINUX=yes with USES+=linux and USE_LINUX=(.*) with USES+=linux:\1 in all ports. - Replace USE_LINUX_APPS with USE_LINUX in all ports. - Use INSTALL_SCRIPT instead of INSTALL_PROGRAM to install scripts in some ports. - When USE_LINUX_RPM is defined, simplify the way DISTFILES and EXTRACT_ONLY are defined. - Remove BRANDELF_DIRS and BRANDELF_FILES handling. In the very rare cases that it is still necessary ports can run ${BRANDELF} from post-patch. - Remove AUTOMATIC_PLIST handling. Only one port used it. - Fix Linux MASTER_SITES. - Replace OVERRIDE_LINUX_BASE_PORT and OVERRIDE_LINUX_NONBASE_PORTS with default versions framework. - bsd.port.mk: - Move Linux related bits to Uses/linux.mk, except USE_LINUX_PREFIX. - Put USE_LINUX_PREFIX handling after USES processing. - Define DOCSDIR, DATADIR, etc. after handling USE_LINUX_PREFIX so it can give these variables a different default value. - When a package needs to run Linux ldconfig check before installation if Linux support is enabled. - emulators/linux_base-*: - Use USES=linux and remove duplication. - Remove files/lp. FreeBSD or CUPS lp(1) should work. - Remove files/yp.conf. No longer seems to be used. - Remove pkg-deinstall and move pkg-install into pkg-plist. - Update pkg-descr and pkg-message. - Fix handling of ldconfig cache in pkg-plist. - devel/fb-adb: Use a Linux shell to run a Linux script but patch the script to use FreeBSD mkdir so mkdir -p $path creates $path and not /compat/linux/$path. PR: 211645 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'graphics/linux-c6-libGLU')
-rw-r--r--graphics/linux-c6-libGLU/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/graphics/linux-c6-libGLU/Makefile b/graphics/linux-c6-libGLU/Makefile
index 4b5d7c48d474..cbd0a87ba5d7 100644
--- a/graphics/linux-c6-libGLU/Makefile
+++ b/graphics/linux-c6-libGLU/Makefile
@@ -13,14 +13,13 @@ ALWAYS_KEEP_DISTFILES= YES
CONFLICTS= linux-f10-dri-[0-9]* linux-f10-libGLU-[0-9]* linux-c6-dri-[0-9]*
-ONLY_FOR_ARCHS= i386 amd64
.if defined(PACKAGE_BUILDING)
SRC_DISTFILES= mesa-${PORTVERSION}-${RPMVERSION}.src.rpm:SOURCE
.endif
RPMVERSION= 4.el6
-USE_LINUX= c6
+USES= linux:c6
USE_LINUX_RPM= yes
USE_LDCONFIG= yes
DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr