aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/luminance-qt5
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-04-11 09:44:53 +0800
committerMatthias Andree <mandree@FreeBSD.org>2021-04-12 08:33:40 +0800
commitd5f6e8b84e881d773e7b7f089874e9075d688c89 (patch)
tree6ac2e1d0d403216199fea17fd03997f8cd63c002 /graphics/luminance-qt5
parent581762cb8de91504f0e76cb5f1ef9f6e17576eeb (diff)
downloadfreebsd-ports-gnome-d5f6e8b84e881d773e7b7f089874e9075d688c89.tar.gz
freebsd-ports-gnome-d5f6e8b84e881d773e7b7f089874e9075d688c89.tar.zst
freebsd-ports-gnome-d5f6e8b84e881d773e7b7f089874e9075d688c89.zip
graphics/luminance-qt5: make compatible with OpenEXR/Imath 3.0
Diffstat (limited to 'graphics/luminance-qt5')
-rw-r--r--graphics/luminance-qt5/Makefile8
-rw-r--r--graphics/luminance-qt5/files/patch-build__files_Modules_FindOpenEXR.cmake23
2 files changed, 28 insertions, 3 deletions
diff --git a/graphics/luminance-qt5/Makefile b/graphics/luminance-qt5/Makefile
index 2ad670154fdf..b5071aa27eff 100644
--- a/graphics/luminance-qt5/Makefile
+++ b/graphics/luminance-qt5/Makefile
@@ -2,7 +2,7 @@
PORTNAME= luminance-hdr
DISTVERSION= 2.5.1
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= graphics
MASTER_SITES= SF/qtpfsgui/luminance/${DISTVERSION}
PKGNAMESUFFIX= -qt5
@@ -17,7 +17,7 @@ EXPIRATION_DATE=2021-06-23
BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:math/fftw3
LIB_DEPENDS= libcfitsio.so:astro/cfitsio \
- libHalf.so:graphics/ilmbase \
+ libImath.so:math/Imath \
libtiff.so:graphics/tiff \
libraw_r.so:graphics/libraw \
libfftw3f.so:math/fftw3-float \
@@ -25,9 +25,11 @@ LIB_DEPENDS= libcfitsio.so:astro/cfitsio \
libexiv2.so:graphics/exiv2 \
liblcms2.so:graphics/lcms2 \
libpng.so:graphics/png \
- libIlmImf.so:graphics/openexr \
+ libOpenEXR.so:graphics/openexr \
libboost_date_time.so:devel/boost-libs
+CFLAGS+= -I${LOCALBASE}/include/Imath
+
USES= cmake desktop-file-utils jpeg pkgconfig qt:5 tar:bzip2
USE_QT= concurrent core declarative gui location network printsupport \
sql svg webchannel webengine widgets xml \
diff --git a/graphics/luminance-qt5/files/patch-build__files_Modules_FindOpenEXR.cmake b/graphics/luminance-qt5/files/patch-build__files_Modules_FindOpenEXR.cmake
new file mode 100644
index 000000000000..a6e21e9799d8
--- /dev/null
+++ b/graphics/luminance-qt5/files/patch-build__files_Modules_FindOpenEXR.cmake
@@ -0,0 +1,23 @@
+--- build_files/Modules/FindOpenEXR.cmake.orig 2017-05-10 19:14:06 UTC
++++ build_files/Modules/FindOpenEXR.cmake
+@@ -39,18 +39,16 @@ if (NOT OPENEXR_VERSION)
+ endif()
+ if (${OPENEXR_VERSION} VERSION_LESS "2.1")
+ SET(_openexr_FIND_COMPONENTS
+- Half
+ Iex
+- IlmImf
++ OpenEXR
+ IlmThread
+ Imath
+ )
+ else ()
+ string(REGEX REPLACE "([0-9]+)[.]([0-9]+).*" "\\1_\\2" _openexr_libs_ver ${OPENEXR_VERSION})
+ SET(_openexr_FIND_COMPONENTS
+- Half
++ OpenEXR-${_openexr_libs_ver}
+ Iex-${_openexr_libs_ver}
+- IlmImf-${_openexr_libs_ver}
+ IlmThread-${_openexr_libs_ver}
+ Imath-${_openexr_libs_ver}
+ )