aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/luxrays/files
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-08-08 06:22:17 +0800
committerwg <wg@FreeBSD.org>2013-08-08 06:22:17 +0800
commit0e957e21070473fb4e7e1f2ab4e217d50d3b4a9d (patch)
tree83e3c73e953c1fd4dfabf89dc9adf339763fe7b1 /graphics/luxrays/files
parentc016ed208001f2cd4181aaa8da54ec2d58fd7721 (diff)
downloadfreebsd-ports-gnome-0e957e21070473fb4e7e1f2ab4e217d50d3b4a9d.tar.gz
freebsd-ports-gnome-0e957e21070473fb4e7e1f2ab4e217d50d3b4a9d.tar.zst
freebsd-ports-gnome-0e957e21070473fb4e7e1f2ab4e217d50d3b4a9d.zip
graphics/luxrays: Accelerate the ray intersection process by using GPUs
LuxRays is library dedicated to accelerate the ray intersection process by using GPUs. Uses a Data Parallel Model: it doesn't reduce the time spent to trace a single ray but it is able to trace many thousands of rays in parallel. Supports Hybrid CPU/GPU mode where only the ray intersection task is off load to the GPUs while everything else run on the CPU and can be written with usual tools and languages. WWW: http://www.luxrender.net/wiki/LuxRays PR: ports/181019 Submitted by: Natacha Porté <natbsd instinctive.eu>
Diffstat (limited to 'graphics/luxrays/files')
-rw-r--r--graphics/luxrays/files/patch-CMakeLists.txt11
-rw-r--r--graphics/luxrays/files/patch-include-luxrays-core-geometry-frame.h16
-rw-r--r--graphics/luxrays/files/patch-samples-benchsimple-CMakeLists.txt8
3 files changed, 35 insertions, 0 deletions
diff --git a/graphics/luxrays/files/patch-CMakeLists.txt b/graphics/luxrays/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..fa1fa3bf098b
--- /dev/null
+++ b/graphics/luxrays/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2013-08-04 12:25:45.415147716 +0200
++++ CMakeLists.txt 2013-08-04 12:26:52.319147148 +0200
+@@ -142,7 +142,7 @@
+ message(WARNING "SLG2 requires OpenCL support, not building")
+ endif(NOT LUXRAYS_DISABLE_OPENCL)
+
+- add_subdirectory(samples/smallluxgpu3)
++ # add_subdirectory(samples/smallluxgpu3)
+ endif(OPENGL_FOUND AND GLUT_FOUND AND GLEW_FOUND)
+
+
diff --git a/graphics/luxrays/files/patch-include-luxrays-core-geometry-frame.h b/graphics/luxrays/files/patch-include-luxrays-core-geometry-frame.h
new file mode 100644
index 000000000000..56fb882f8628
--- /dev/null
+++ b/graphics/luxrays/files/patch-include-luxrays-core-geometry-frame.h
@@ -0,0 +1,16 @@
+--- include/luxrays/core/geometry/frame.h.orig 2013-08-04 12:00:53.496371213 +0200
++++ include/luxrays/core/geometry/frame.h 2013-08-04 12:01:10.695167535 +0200
+@@ -44,11 +44,11 @@
+ SetFromZ(z);
+ }
+
+- Frame(const Normal &z) {
++ Frame(const luxrays::Normal &z) {
+ SetFromZ(Vector(z));
+ }
+
+- void SetFromZ(const Normal &z) {
++ void SetFromZ(const luxrays::Normal &z) {
+ SetFromZ(Vector(z));
+ }
+
diff --git a/graphics/luxrays/files/patch-samples-benchsimple-CMakeLists.txt b/graphics/luxrays/files/patch-samples-benchsimple-CMakeLists.txt
new file mode 100644
index 000000000000..99735bb48d02
--- /dev/null
+++ b/graphics/luxrays/files/patch-samples-benchsimple-CMakeLists.txt
@@ -0,0 +1,8 @@
+--- samples/benchsimple/CMakeLists.txt.orig 2013-08-04 12:21:54.850147165 +0200
++++ samples/benchsimple/CMakeLists.txt 2013-08-04 12:22:17.696646898 +0200
+@@ -23,4 +23,4 @@
+ link_directories (${LuxRays_LIB_DIR})
+
+ add_executable(benchsimple benchsimple.cpp)
+-target_link_libraries(benchsimple luxrays)
++target_link_libraries(benchsimple luxrays pthread)