aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/mupdf
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-07-15 14:29:36 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2018-07-15 14:29:36 +0800
commita1fe8805db104c50be22bce2da31f757b9dad6b0 (patch)
treedae53eb30ad73104157c6b490e05571121a32b5b /graphics/mupdf
parent7998db574182b0c550783efba158317649fb93e0 (diff)
downloadfreebsd-ports-gnome-a1fe8805db104c50be22bce2da31f757b9dad6b0.tar.gz
freebsd-ports-gnome-a1fe8805db104c50be22bce2da31f757b9dad6b0.tar.zst
freebsd-ports-gnome-a1fe8805db104c50be22bce2da31f757b9dad6b0.zip
graphics/mupdf: Fix headers conflict with openjpeg15
Reported by: Ajtim <starikarp@yandex.com> (on ports ML)
Diffstat (limited to 'graphics/mupdf')
-rw-r--r--graphics/mupdf/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/graphics/mupdf/Makefile b/graphics/mupdf/Makefile
index 2b7c6351796b..0aecb26d0ba7 100644
--- a/graphics/mupdf/Makefile
+++ b/graphics/mupdf/Makefile
@@ -23,16 +23,17 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libjbig2dec.so:graphics/jbig2dec \
libopenjp2.so:graphics/openjpeg
-CFLAGS+= -I${WRKSRC}/include/mupdf -fPIC
-LIBS+= -L${LOCALBASE}/lib
+USES= cpe compiler:c++11-lang gmake jpeg pkgconfig
MAKE_ARGS= build=release prefix=${PREFIX} mandir=${PREFIX}/man verbose=yes \
SOVERSION=${PORTVERSION}
ALL_TARGET= all extra
-USES= cpe compiler:c++11-lang gmake jpeg pkgconfig
USE_XORG= x11 xcursor xext xinerama xrandr
USE_GL= gl glut
USE_LDCONFIG= yes
+CFLAGS+= `pkg-config --cflags libopenjp2` -I${WRKSRC}/include/mupdf -fPIC # pkg-config to avoid the conflict with openjpeg15
+LIBS+= -L${LOCALBASE}/lib
+
CPE_VENDOR= artifex
OPTIONS_DEFINE= DOCS JS SCROLL