aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/netpbm
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-01-31 16:14:52 +0800
committerDirk Meyer <dinoex@FreeBSD.org>2004-01-31 16:14:52 +0800
commit2704aa9a9bb043ea8782620a5dc88f30e234473e (patch)
tree95eb9a6e5d05b00d78428d843d02229e1a58fac1 /graphics/netpbm
parent39e1c1961c297ab60f21c547529e84cb1d47d9da (diff)
downloadfreebsd-ports-gnome-2704aa9a9bb043ea8782620a5dc88f30e234473e.tar.gz
freebsd-ports-gnome-2704aa9a9bb043ea8782620a5dc88f30e234473e.tar.zst
freebsd-ports-gnome-2704aa9a9bb043ea8782620a5dc88f30e234473e.zip
- update to 10.20
- use DOCSDIR, suports now NOPORTDOCS
Diffstat (limited to 'graphics/netpbm')
-rw-r--r--graphics/netpbm/Makefile12
-rw-r--r--graphics/netpbm/distinfo3
-rw-r--r--graphics/netpbm/files/patch-converter-other-anytopnm65
-rw-r--r--graphics/netpbm/files/patch-editor-pnmquant45
-rw-r--r--graphics/netpbm/pkg-plist5
5 files changed, 12 insertions, 118 deletions
diff --git a/graphics/netpbm/Makefile b/graphics/netpbm/Makefile
index 44a21fdf1bc9..5fff0d2f86c6 100644
--- a/graphics/netpbm/Makefile
+++ b/graphics/netpbm/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= netpbm
-PORTVERSION= 10.19
-PORTREVISION?= 3
+PORTVERSION= 10.20
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -55,9 +54,12 @@ post-patch:
post-install:
@${ECHO_MSG} "===> Installing man pages..."
- @${REINPLACE_CMD} -e 's|doc/USERDOC|${DOCSDIR}/USERDOC|g' ${WRKSRC}/doc/netpbm.1
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/USERDOC ${DOCSDIR}
+ @${REINPLACE_CMD} -e 's|doc/USERDOC|${DOCSDIR}/USERDOC|g' \
+ ${WRKSRC}/doc/netpbm.1
${INSTALL_MAN} ${WRKSRC}/doc/netpbm.1 ${MANPREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/USERDOC ${DOCSDIR}/
+.endif
.include <bsd.port.post.mk>
diff --git a/graphics/netpbm/distinfo b/graphics/netpbm/distinfo
index ab2214d8701f..8545731d833b 100644
--- a/graphics/netpbm/distinfo
+++ b/graphics/netpbm/distinfo
@@ -1 +1,2 @@
-MD5 (netpbm-10.19.tgz) = e6bf74f0cef5271041e0ee4842c8fcef
+MD5 (netpbm-10.20.tgz) = 4aa2f767c4d58bcbdafaba6a7dd03313
+SIZE (netpbm-10.20.tgz) = 2110651
diff --git a/graphics/netpbm/files/patch-converter-other-anytopnm b/graphics/netpbm/files/patch-converter-other-anytopnm
deleted file mode 100644
index d340b0a99577..000000000000
--- a/graphics/netpbm/files/patch-converter-other-anytopnm
+++ /dev/null
@@ -1,65 +0,0 @@
---- converter/other/anytopnm Fri Sep 19 22:35:58 2003
-+++ converter/other/anytopnm Sun Dec 21 18:17:25 2003
-@@ -11,7 +11,7 @@
- # documentation. This software is provided "as is" without express or
- # implied warranty.
-
--function putInputIntoTempfile() {
-+putInputIntoTempfile() {
-
- # $1 is the input file specification
- # $2 is the temporary file name
-@@ -46,7 +46,7 @@
-
-
-
--function setMimeType() {
-+setMimeType() {
- # $1 is the file name
-
- # Christos Zoulas's current 'file' (see Freshmeat) has the --mime option.
-@@ -64,7 +64,7 @@
-
-
-
--function computeTypeFromMimeType () {
-+computeTypeFromMimeType() {
-
- # $1 is the mime type string
-
-@@ -100,7 +100,7 @@
-
-
-
--function computeTypeFromTypeDescription () {
-+computeTypeFromTypeDescription() {
-
- # $1 is the full description from 'file' of the file type
-
-@@ -196,7 +196,7 @@
-
-
-
--function computeTypeFromFilenameExtension () {
-+computeTypeFromFilenameExtension() {
- # $1 is the filename extension (".gif", etc.)
-
- case "$1" in
-@@ -304,7 +304,7 @@
-
-
-
--function determineType () {
-+determineType() {
-
- # $1 is the name of the file that contains the subject file's contents
- # $2 is the mime type or "unknown"
-@@ -327,7 +327,7 @@
-
-
-
--function convertIt () {
-+convertIt() {
- # Based on the file type computed, do the conversion
-
- # $1 is the input file name
diff --git a/graphics/netpbm/files/patch-editor-pnmquant b/graphics/netpbm/files/patch-editor-pnmquant
deleted file mode 100644
index df830ab671a1..000000000000
--- a/graphics/netpbm/files/patch-editor-pnmquant
+++ /dev/null
@@ -1,45 +0,0 @@
---- editor/pnmquant.DIST Mon Dec 29 08:11:52 2003
-+++ editor/pnmquant Mon Dec 29 08:12:24 2003
-@@ -20,7 +20,7 @@
-
- sub parseCommandLine(@) {
-
-- my @args = @_;
-+ @ARGV = @_;
-
- my ($opt_center, $opt_meancolor, $opt_meanpixel, $opt_floyd,
- $opt_spreadbrightness, $opt_spreadluminosity, $opt_mapfile);
-@@ -34,18 +34,18 @@
- "floyd|fs!" => \$opt_floyd,
- );
-
-- if (@args > 2) {
-+ if (@ARGV > 2) {
- print(STDERR "This program takes at most 2 arguments. You specified ",
-- 0+@args, "\n");
-+ 0+@ARGV, "\n");
- exit(1);
- }
-- if (@args < 1) {
-+ if (@ARGV < 1) {
- print(STDERR
- "You must specify the number of colors as an argument.\n");
- exit(1);
- }
- my $infile;
-- my $ncolors = $args[0];
-+ my $ncolors = $ARGV[0];
-
- if (!($ncolors =~ m{ ^[[:digit:]]+$ }x ) || $ncolors == 0) {
- print(STDERR
-@@ -54,8 +54,8 @@
- exit(1);
- }
-
-- if (@args > 1) {
-- $infile = $args[1];
-+ if (@ARGV > 1) {
-+ $infile = $ARGV[1];
- } else {
- $infile = "-";
- }
diff --git a/graphics/netpbm/pkg-plist b/graphics/netpbm/pkg-plist
index 4b70c739e9af..083424660fe6 100644
--- a/graphics/netpbm/pkg-plist
+++ b/graphics/netpbm/pkg-plist
@@ -50,6 +50,7 @@ bin/pamfunc
bin/pamlookup
bin/pamoil
bin/pampop9
+bin/pamscale
bin/pamseq
bin/pamslice
bin/pamstack
@@ -298,6 +299,6 @@ share/netpbm/palmgray1.map
share/netpbm/palmgray2.map
share/netpbm/palmgray4.map
share/netpbm/rgb.txt
-%%PORTDOCS%%share/doc/netpbm/USERDOC
-%%PORTDOCS%%@dirrm share/doc/netpbm
+%%PORTDOCS%%%%DOCSDIR%%/USERDOC
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm share/netpbm
pan> * news/nzbget: Update from 16.4 to 17.1tz2016-12-163-6/+12 * update MAINTAINER to my FreeBSD.org emaillifanov2016-12-141-1/+1 * Remove libintl.so.9 compatibility link that was added in r374303 totijl2016-12-091-1/+1 * Remove libiconv.so.3 compatibility link that was added in r374303 totijl2016-12-091-1/+1 * - fix build for FreeBSD-9dinoex2016-11-231-0/+3 * Bump PORTREVISIONS for ports depending on the canonical version of GCC andgerald2016-11-201-0/+1 * devel/icu: update to 58.1jbeich2016-11-201-1/+1 * - fix build on FreeBSD-12dinoex2016-11-191-0/+6 * - fix include and prototype problems with ansi patchesdinoex2016-11-1623-1050/+5 * chinese/tin: drop PORTREVISION as it has no effectjbeich2016-11-111-1/+1 * Mark as broken on aarch64: fails to link with sbrk.linimon2016-11-102-0/+5 * - fix include and prototype problems with ansi patchesdinoex2016-11-0834-628/+28 * Update slrn to 1.0.3 (bugfix release)johans2016-11-072-6/+8 * Fix character encoding issuesriggs2016-11-062-1/+2 * ${RM} already has -f.mat2016-10-212-3/+3 * news/golded+: honor LDFLAGSmarino2016-10-181-5/+5 * - Double-quote $@ to properly propagate parameters down the execution pathdanfe2016-10-171-2/+1 * Update rawdog to 2.22.tdb2016-10-123-13/+14 * Update to 1.4.3ehaupt2016-10-062-5/+5 * Update to 1.1.5-20160322.fjoe2016-10-059-110/+18 * - Update devel/icu to 57.1.tijl2016-09-241-1/+1 * - Update to 1.1.0amdmi32016-09-233-30/+26 * - fix cstd fior FreeBSD-12dinoex2016-09-161-0/+1 * Mark NO_ARCH and define LICENSEehaupt2016-09-101-0/+4 * Fix package install failure when /var/spool/news already exists.tijl2016-09-082-6/+4 * - Add NO_ARCHamdmi32016-08-181-10/+10 * - Add LICENSEamdmi32016-08-171-1/+7 * - fix regressions on FreeBSD 10.3dinoex2016-08-121-2/+3 * USE_BDB cleanup.mat2016-08-081-2/+2 * news/atp: Remove redundant dependency on unzipmarino2016-08-041-2/+1 * news/mmail: Remove redundant dependency on unzipmarino2016-08-041-2/+1 * Fix build with clang and getline(3)bapt2016-07-311-2/+6 * Prevent collision with getline(3)bapt2016-07-304-0/+53 * Don't echo in post-install, use pkg-message. Also, don't "fix"mat2016-07-192-4/+2 * Bump PORTREVISION for the icu revert.mat2016-07-071-1/+1 * devel/icu: bump PORTREVISION on missing dependent portsgahr2016-07-061-0/+1 * Remove expired ports without open PRs:rene2016-07-057-118/+0 * - Update to tin 2.3.4johans2016-06-292-11/+11 * With the power of USES=dos2unix, get rid of most patches and filesmat2016-06-216-120/+121 * news/sabnzbdplus: 1.0.2 -> 1.0.3pi2016-06-153-10/+11 * Deprecate ports broken for more than 6 monthsantoine2016-06-041-0/+2 * Remove NLS, DOCS, EXAMPLES and IPV6 from OPTIONS_DEFAULT, they are enabled by...amdmi32016-05-241-1/+1 * Prevent collision with getline(3)bapt2016-05-233-0/+39 * - Fix trailing whitespace in pkg-messagesamdmi32016-05-191-1/+1 * - Fix trailing whitespace in pkg-descrs, categories [g-n]*amdmi32016-05-1914-22/+22 * - No need to specify master site subdirectory when it's the same as defaultamdmi32016-05-181-1/+1 * - Fix build on 9.x (extract of build error, below)olivierd2016-05-181-3/+4 * news/sabnzbdplus: update 1.0.1 -> 1.0.2robak2016-05-173-3/+4 * - strip all binariesdinoex2016-05-161-0/+3 * Prevent collision with get_linebapt2016-05-122-0/+31 * news/sabnzbdplus: update 1.0.0 -> 1.0.1robak2016-05-042-3/+3 * Update to tin 2.3.3 "Kinloch"johans2016-04-272-3/+3 * - Update to 1.06sunpoet2016-04-252-7/+12 * news/pan: 0.139 -> 0.140pi2016-04-103-54/+53 * Remove ${PORTSDIR}/ from dependencies, categories m, n, o, and p.mat2016-04-0148-116/+116 * news/nzbget: Add pkg-message to inform users how to drop privsfeld2016-03-292-1/+4 * - Update security/gnutls to 3.4.10.tijl2016-03-271-1/+1 * * Add gnutls options for SSL news servers (default on)kwm2016-03-251-22/+24 * news/sabnzbdplus: Update to 1.0.0feld2016-03-184-152/+114 * news/sabnzbdplus: fix RUN_DEPENDSpi2016-03-131-3/+3 * news/sabnzbdplus: Revert removal of PATH in rc scriptfeld2016-03-102-1/+2 * news/sabnzbdplus: Port cleanupfeld2016-03-094-29/+13 * - Makefile.local for slave ports is included by bsd.port.mk r397519dinoex2016-02-281-4/+0 * Set `command' before using it in the startup script.rakuco2016-02-162-1/+2 * news/trn4: document ncurses requirement (USES+=ncurses)marino2016-02-053-1/+19 * news/trn: document ncurses rqmt (USES+=ncurses), respect LDFLAGSmarino2016-02-053-5/+14 * news/tin: document ncurses requirement (USES+=ncurses)marino2016-02-051-1/+1 * news/mmail: USES+= ncurses, respect LDFLAGS, link ncurses, not cursesmarino2016-02-051-2/+2 * news/golded+: document ncurses rqmt (USES+=ncurses), respect LDFLAGSmarino2016-02-052-1/+12 * - Add LICENSEamdmi32016-02-051-2/+7 * Update tin to 2.3.2johans2016-01-175-22/+23 * Fix staging (as a regular user) / packaging (as root)antoine2016-01-031-0/+21 * Cleanup and update.mandree2015-12-302-17/+14 * Fix build as a user.mat2015-12-293-22/+10 * Old homepage disappeared, link to Russ Allbery's INN pagejohans2015-12-281-1/+1 * Fix usage of ${PERL5}.mat2015-12-181-7/+3 * Make build as a user.mat2015-12-1518-164/+116 * Staticly link to libgcc and libstdc++. This fixes a segmentation faultkwm2015-12-131-2/+3 * news/nzbget: Update to 16.4feld2015-12-122-3/+3 * - Modernize plistamdmi32015-12-012-41/+35 * - fix build with new inndinoex2015-11-221-2/+1 * - use USES=tardinoex2015-11-221-2/+1 * - use post-install-DOCS-ondinoex2015-11-222-4/+2 * - fix build with custom CNEWS_PORTdinoex2015-11-221-7/+9 * news/nzbget: 16.1 -> 16.3pi2015-11-222-3/+3 * Mark a few ports BROKEN: unfetchableantoine2015-11-091-0/+2 * Fix ports that confused the meaning of WRKDIR and WRKSRC.mat2015-11-052-3/+3 * Bump portrevision of ports that might have been built with a broken post-installbapt2015-10-31