aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ocaml-images
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2010-04-09 18:06:44 +0800
committerstas <stas@FreeBSD.org>2010-04-09 18:06:44 +0800
commit7cdb5fd9d9234b2ef290977a32dc6a7188684280 (patch)
tree66c8608d3dd2a527a0d8720ac5cd03cc0b868af3 /graphics/ocaml-images
parent6e4dbfae1f9bf407042175402119e129d57cf24b (diff)
downloadfreebsd-ports-gnome-7cdb5fd9d9234b2ef290977a32dc6a7188684280.tar.gz
freebsd-ports-gnome-7cdb5fd9d9234b2ef290977a32dc6a7188684280.tar.zst
freebsd-ports-gnome-7cdb5fd9d9234b2ef290977a32dc6a7188684280.zip
- Do not expose list_length. This prevents the library to be used in
games/freetennis, which links sdl_image library that exposes the same symbol.
Diffstat (limited to 'graphics/ocaml-images')
-rw-r--r--graphics/ocaml-images/Makefile4
-rw-r--r--graphics/ocaml-images/files/patch-src_gifwrite.c11
2 files changed, 13 insertions, 2 deletions
diff --git a/graphics/ocaml-images/Makefile b/graphics/ocaml-images/Makefile
index 1599bfc0b7d0..d96a2a36a78c 100644
--- a/graphics/ocaml-images/Makefile
+++ b/graphics/ocaml-images/Makefile
@@ -8,7 +8,7 @@
PORTNAME= images
PORTVERSION= 3.0.2
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 2
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.inria.fr/INRIA/Projects/cristal/caml-light/bazar-ocaml/ \
@@ -46,7 +46,7 @@ OPTIONS= PNG "Enable PNG support" on \
.include <bsd.port.options.mk>
.if !defined(WITHOUT_PNG)
-LIB_DEPENDS+= png.6:${PORTSDIR}/graphics/png
+LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
CONFIGURE_ARGS+= --with-png
.else
CONFIGURE_ARGS+= --without-png
diff --git a/graphics/ocaml-images/files/patch-src_gifwrite.c b/graphics/ocaml-images/files/patch-src_gifwrite.c
new file mode 100644
index 000000000000..301d3821631f
--- /dev/null
+++ b/graphics/ocaml-images/files/patch-src_gifwrite.c
@@ -0,0 +1,11 @@
+--- ./src/gifwrite.c.orig 2010-04-09 03:01:01.000000000 -0700
++++ ./src/gifwrite.c 2010-04-09 03:01:08.000000000 -0700
+@@ -25,7 +25,7 @@
+
+ #include <gif_lib.h>
+
+-int list_length( value list )
++static int list_length( value list )
+ {
+ CAMLparam1(list);
+ CAMLlocal1(l);