aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/p5-Geo-Point
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-01-11 22:03:26 +0800
committermiwi <miwi@FreeBSD.org>2009-01-11 22:03:26 +0800
commit3b5488ec2abdc39de27cc40ed970d86af6c1244f (patch)
tree6ec8b85e4af5730b75946e53a7f97fdd47110721 /graphics/p5-Geo-Point
parent8bf5e2ed744d4170156ca08df8d56808532f82e2 (diff)
downloadfreebsd-ports-gnome-3b5488ec2abdc39de27cc40ed970d86af6c1244f.tar.gz
freebsd-ports-gnome-3b5488ec2abdc39de27cc40ed970d86af6c1244f.tar.zst
freebsd-ports-gnome-3b5488ec2abdc39de27cc40ed970d86af6c1244f.zip
Geo::Point tries to abstract coordinate systems. It does not
try to solve all the problems itself, but will call-out for helper modules when computation has to be done. The module is heavily resting on Math::Polygon. WWW: http://search.cpan.org/dist/Geo-Point/ PR: ports/130360 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'graphics/p5-Geo-Point')
-rw-r--r--graphics/p5-Geo-Point/Makefile28
-rw-r--r--graphics/p5-Geo-Point/distinfo3
-rw-r--r--graphics/p5-Geo-Point/pkg-descr7
-rw-r--r--graphics/p5-Geo-Point/pkg-plist18
4 files changed, 56 insertions, 0 deletions
diff --git a/graphics/p5-Geo-Point/Makefile b/graphics/p5-Geo-Point/Makefile
new file mode 100644
index 000000000000..b1419f1feea1
--- /dev/null
+++ b/graphics/p5-Geo-Point/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Geo-Point
+# Date created: 07 January 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Geo-Point
+PORTVERSION= 0.09
+CATEGORIES= graphics devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Perl Module Tries To Abstract Coordinate Systems
+
+RUN_DEPENDS= ${SITE_PERL}/Test/Simple.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ p5-Geo-Distance>=0.06:${PORTSDIR}/math/p5-Geo-Distance \
+ p5-Geo-Proj4>=1.00:${PORTSDIR}/graphics/p5-Geo-Proj4 \
+ p5-Math-Complex>=1.54:${PORTSDIR}/math/p5-Math-Complex \
+ p5-Math-Polygon>=1.00:${PORTSDIR}/math/p5-Math-Polygon
+
+MAN3= Geo::Point.3 Geo::Shape.3 Geo::Surface.3 \
+ Geo::Line.3 Geo::Proj.3 Geo::Space.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-Geo-Point/distinfo b/graphics/p5-Geo-Point/distinfo
new file mode 100644
index 000000000000..c1355c0ceaed
--- /dev/null
+++ b/graphics/p5-Geo-Point/distinfo
@@ -0,0 +1,3 @@
+MD5 (Geo-Point-0.09.tar.gz) = d376f90b49ca9ccd9656d7e6a51fda99
+SHA256 (Geo-Point-0.09.tar.gz) = f4b7a7afe0e55ac26ea88b7a942328ba16bfed3fb1cbc112e143695a89269f7d
+SIZE (Geo-Point-0.09.tar.gz) = 22712
diff --git a/graphics/p5-Geo-Point/pkg-descr b/graphics/p5-Geo-Point/pkg-descr
new file mode 100644
index 000000000000..4e057f737b87
--- /dev/null
+++ b/graphics/p5-Geo-Point/pkg-descr
@@ -0,0 +1,7 @@
+Geo::Point tries to abstract coordinate systems. It does not
+try to solve all the problems itself, but will call-out for
+helper modules when computation has to be done.
+
+The module is heavily resting on Math::Polygon.
+
+WWW: http://search.cpan.org/dist/Geo-Point/
diff --git a/graphics/p5-Geo-Point/pkg-plist b/graphics/p5-Geo-Point/pkg-plist
new file mode 100644
index 000000000000..a35d67c3eea5
--- /dev/null
+++ b/graphics/p5-Geo-Point/pkg-plist
@@ -0,0 +1,18 @@
+%%SITE_PERL%%/mach/auto/Geo/Point/.packlist
+%%SITE_PERL%%/Geo/Surface.pod
+%%SITE_PERL%%/Geo/Point.pod
+%%SITE_PERL%%/Geo/Point.pm
+%%SITE_PERL%%/Geo/Proj.pm
+%%SITE_PERL%%/Geo/Shape.pm
+%%SITE_PERL%%/Geo/Line.pod
+%%SITE_PERL%%/Geo/Surface.pm
+%%SITE_PERL%%/Geo/Line.pm
+%%SITE_PERL%%/Geo/Space.pm
+%%SITE_PERL%%/Geo/Space.pod
+%%SITE_PERL%%/Geo/Proj.pod
+%%SITE_PERL%%/Geo/Shape.pod
+@dirrmtry %%SITE_PERL%%/mach/auto/Geo/Point
+@dirrmtry %%SITE_PERL%%/mach/auto/Geo
+@dirrmtry %%SITE_PERL%%/mach/auto
+@dirrmtry %%SITE_PERL%%/mach
+@dirrmtry %%SITE_PERL%%/Geo