aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/p5-Gimp
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-09-05 00:50:22 +0800
committermat <mat@FreeBSD.org>2014-09-05 00:50:22 +0800
commit7a1d5f6499f887a5f1815a3b069890eeea86b6af (patch)
tree09e781c47b3e763ddb49c290e88ff5c352af72db /graphics/p5-Gimp
parent6b7c25326fa0d950adf1f86b20d148761f01eee4 (diff)
downloadfreebsd-ports-gnome-7a1d5f6499f887a5f1815a3b069890eeea86b6af.tar.gz
freebsd-ports-gnome-7a1d5f6499f887a5f1815a3b069890eeea86b6af.tar.zst
freebsd-ports-gnome-7a1d5f6499f887a5f1815a3b069890eeea86b6af.zip
Resurect p5-Gimp, it has an upstream again.
Sponsored by: Absolight
Diffstat (limited to 'graphics/p5-Gimp')
-rw-r--r--graphics/p5-Gimp/Makefile31
-rw-r--r--graphics/p5-Gimp/distinfo2
-rw-r--r--graphics/p5-Gimp/files/patch-examples__Makefile.PL21
-rw-r--r--graphics/p5-Gimp/pkg-descr3
-rw-r--r--graphics/p5-Gimp/pkg-plist98
5 files changed, 155 insertions, 0 deletions
diff --git a/graphics/p5-Gimp/Makefile b/graphics/p5-Gimp/Makefile
new file mode 100644
index 000000000000..bc4560876087
--- /dev/null
+++ b/graphics/p5-Gimp/Makefile
@@ -0,0 +1,31 @@
+# Created by: Mathieu Arnold
+# $FreeBSD$
+
+PORTNAME= Gimp
+PORTVERSION= 2.31
+CATEGORIES= graphics perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Write GIMP extensions/plug-ins/load- and save-handlers in Perl
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+RUN_DEPENDS= p5-Gtk2>=1.0:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
+ PDL>=2.007:${PORTSDIR}/math/PDL \
+ p5-IO-All>=0:${PORTSDIR}/devel/p5-IO-All \
+ p5-Gtk2-Ex-PodViewer>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2-Ex-PodViewer \
+ p5-IO-stringy>=0:${PORTSDIR}/devel/p5-IO-stringy \
+ p5-Web-Scraper>=0:${PORTSDIR}/www/p5-Web-Scraper \
+ p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser
+BUILD_DEPENDS= p5-ExtUtils-Depends>=0.200:${PORTSDIR}/devel/p5-ExtUtils-Depends \
+ p5-ExtUtils-PkgConfig>=1:${PORTSDIR}/devel/p5-ExtUtils-PkgConfig \
+ ${RUN_DEPENDS}
+LIB_DEPENDS= libgimp-2.0.so:${PORTSDIR}/graphics/gimp-app
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-Gimp/distinfo b/graphics/p5-Gimp/distinfo
new file mode 100644
index 000000000000..2a2d9c8df6d5
--- /dev/null
+++ b/graphics/p5-Gimp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Gimp-2.31.tar.gz) = 151d12348ea24b872425ad9410d915e17008bd4344dbdc520fbd6e8b87cb4393
+SIZE (Gimp-2.31.tar.gz) = 448538
diff --git a/graphics/p5-Gimp/files/patch-examples__Makefile.PL b/graphics/p5-Gimp/files/patch-examples__Makefile.PL
new file mode 100644
index 000000000000..0988a6b8beb2
--- /dev/null
+++ b/graphics/p5-Gimp/files/patch-examples__Makefile.PL
@@ -0,0 +1,21 @@
+--- examples/Makefile.PL.orig 2014-06-19 14:53:12 UTC
++++ examples/Makefile.PL
+@@ -48,7 +48,8 @@
+ my $dest = '$(GIMP_PLUGINS)/'.basename($plugin);
+ <<EOF;
+ $dest : $src
+- \$(NOECHO) \$(GTINSTALL) "$src"
++ \$(NOECHO) \$(MKPATH) \$(GIMP_PLUGINS)
++ \$(CP) "$src" "$dest"
+
+ EOF
+ }
+@@ -73,7 +74,7 @@
+ <<EOF;
+
+ INST_PLUGINS = ../blib/plugins
+-GIMP_PLUGINS = $cfg{gimpplugindir}
++GIMP_PLUGINS = \$(DESTDIR)$cfg{gimpplugindir}
+
+ \$(INST_PLUGINS)\$(DFSEP).exists :: Makefile.PL
+ \$(NOECHO) \$(MKPATH) \$(INST_PLUGINS)
diff --git a/graphics/p5-Gimp/pkg-descr b/graphics/p5-Gimp/pkg-descr
new file mode 100644
index 000000000000..a40297f77cfa
--- /dev/null
+++ b/graphics/p5-Gimp/pkg-descr
@@ -0,0 +1,3 @@
+Gimp - Perl extension for writing Gimp Extension/Plug-ins/Load & Save-Handlers.
+
+WWW: http://search.cpan.org/dist/Gimp/
diff --git a/graphics/p5-Gimp/pkg-plist b/graphics/p5-Gimp/pkg-plist
new file mode 100644
index 000000000000..6b938ed3d7e9
--- /dev/null
+++ b/graphics/p5-Gimp/pkg-plist
@@ -0,0 +1,98 @@
+bin/embedxpm
+bin/gimpdoc
+bin/scm2perl
+bin/xcftopnm
+%%PERL5_MAN3%%/Gimp.3.gz
+%%PERL5_MAN3%%/Gimp::Config.3.gz
+%%PERL5_MAN3%%/Gimp::Data.3.gz
+%%PERL5_MAN3%%/Gimp::Extension.3.gz
+%%PERL5_MAN3%%/Gimp::Fu.3.gz
+%%PERL5_MAN3%%/Gimp::Lib.3.gz
+%%PERL5_MAN3%%/Gimp::Net.3.gz
+%%PERL5_MAN3%%/Gimp::Pod.3.gz
+%%PERL5_MAN3%%/Gimp::UI.3.gz
+%%PERL5_MAN3%%/Gimp::Util.3.gz
+%%SITE_PERL%%/%%PERL_ARCH%%/Gimp.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Gimp/ColorDB.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Gimp/Config.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Gimp/Constant.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Gimp/Data.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Gimp/Extension.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Gimp/Fu.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Gimp/Install/Files.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Gimp/Lib.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Gimp/Lib/Install/typemap
+%%SITE_PERL%%/%%PERL_ARCH%%/Gimp/Lib/Install/typemap.pdl
+%%SITE_PERL%%/%%PERL_ARCH%%/Gimp/Net.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Gimp/Pod.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Gimp/UI.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Gimp/UI/Install/typemap
+%%SITE_PERL%%/%%PERL_ARCH%%/Gimp/Util.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Gimp/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Gimp/Gimp.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Gimp/Lib/Lib.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Gimp/Net/Net.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Gimp/UI/UI.so
+libexec/gimp/2.2/plug-ins/Perl-Console
+libexec/gimp/2.2/plug-ins/Perl-Server
+libexec/gimp/2.2/plug-ins/animate_cells
+libexec/gimp/2.2/plug-ins/blended2
+libexec/gimp/2.2/plug-ins/blowinout
+libexec/gimp/2.2/plug-ins/bricks
+libexec/gimp/2.2/plug-ins/burst
+libexec/gimp/2.2/plug-ins/centerguide
+libexec/gimp/2.2/plug-ins/colorhtml
+libexec/gimp/2.2/plug-ins/dataurl
+libexec/gimp/2.2/plug-ins/ditherize
+libexec/gimp/2.2/plug-ins/dots
+libexec/gimp/2.2/plug-ins/dust
+libexec/gimp/2.2/plug-ins/example-fu
+libexec/gimp/2.2/plug-ins/exceptiontest
+libexec/gimp/2.2/plug-ins/fade-alpha
+libexec/gimp/2.2/plug-ins/frame_filter
+libexec/gimp/2.2/plug-ins/frame_reshuffle
+libexec/gimp/2.2/plug-ins/glowing_steel
+libexec/gimp/2.2/plug-ins/goldenmean
+libexec/gimp/2.2/plug-ins/gouge
+libexec/gimp/2.2/plug-ins/guidegrid
+libexec/gimp/2.2/plug-ins/guides_to_selection
+libexec/gimp/2.2/plug-ins/iland
+libexec/gimp/2.2/plug-ins/image_tile
+libexec/gimp/2.2/plug-ins/innerbevel
+libexec/gimp/2.2/plug-ins/layerfuncs
+libexec/gimp/2.2/plug-ins/map_to_gradient
+libexec/gimp/2.2/plug-ins/mirrorsplit
+libexec/gimp/2.2/plug-ins/perlotine
+libexec/gimp/2.2/plug-ins/pixelmap
+libexec/gimp/2.2/plug-ins/prep4gif
+libexec/gimp/2.2/plug-ins/randomart1
+libexec/gimp/2.2/plug-ins/randomblends
+libexec/gimp/2.2/plug-ins/redeye
+libexec/gimp/2.2/plug-ins/registry_viewer
+libexec/gimp/2.2/plug-ins/repdup
+libexec/gimp/2.2/plug-ins/scratches
+libexec/gimp/2.2/plug-ins/selective_sharpen
+libexec/gimp/2.2/plug-ins/sethspin
+libexec/gimp/2.2/plug-ins/stamps
+libexec/gimp/2.2/plug-ins/translogo
+libexec/gimp/2.2/plug-ins/warp-sharp
+libexec/gimp/2.2/plug-ins/webify
+libexec/gimp/2.2/plug-ins/windify
+libexec/gimp/2.2/plug-ins/xachlego
+libexec/gimp/2.2/plug-ins/xachshadow
+libexec/gimp/2.2/plug-ins/xachvision
+libexec/gimp/2.2/plug-ins/yinyang
+man/man1/embedxpm.1.gz
+man/man1/gimpdoc.1.gz
+man/man1/scm2perl.1.gz
+man/man1/xcftopnm.1.gz
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Gimp/Install
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Gimp/Lib/Install
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Gimp/Lib
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Gimp/UI/Install
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Gimp/UI
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Gimp
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Gimp/Lib
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Gimp/Net
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Gimp/UI
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Gimp