aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/piddle/Makefile
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>2000-09-25 20:30:49 +0800
committertg <tg@FreeBSD.org>2000-09-25 20:30:49 +0800
commitcd2a7db59fc5aafd14503eb2c5a55613df89d275 (patch)
treeb2a3bb0b7bb36e7c43b2407d36e72519691ed9d2 /graphics/piddle/Makefile
parent587ebcc393a8aa9592d8756d65638dee12f528f7 (diff)
downloadfreebsd-ports-gnome-cd2a7db59fc5aafd14503eb2c5a55613df89d275.tar.gz
freebsd-ports-gnome-cd2a7db59fc5aafd14503eb2c5a55613df89d275.tar.zst
freebsd-ports-gnome-cd2a7db59fc5aafd14503eb2c5a55613df89d275.zip
Use USE_PYTHON.
PR: 21509 Submitted by: Dominic Mitchell <dom@happygiraffe.net>
Diffstat (limited to 'graphics/piddle/Makefile')
-rw-r--r--graphics/piddle/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/graphics/piddle/Makefile b/graphics/piddle/Makefile
index 87b108d21033..0e0ce99de065 100644
--- a/graphics/piddle/Makefile
+++ b/graphics/piddle/Makefile
@@ -14,13 +14,11 @@ DISTFILES= ${DISTNAME}-5.tgz
MAINTAINER= dom@myrddin.demon.co.uk
-RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
-
+USE_PYTHON= yes
+WRKSRC= ${WRKDIR}/${PKGNAME}
NO_BUILD= yes
-PYTHON?= ${LOCALBASE}/bin/python
-PYTHONLIBDIR?= ${LOCALBASE}/lib/python1.5
-PIDDLEDIR= ${PYTHONLIBDIR}/site-packages/piddle
+PIDDLEDIR= ${PYTHON_SITELIBDIR}/piddle
PIDDLEDOCDIR= ${PREFIX}/share/doc/piddle
PIDDLEEGDIR= ${PREFIX}/share/examples/piddle
@@ -38,8 +36,8 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/pilfonts/*.pbm ${PIDDLEDIR}/pilfonts
${INSTALL_DATA} ${WRKSRC}/pilfonts/metrics.dat ${PIDDLEDIR}/pilfonts
${ECHO} 'piddle' > ${PIDDLEDIR}.pth
- @${PYTHON} ${PYTHONLIBDIR}/compileall.py ${PIDDLEDIR}
- @${PYTHON} -O ${PYTHONLIBDIR}/compileall.py ${PIDDLEDIR}
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${PIDDLEDIR}
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${PIDDLEDIR}
${MKDIR} ${PIDDLEDOCDIR}
(cd ${WRKSRC}/docs ; tar cf - *) | \
(cd ${PIDDLEDOCDIR} ; tar xf -)