aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/podofo
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-05-08 05:26:29 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-05-08 05:26:29 +0800
commit5b8ebbfd36aca0ca05298582b1c1abb6eef682a1 (patch)
tree95a418c367f5af57c79063461e735fa8b39c28fd /graphics/podofo
parente1b82c4f1638e67be3cd8e340ba92d40a8be19a8 (diff)
downloadfreebsd-ports-gnome-5b8ebbfd36aca0ca05298582b1c1abb6eef682a1.tar.gz
freebsd-ports-gnome-5b8ebbfd36aca0ca05298582b1c1abb6eef682a1.tar.zst
freebsd-ports-gnome-5b8ebbfd36aca0ca05298582b1c1abb6eef682a1.zip
Update to 0.9.5
- Build and install static library - Use _CMAKE_BOOL - Update pkg-descr - Take maintainership
Diffstat (limited to 'graphics/podofo')
-rw-r--r--graphics/podofo/Makefile41
-rw-r--r--graphics/podofo/distinfo6
-rw-r--r--graphics/podofo/files/patch-cmake-modules-FindLua51.cmake (renamed from graphics/podofo/files/patch-cmake_modules_FindLua51.cmake)0
-rw-r--r--graphics/podofo/files/patch-src-CMakeLists.txt (renamed from graphics/podofo/files/patch-src_CMakeLists.txt)0
-rw-r--r--graphics/podofo/files/patch-src_base_PdfMemoryManagement.cpp19
-rw-r--r--graphics/podofo/pkg-descr16
-rw-r--r--graphics/podofo/pkg-plist6
7 files changed, 36 insertions, 52 deletions
diff --git a/graphics/podofo/Makefile b/graphics/podofo/Makefile
index 45fd507008de..5409f6a3f62d 100644
--- a/graphics/podofo/Makefile
+++ b/graphics/podofo/Makefile
@@ -2,45 +2,42 @@
# $FreeBSD$
PORTNAME= podofo
-PORTVERSION= 0.9.4
-PORTREVISION= 1
+PORTVERSION= 0.9.5
CATEGORIES= graphics print
MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= PDF manipulation library and tools
LICENSE= GPLv2 LGPL21
LICENSE_COMB= multi
-LIB_DEPENDS= libidn.so:dns/libidn \
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
- libfontconfig.so:x11-fonts/fontconfig
+ libidn.so:dns/libidn
-USES= cmake compiler dos2unix ssl
-CMAKE_ARGS= -DPODOFO_BUILD_SHARED:BOOL=TRUE \
- -DPODOFO_BUILD_STATIC:BOOL=FALSE \
- -DOPENSSL_INCLUDE_DIR:PATH="${OPENSSLINC}" \
- -DOPENSSL_LIBRARIES:PATH="${OPENSSLDIR}"
+OPTIONS_DEFINE= IMPOSE JPEG PNG TIFF
+OPTIONS_DEFAULT=JPEG PNG TIFF
+IMPOSE_DESC= Build impose tool (Lua required)
+
+CMAKE_ARGS= -DOPENSSL_INCLUDE_DIR="${OPENSSLINC}" \
+ -DOPENSSL_LIBRARIES="${OPENSSLDIR}" \
+ -DPODOFO_BUILD_SHARED=TRUE \
+ -DPODOFO_BUILD_STATIC=TRUE
USE_LDCONFIG= yes
-DOS2UNIX_FILES= cmake/modules/FindFREETYPE.cmake
+USES= cmake compiler dos2unix ssl
-OPTIONS_DEFINE= IMPOSE JPEG PNG TIFF
-OPTIONS_DEFAULT= JPEG PNG TIFF
+DOS2UNIX_FILES= cmake/modules/FindFREETYPE.cmake
-IMPOSE_DESC= Build impose tool (needs Lua)
-IMPOSE_USES= lua:51
-IMPOSE_CMAKE_ON= -DWANT_LUA:BOOL=TRUE
+IMPOSE_CMAKE_BOOL= WANT_LUA
IMPOSE_CXXFLAGS= -I${LUA_INCDIR}
IMPOSE_LDFLAGS= -L${LUA_LIBDIR}
-
-JPEG_CMAKE_ON= -DWANT_LIBJPEG:BOOL=TRUE
+IMPOSE_USES= lua
+JPEG_CMAKE_BOOL= WANT_LIBJPEG
JPEG_USES= jpeg
-
-PNG_CMAKE_ON= -DWANT_PNG:BOOL=TRUE
+PNG_CMAKE_BOOL= WANT_PNG
PNG_LIB_DEPENDS= libpng.so:graphics/png
-
-TIFF_CMAKE_ON= -DWANT_TIFF:BOOL=TRUE
+TIFF_CMAKE_BOOL= WANT_TIFF
TIFF_LIB_DEPENDS= libtiff.so:graphics/tiff
.include <bsd.port.pre.mk>
diff --git a/graphics/podofo/distinfo b/graphics/podofo/distinfo
index 605c7c278216..baa0a11b0d54 100644
--- a/graphics/podofo/distinfo
+++ b/graphics/podofo/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1465922141
-SHA256 (podofo-0.9.4.tar.gz) = ccdf505fcb4904617e728b15729da8700ff38442c1dd2f24fbd52934287ff859
-SIZE (podofo-0.9.4.tar.gz) = 1147939
+TIMESTAMP = 1494045852
+SHA256 (podofo-0.9.5.tar.gz) = 854981cb897ebc14bac854ea0f25305372261a48a205363fe1c61659ba7b5304
+SIZE (podofo-0.9.5.tar.gz) = 1160799
diff --git a/graphics/podofo/files/patch-cmake_modules_FindLua51.cmake b/graphics/podofo/files/patch-cmake-modules-FindLua51.cmake
index 5868cf76650d..5868cf76650d 100644
--- a/graphics/podofo/files/patch-cmake_modules_FindLua51.cmake
+++ b/graphics/podofo/files/patch-cmake-modules-FindLua51.cmake
diff --git a/graphics/podofo/files/patch-src_CMakeLists.txt b/graphics/podofo/files/patch-src-CMakeLists.txt
index 4aec29293c76..4aec29293c76 100644
--- a/graphics/podofo/files/patch-src_CMakeLists.txt
+++ b/graphics/podofo/files/patch-src-CMakeLists.txt
diff --git a/graphics/podofo/files/patch-src_base_PdfMemoryManagement.cpp b/graphics/podofo/files/patch-src_base_PdfMemoryManagement.cpp
deleted file mode 100644
index df25e1fd6e05..000000000000
--- a/graphics/podofo/files/patch-src_base_PdfMemoryManagement.cpp
+++ /dev/null
@@ -1,19 +0,0 @@
---- src/base/PdfMemoryManagement.cpp.orig 2016-07-03 09:12:06 UTC
-+++ src/base/PdfMemoryManagement.cpp
-@@ -34,15 +34,9 @@
- #include "PdfMemoryManagement.h"
- #include "PdfDefinesPrivate.h"
-
--#ifdef _WIN32
- #ifndef SIZE_MAX
--#ifdef _WIN64
--#define SIZE_MAX _UI64_MAX
--#else
--#define SIZE_MAX UINT_MAX
--#endif
-+#define SIZE_MAX std::numeric_limits<size_t>::max()
- #endif
--#endif // _WIN32
-
- #if defined(_MSC_VER) && ( _MSC_VER <= 1200 )
- // errno.h isn't available in Visual C++ 6 (definitions are in stdlib.h which is already included)
diff --git a/graphics/podofo/pkg-descr b/graphics/podofo/pkg-descr
index ca311e73f70f..d855d9f67c8f 100644
--- a/graphics/podofo/pkg-descr
+++ b/graphics/podofo/pkg-descr
@@ -1,5 +1,13 @@
-PoDoFo is a library to work with the PDF file format. The name comes
-from the first letter of PDF (Portable Document Format). A few tools
-to work with PDF files are already included in the PoDoFo package.
+PoDoFo is a library to work with the PDF file format. The name comes from the
+first letter of PDF (Portable Document Format). A few tools to work with PDF
+files are already included in the PoDoFo package.
-WWW: http://podofo.sourceforge.net
+The PoDoFo library is a free, portable C++ library which includes classes to
+parse PDF files and modify their contents into memory. The changes can be
+written back to disk easily. The parser can also be used to extract information
+from a PDF file (for example the parser could be used in a PDF viewer). Besides
+parsing PoDoFo includes also very simple classes to create your own PDF files.
+All classes are documented so it is easy to start writing your own application
+using PoDoFo.
+
+WWW: http://podofo.sourceforge.net/
diff --git a/graphics/podofo/pkg-plist b/graphics/podofo/pkg-plist
index ca3a71cbf0d1..8032f5d48b4d 100644
--- a/graphics/podofo/pkg-plist
+++ b/graphics/podofo/pkg-plist
@@ -11,6 +11,7 @@ bin/podofoincrementalupdates
bin/podofomerge
bin/podofopages
bin/podofopdfinfo
+bin/podofosign
bin/podofotxt2pdf
bin/podofotxtextract
bin/podofouncompress
@@ -53,7 +54,6 @@ include/podofo/base/PdfRect.h
include/podofo/base/PdfRefCountedBuffer.h
include/podofo/base/PdfRefCountedInputDevice.h
include/podofo/base/PdfReference.h
-include/podofo/base/PdfSigIncWriter.h
include/podofo/base/PdfStream.h
include/podofo/base/PdfString.h
include/podofo/base/PdfTokenizer.h
@@ -114,9 +114,6 @@ include/podofo/doc/PdfPagesTreeCache.h
include/podofo/doc/PdfPainter.h
include/podofo/doc/PdfPainterMM.h
include/podofo/doc/PdfShadingPattern.h
-include/podofo/doc/PdfSigIncMemDocument.h
-include/podofo/doc/PdfSigIncPainter.h
-include/podofo/doc/PdfSigIncSignatureField.h
include/podofo/doc/PdfSignOutputDevice.h
include/podofo/doc/PdfSignatureField.h
include/podofo/doc/PdfStreamedDocument.h
@@ -125,6 +122,7 @@ include/podofo/doc/PdfTilingPattern.h
include/podofo/doc/PdfXObject.h
include/podofo/podofo-base.h
include/podofo/podofo.h
+lib/libpodofo.a
lib/libpodofo.so
lib/libpodofo.so.0
man/man1/podofobox.1.gz