aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/podofo
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-07-21 04:34:06 +0800
committertcberner <tcberner@FreeBSD.org>2018-07-21 04:34:06 +0800
commitb2ade2a1d4accd5b591d73445c5a017ac061cf03 (patch)
tree62dff5eb65ca749123678a065c75a37ff7c28fa4 /graphics/podofo
parentbbcb67694e3c40445876cc1b5cf4771b037029b0 (diff)
downloadfreebsd-ports-gnome-b2ade2a1d4accd5b591d73445c5a017ac061cf03.tar.gz
freebsd-ports-gnome-b2ade2a1d4accd5b591d73445c5a017ac061cf03.tar.zst
freebsd-ports-gnome-b2ade2a1d4accd5b591d73445c5a017ac061cf03.zip
graphics/podofo: Add patch to fix build with upcomeing cmake-3.12
The behaviour of cmake's copy_directory was changed, so that it now fails if the source directory does not exist. PR: 229854 Reported by: antoine
Diffstat (limited to 'graphics/podofo')
-rw-r--r--graphics/podofo/files/patch-test_TokenizerTest_CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/graphics/podofo/files/patch-test_TokenizerTest_CMakeLists.txt b/graphics/podofo/files/patch-test_TokenizerTest_CMakeLists.txt
new file mode 100644
index 000000000000..213168ffbd8f
--- /dev/null
+++ b/graphics/podofo/files/patch-test_TokenizerTest_CMakeLists.txt
@@ -0,0 +1,11 @@
+Prior to 3.12 cmake silently created an empty destination directory if the origin of the copy_directory does not exist.
+
+--- test/TokenizerTest/CMakeLists.txt.orig 2007-09-16 09:33:38 UTC
++++ test/TokenizerTest/CMakeLists.txt
+@@ -7,5 +7,6 @@ ADD_DEPENDENCIES(TokenizerTest ${PODOFO_DEPEND_TARGET}
+ ADD_CUSTOM_COMMAND(
+ TARGET TokenizerTest
+ POST_BUILD
++ COMMAND "${CMAKE_COMMAND}" -E make_directory "${CMAKE_CURRENT_SOURCE_DIR}/objects"
+ COMMAND "${CMAKE_COMMAND}" -E copy_directory "${CMAKE_CURRENT_SOURCE_DIR}/objects" "${CMAKE_CURRENT_BINARY_DIR}/objects"
+ )