aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/potracegui/files
diff options
context:
space:
mode:
authormarkus <markus@FreeBSD.org>2006-01-10 18:31:46 +0800
committermarkus <markus@FreeBSD.org>2006-01-10 18:31:46 +0800
commit83e9d684f5fd4d7ca56e952a039203e8da448a68 (patch)
treee5f2bc374246b8c17b067f395f1b144a5eb43edf /graphics/potracegui/files
parentaf526ca3bec7016c4b0e86ae431f14986e203db1 (diff)
downloadfreebsd-ports-gnome-83e9d684f5fd4d7ca56e952a039203e8da448a68.tar.gz
freebsd-ports-gnome-83e9d684f5fd4d7ca56e952a039203e8da448a68.tar.zst
freebsd-ports-gnome-83e9d684f5fd4d7ca56e952a039203e8da448a68.zip
- Update to version 1.3.4
- Add SHA256 - Remove dirs from pkg-plist which are already covered by misc/kdehier
Diffstat (limited to 'graphics/potracegui/files')
-rw-r--r--graphics/potracegui/files/patch-pixelview.cpp16
-rw-r--r--graphics/potracegui/files/patch-pixelview.h11
-rw-r--r--graphics/potracegui/files/patch-po-Makefile.in153
3 files changed, 180 insertions, 0 deletions
diff --git a/graphics/potracegui/files/patch-pixelview.cpp b/graphics/potracegui/files/patch-pixelview.cpp
new file mode 100644
index 000000000000..98fcb373c44a
--- /dev/null
+++ b/graphics/potracegui/files/patch-pixelview.cpp
@@ -0,0 +1,16 @@
+--- src/pixelview.cpp.orig Tue Jan 10 02:18:12 2006
++++ src/pixelview.cpp Tue Jan 10 11:12:14 2006
+@@ -169,11 +169,11 @@
+ internThresholdPercent = m_thresholdPercent;
+
+ //initialize variables
+- unsigned int m_threshold = static_cast<unsigned int>(round(255*m_thresholdPercent/100));
++ unsigned int m_threshold = static_cast<unsigned int>(rint(255*m_thresholdPercent/100));
+
+ //do the necessary recalculations
+ if ( //if new thresholding is nesecarry. This is the case when
+- ( internThresholdingEnabled != m_thresholdingEnabled ) or //thresholding was enabled or disabled OR
++ ( internThresholdingEnabled != m_thresholdingEnabled ) || //thresholding was enabled or disabled OR
+ ( internThreshold != m_threshold ) //another threshold is given.
+ )
+ {
diff --git a/graphics/potracegui/files/patch-pixelview.h b/graphics/potracegui/files/patch-pixelview.h
new file mode 100644
index 000000000000..edb13d7c6ae3
--- /dev/null
+++ b/graphics/potracegui/files/patch-pixelview.h
@@ -0,0 +1,11 @@
+--- src/pixelview.h.orig Tue Jan 10 02:16:14 2006
++++ src/pixelview.h Tue Jan 10 02:16:41 2006
+@@ -34,7 +34,7 @@
+ /**
+ @author Tim Fechtner
+ */
+-class PixelView : protected QScrollView
++class PixelView : public QScrollView
+ {
+ Q_OBJECT
+ public:
diff --git a/graphics/potracegui/files/patch-po-Makefile.in b/graphics/potracegui/files/patch-po-Makefile.in
new file mode 100644
index 000000000000..652825c98be4
--- /dev/null
+++ b/graphics/potracegui/files/patch-po-Makefile.in
@@ -0,0 +1,153 @@
+--- po/Makefile.in.orig Tue Jan 10 01:24:24 2006
++++ po/Makefile.in Tue Jan 10 01:24:51 2006
+@@ -1,9 +1,9 @@
+-# Makefile.in generated by automake 1.8.3 from Makefile.am.
++# Makefile.in generated by automake 1.9.6 from Makefile.am.
+ # KDE tags expanded automatically by am_edit - $Revision: 1.1.1.1 $
+ # @configure_input@
+
+ # Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
+-# 2003, 2004 Free Software Foundation, Inc.
++# 2003, 2004, 2005 Free Software Foundation, Inc.
+ # This Makefile.in is free software; the Free Software Foundation
+ # gives unlimited permission to copy and/or distribute it,
+ # with or without modifications, as long as this notice is preserved.
+@@ -51,7 +51,9 @@
+ DIST_SOURCES =
+ #>- DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
+ #>+ 1
+-DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST) $(KDE_DIST)
++#>- DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST) $(KDE_DIST)
++#>+ 1
++DISTFILES = $(GMOFILES) $(POFILES) $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST) $(KDE_DIST)
+ ACLOCAL = @ACLOCAL@
+ AMDEP_FALSE = @AMDEP_FALSE@
+ AMDEP_TRUE = @AMDEP_TRUE@
+@@ -207,6 +209,8 @@
+ am__include = @am__include@
+ am__leading_dot = @am__leading_dot@
+ am__quote = @am__quote@
++am__tar = @am__tar@
++am__untar = @am__untar@
+ bindir = @bindir@
+ build = @build@
+ build_alias = @build_alias@
+@@ -271,10 +275,13 @@
+ xdg_appsdir = @xdg_appsdir@
+ xdg_directorydir = @xdg_directorydir@
+ xdg_menudir = @xdg_menudir@
+-POFILES = AUTO
++#>- POFILES = AUTO
++#>+ 2
++POFILES = de.po
++GMOFILES = de.gmo
+ #>- all: all-am
+ #>+ 1
+-all: docs-am all-am
++all: all-nls docs-am all-am
+
+ .SUFFIXES:
+ $(srcdir)/Makefile.in: $(srcdir)/Makefile.am $(am__configure_deps)
+@@ -336,7 +343,9 @@
+ CTAGS:
+
+
+-distdir: $(DISTFILES)
++#>- distdir: $(DISTFILES)
++#>+ 1
++distdir: distdir-nls $(DISTFILES)
+ @srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`; \
+ topsrcdirstrip=`echo "$(top_srcdir)" | sed 's|.|.|g'`; \
+ list='$(DISTFILES)'; for file in $$list; do \
+@@ -370,7 +379,9 @@
+ install: install-am
+ install-exec: install-exec-am
+ install-data: install-data-am
+-uninstall: uninstall-am
++#>- uninstall: uninstall-am
++#>+ 1
++uninstall: uninstall-nls uninstall-am
+
+ install-am: all-am
+ @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
+@@ -386,7 +397,7 @@
+ clean-generic:
+
+ distclean-generic:
+- -rm -f $(CONFIG_CLEAN_FILES)
++ -test -z "$(CONFIG_CLEAN_FILES)" || rm -f $(CONFIG_CLEAN_FILES)
+
+ maintainer-clean-generic:
+ @echo "This command is intended for maintainers to use"
+@@ -413,7 +424,9 @@
+
+ info-am:
+
+-install-data-am:
++#>- install-data-am:
++#>+ 1
++install-data-am: install-nls
+
+ install-exec-am:
+
+@@ -423,7 +436,9 @@
+
+ installcheck-am:
+
+-maintainer-clean: maintainer-clean-am
++#>- maintainer-clean: maintainer-clean-am
++#>+ 1
++maintainer-clean: clean-nls maintainer-clean-am
+ -rm -f Makefile
+ maintainer-clean-am: distclean-am maintainer-clean-generic
+
+@@ -456,7 +471,48 @@
+ .NOEXPORT:
+
+ #>+ 2
+-KDE_DIST=Makefile.in Makefile.am
++KDE_DIST=Makefile.in potracegui.pot de.po Makefile.am
++
++#>+ 4
++de.gmo: de.po
++ rm -f de.gmo; $(GMSGFMT) -o de.gmo $(srcdir)/de.po
++ test ! -f de.gmo || touch de.gmo
++
++#>+ 3
++clean-nls:
++ -rm -f de.gmo
++
++#>+ 10
++install-nls:
++ @for base in de ; do \
++ echo $(INSTALL_DATA) $$base.gmo $(DESTDIR)$(kde_locale)/$$base/LC_MESSAGES/$(PACKAGE).mo ;\
++ $(mkinstalldirs) $(DESTDIR)$(kde_locale)/$$base/LC_MESSAGES ; \
++ if test -f $$base.gmo; then $(INSTALL_DATA) $$base.gmo $(DESTDIR)$(kde_locale)/$$base/LC_MESSAGES/$(PACKAGE).mo ;\
++ elif test -f $(srcdir)/$$base.gmo; then $(INSTALL_DATA) $(srcdir)/$$base.gmo $(DESTDIR)$(kde_locale)/$$base/LC_MESSAGES/$(PACKAGE).mo ;\
++ fi ;\
++ done
++
++
++#>+ 3
++uninstall-nls:
++ rm -f $(DESTDIR)$(kde_locale)/de/LC_MESSAGES/$(PACKAGE).mo
++
++#>+ 2
++all-nls: $(GMOFILES)
++
++#>+ 8
++distdir-nls:$(GMOFILES)
++ for file in $(POFILES); do \
++ cp $(srcdir)/$$file $(distdir); \
++ done
++ for file in $(GMOFILES); do \
++ cp $(srcdir)/$$file $(distdir); \
++ done
++
++#>+ 4
++merge:
++ $(MAKE) -f $(top_srcdir)/admin/Makefile.common package-merge POFILES="${POFILES}" PACKAGE=${PACKAGE}
++
+
+ #>+ 2
+ docs-am: