aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/povray36
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2012-06-01 13:26:28 +0800
committerdinoex <dinoex@FreeBSD.org>2012-06-01 13:26:28 +0800
commit530706893f31269bbfa303e069f2e76cbbe2fce7 (patch)
treea8077a0d6e20d70b39e6a7fe3e57a6dafe7c7f33 /graphics/povray36
parent9d262811a145d3e715edefd1d5d64ceac41de547 (diff)
downloadfreebsd-ports-gnome-530706893f31269bbfa303e069f2e76cbbe2fce7.tar.gz
freebsd-ports-gnome-530706893f31269bbfa303e069f2e76cbbe2fce7.tar.zst
freebsd-ports-gnome-530706893f31269bbfa303e069f2e76cbbe2fce7.zip
- update png to 1.5.10
Diffstat (limited to 'graphics/povray36')
-rw-r--r--graphics/povray36/Makefile6
-rw-r--r--graphics/povray36/files/patch-png_pov.cpp104
2 files changed, 105 insertions, 5 deletions
diff --git a/graphics/povray36/Makefile b/graphics/povray36/Makefile
index 2fab13fe4fab..5d7c66378e30 100644
--- a/graphics/povray36/Makefile
+++ b/graphics/povray36/Makefile
@@ -7,7 +7,7 @@
PORTNAME= povray
PORTVERSION= 3.6.1
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.povray.org/pub/povray/%SUBDIR%/ \
ftp://ftp.mirrorservice.org/sites/ftp.povray.org/pub/povray/%SUBDIR%/ \
@@ -21,7 +21,7 @@ COMMENT= Persistence of Vision Ray Tracer
.if defined(WITH_ICC)
BUILD_DEPENDS= ${LOCALBASE}/intel_cc_80/bin/icc:${PORTSDIR}/lang/icc
.endif
-LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
tiff:${PORTSDIR}/graphics/tiff \
jpeg:${PORTSDIR}/graphics/jpeg
@@ -54,6 +54,8 @@ CFLAGS= -O3 -tpp7 -axN -Vaxlib
CXXFLAGS= -O3 -tpp7 -axN -Vaxlib
.endif
+CFLAGS+= -I${LOCALBASE}/include/libpng15
+CXXFLAGS+= -I${LOCALBASE}/include/libpng15
CONFIGURE_ARGS= --x-includes="${LOCALBASE}/include" --includedir=${LOCALBASE} \
CXXFLAGS="${CXXFLAGS} -L${LOCALBASE}/lib" \
CFLAGS="${CFLAGS} -L${LOCALBASE}/lib" \
diff --git a/graphics/povray36/files/patch-png_pov.cpp b/graphics/povray36/files/patch-png_pov.cpp
index 01225b66021e..de3b006562ba 100644
--- a/graphics/povray36/files/patch-png_pov.cpp
+++ b/graphics/povray36/files/patch-png_pov.cpp
@@ -1,6 +1,104 @@
--- source/png_pov.cpp.orig 2004-08-03 01:11:37.000000000 +0200
-+++ source/png_pov.cpp 2010-03-29 14:06:26.000000000 +0200
-@@ -1428,7 +1428,7 @@
++++ source/png_pov.cpp 2012-05-05 07:35:49.000000000 +0200
+@@ -53,6 +53,7 @@
+ #include "pov_util.h"
+ #include "povmsend.h"
+ #include "colour.h"
++#include "pngpriv.h"
+
+ USING_POV_NAMESPACE
+
+@@ -167,7 +168,7 @@
+ if (png_get_error_ptr(png_ptr))
+ PossibleError("libpng: %s",msg);
+
+- longjmp(png_ptr->jmpbuf,1);
++ longjmp(png_jmpbuf(png_ptr),1);
+ }
+
+
+@@ -387,7 +388,7 @@
+ Error("Cannot allocate PNG data structures");
+ }
+
+- if (setjmp(o_png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(o_png_ptr)))
+ {
+ // If we get here, we had a problem reading the file
+ png_destroy_read_struct(&o_png_ptr, &info_ptr, (png_infopp)NULL);
+@@ -433,7 +434,7 @@
+ Error("Cannot allocate PNG data structures");
+ }
+
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ // If we get here, we had a problem writing the file
+ png_destroy_read_struct(&o_png_ptr, &info_ptr, (png_infopp)NULL);
+@@ -529,7 +530,7 @@
+ Error("Cannot allocate PNG data structures");
+ }
+
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ // If we get here, we had a problem writing the file
+ png_destroy_write_struct(&png_ptr, &info_ptr);
+@@ -647,7 +648,7 @@
+ case APPEND_MODE:
+
+ #if defined(PNG_WRITE_FLUSH_SUPPORTED)
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ // If we get here, we had a problem writing the file
+
+@@ -756,7 +757,7 @@
+
+ if (png_ptr != NULL)
+ {
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ // If we get here, we had a problem writing the file
+
+@@ -1204,7 +1205,7 @@
+ }
+ }
+
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ // If we get here, we had a problem writing the file
+ delete out_file;
+@@ -1252,7 +1253,7 @@
+
+ register int col, j, step;
+
+- if (setjmp(o_png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(o_png_ptr)))
+ {
+ /* If we get here, we had a problem reading the file, which probably
+ * means that we have read all the available data, rather than a real
+@@ -1261,7 +1262,7 @@
+ return 0;
+ }
+
+- if (setjmp(png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ {
+ // If we get here, we had a problem writing the new file
+ delete in_file;
+@@ -1377,7 +1378,7 @@
+ ((r_info_ptr = png_create_info_struct(r_png_ptr)) == NULL))
+ Error("Cannot allocate PNG data structures");
+
+- if(setjmp(r_png_ptr->jmpbuf))
++ if(setjmp(png_jmpbuf(r_png_ptr)))
+ {
+ // If we get here, we had a problem reading the file
+ png_destroy_read_struct(&r_png_ptr, &r_info_ptr, (png_infopp)NULL);
+@@ -1428,7 +1429,7 @@
if(r_info_ptr->valid & PNG_INFO_tRNS)
{
for (index = 0; index < r_info_ptr->num_trans; index++)
@@ -9,7 +107,7 @@
}
Image->data.map_lines = (unsigned char **)POV_MALLOC(height * sizeof(unsigned char *), "PNG image");
-@@ -1461,7 +1461,7 @@
+@@ -1461,7 +1462,7 @@
if(r_info_ptr->valid & PNG_INFO_tRNS)
{
for (index = 0; index < r_info_ptr->num_trans; index++)