aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/py-stl/Makefile
diff options
context:
space:
mode:
authorscheidell <scheidell@FreeBSD.org>2012-01-12 21:32:14 +0800
committerscheidell <scheidell@FreeBSD.org>2012-01-12 21:32:14 +0800
commitc594cf518e6d159091e6ed0e490cb578779d6703 (patch)
treec4d556f5706714538bfadf4029add16f68d39783 /graphics/py-stl/Makefile
parentf81150a956837ff9684a726c024b566f08dbbd59 (diff)
downloadfreebsd-ports-gnome-c594cf518e6d159091e6ed0e490cb578779d6703.tar.gz
freebsd-ports-gnome-c594cf518e6d159091e6ed0e490cb578779d6703.tar.zst
freebsd-ports-gnome-c594cf518e6d159091e6ed0e490cb578779d6703.zip
- Author of stl2pov has replaced code with python module, py-stl
PR: ports/163698 Submitted by: Roland Smith <rsmith@xs4all.nl> (maintainer) Approved by: maintainer, gabor (mentor)
Diffstat (limited to 'graphics/py-stl/Makefile')
-rw-r--r--graphics/py-stl/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/graphics/py-stl/Makefile b/graphics/py-stl/Makefile
new file mode 100644
index 000000000000..913e5ff518b3
--- /dev/null
+++ b/graphics/py-stl/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: py-stl
+# Date created: 28 Dec 2011
+# Whom: rsmith@xs4all.nl
+#
+# $FreeBSD$
+
+PORTNAME= stl
+PORTVERSION= 3.0
+CATEGORIES= graphics python
+MASTER_SITES= http://rsmith.home.xs4all.nl/software/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= py-${PORTNAME}-${GITVER}
+
+MAINTAINER= rsmith@xs4all.nl
+COMMENT= Converts STL models to POV-Ray meshes or PostScript/PDF images
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}reportlab2>2:${PORTSDIR}/print/py-reportlab2
+
+GITVER= 31a5b12
+
+USE_ZIP= YES
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS= YES
+
+CONFLICTS= stl2pov-[0-9]*
+
+MAN1= stl2ps.1 stlinfo.1 stl2pdf.1
+
+NO_BUILD= YES
+
+post-install:
+ @${INSTALL_MAN} ${WRKSRC}/stl2ps.1 ${MANPREFIX}/man/man1
+ @${INSTALL_MAN} ${WRKSRC}/stlinfo.1 ${MANPREFIX}/man/man1
+ @${INSTALL_MAN} ${WRKSRC}/stl2pdf.1 ${MANPREFIX}/man/man1
+ @${MV} ${PREFIX}/bin/stl2ps.py ${PREFIX}/bin/stl2ps
+ @${MV} ${PREFIX}/bin/stl2pov.py ${PREFIX}/bin/stl2pov
+ @${MV} ${PREFIX}/bin/stlinfo.py ${PREFIX}/bin/stlinfo
+ @${MV} ${PREFIX}/bin/stl2pdf.py ${PREFIX}/bin/stl2pdf
+ @${MV} ${PYTHON_SITELIBDIR}/py_stl-${GITVER}-py${PYTHON_VER}.egg-info ${PYTHON_SITELIBDIR}/${PYDISTUTILS_EGGINFO}
+
+.include <bsd.port.mk>