aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/quesoglc
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-12-29 18:38:18 +0800
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-12-29 18:38:18 +0800
commitae8c2f0880ff02af3f611913e49589f31aec17b5 (patch)
treeb2d46ebe4a7840c0598ecf2ee725cefceb299ba3 /graphics/quesoglc
parentf6c45af718db803116d71aea6510e05ce4a9f8bd (diff)
downloadfreebsd-ports-gnome-ae8c2f0880ff02af3f611913e49589f31aec17b5.tar.gz
freebsd-ports-gnome-ae8c2f0880ff02af3f611913e49589f31aec17b5.tar.zst
freebsd-ports-gnome-ae8c2f0880ff02af3f611913e49589f31aec17b5.zip
- Add LICENSE
- Switch to USES=localbase - Remove unneeded glut dependency - Add missing libX11 dependency - Support tests properly - Switch to options helpers
Diffstat (limited to 'graphics/quesoglc')
-rw-r--r--graphics/quesoglc/Makefile31
1 files changed, 22 insertions, 9 deletions
diff --git a/graphics/quesoglc/Makefile b/graphics/quesoglc/Makefile
index 9b13bb022cb0..b647c836a296 100644
--- a/graphics/quesoglc/Makefile
+++ b/graphics/quesoglc/Makefile
@@ -3,34 +3,47 @@
PORTNAME= quesoglc
PORTVERSION= 0.7.2
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Free implementation of the OpenGL Character Renderer
+LICENSE= LGPL21+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= libfribidi.so:converters/fribidi \
libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig
-USES= tar:bzip2 pathfix gmake libtool
+USES= gmake libtool localbase pathfix pkgconfig tar:bzip2
GNU_CONFIGURE= yes
-USE_GL= gl glu glut
+USE_GL= gl glu
+USE_XORG= x11
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
# needs GLEW MX (multiple rendering contexts), so system glew won't go
CONFIGURE_ARGS= --without-glew --with-fribidi
PORTDOCS= README
-OPTIONS_DEFINE= DOCS
-
-post-install:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+OPTIONS_DEFINE= DOCS TEST
+
+TEST_CONFIGURE_ENABLE= executables
+# these libs are only required for building tests, which are not
+# installed, so no LIB_DEPENDS; tests also require X11 display
+# and are interactive
+TEST_BUILD_DEPENDS= ${LOCALBASE}/lib/libglut.so:graphics/freeglut \
+ ${LOCALBASE}/lib/libSM.so:x11/libSM \
+ ${LOCALBASE}/lib/libICE.so:x11/libICE \
+ ${LOCALBASE}/lib/libXi.so:x11/libXi \
+ ${LOCALBASE}/lib/libXmu.so:x11-toolkits/libXmu
+TEST_TEST_TARGET= check
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>