aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/radius-engine
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2012-05-18 12:40:50 +0800
committermiwi <miwi@FreeBSD.org>2012-05-18 12:40:50 +0800
commitc69911168b86c03870bd6e040331bf0e395f66de (patch)
tree9dfcca5d23ed92da43b0d8ae2f343763d382e52b /graphics/radius-engine
parentd329af229d9d97817d45e560640b5a60b27caab6 (diff)
downloadfreebsd-ports-gnome-c69911168b86c03870bd6e040331bf0e395f66de.tar.gz
freebsd-ports-gnome-c69911168b86c03870bd6e040331bf0e395f66de.tar.zst
freebsd-ports-gnome-c69911168b86c03870bd6e040331bf0e395f66de.zip
Radius Engine is a Lua script-based real-time 2D graphics engine designed
for rapidly prototyping games. Built on top of SDL and OpenGL, games made with Radius Engine are portable to both Windows and Linux. WWW: http://radius-engine.sourceforge.net/ PR: ports/168083 Submitted by: nemysis@gmx.ch
Diffstat (limited to 'graphics/radius-engine')
-rw-r--r--graphics/radius-engine/Makefile39
-rw-r--r--graphics/radius-engine/distinfo2
-rw-r--r--graphics/radius-engine/pkg-descr5
3 files changed, 46 insertions, 0 deletions
diff --git a/graphics/radius-engine/Makefile b/graphics/radius-engine/Makefile
new file mode 100644
index 000000000000..2163fc6fae1c
--- /dev/null
+++ b/graphics/radius-engine/Makefile
@@ -0,0 +1,39 @@
+# New Ports collection makefile for: Radius Engine
+# Date created: 2012-05-17
+# Whom: nemysis@gmx.ch
+#
+# $FreeBSD$
+#
+
+PORTNAME= radius-engine
+PORTVERSION= 1.1
+CATEGORIES= graphics devel
+MASTER_SITES= SF/${PORTNAME}/
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Lua script-based 2D engine built on top of OpenGL and SDL
+
+LICENSE= MIT
+
+LIB_DEPENDS= lua-5.1:${PORTSDIR}/lang/lua \
+ png:${PORTSDIR}/graphics/png \
+ physfs.1:${PORTSDIR}/devel/physfs
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+CFLAGS+= -I${LOCALBASE}/include
+USE_SDL= sdl sound
+USE_GL= glu
+MAKE_JOBS_SAFE= yes
+
+PLIST_FILES= include/radius.h \
+ lib/libradius-engine.a \
+ libdata/pkgconfig/radius-engine.pc
+PLIST_DIRSTRY= libdata/pkgconfig
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|lua5.1|lua-5.1|g' \
+ ${WRKSRC}/acinclude.m4 ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|(pkgconfigdir)|{PREFIX}/libdata/pkgconfig|g' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/graphics/radius-engine/distinfo b/graphics/radius-engine/distinfo
new file mode 100644
index 000000000000..077c1168c32b
--- /dev/null
+++ b/graphics/radius-engine/distinfo
@@ -0,0 +1,2 @@
+SHA256 (radius-engine-1.1.tar.gz) = 7acad286ac9d8ed1d7328411ec38d225dd8a90acb848f63bb8bb7edee8de42ed
+SIZE (radius-engine-1.1.tar.gz) = 237747
diff --git a/graphics/radius-engine/pkg-descr b/graphics/radius-engine/pkg-descr
new file mode 100644
index 000000000000..470de7c88fc5
--- /dev/null
+++ b/graphics/radius-engine/pkg-descr
@@ -0,0 +1,5 @@
+Radius Engine is a Lua script-based real-time 2D graphics engine designed
+for rapidly prototyping games. Built on top of SDL and OpenGL,
+games made with Radius Engine are portable to both Windows and Linux.
+
+WWW: http://radius-engine.sourceforge.net/