aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/rawtherapee
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2011-09-08 08:07:55 +0800
committerstas <stas@FreeBSD.org>2011-09-08 08:07:55 +0800
commit73c75b09d9493c301f647e23c8891a6adedc4d3b (patch)
treeb1a345a6f6f4b69293cfe39aba3da5835a11838c /graphics/rawtherapee
parent8ebad781462d796a0dbba2b3dc4d632b228e852d (diff)
downloadfreebsd-ports-gnome-73c75b09d9493c301f647e23c8891a6adedc4d3b.tar.gz
freebsd-ports-gnome-73c75b09d9493c301f647e23c8891a6adedc4d3b.tar.zst
freebsd-ports-gnome-73c75b09d9493c301f647e23c8891a6adedc4d3b.zip
- Update to 4.0.2.
- Add workaround for Glib's non-UTF8 locale bug.
Diffstat (limited to 'graphics/rawtherapee')
-rw-r--r--graphics/rawtherapee/Makefile13
-rw-r--r--graphics/rawtherapee/distinfo4
-rw-r--r--graphics/rawtherapee/files/patch-About-Linux.cmake31
-rw-r--r--graphics/rawtherapee/files/patch-CMakeLists.txt70
-rw-r--r--graphics/rawtherapee/files/patch-rtengine_safegtk.cc47
-rw-r--r--graphics/rawtherapee/pkg-plist101
6 files changed, 174 insertions, 92 deletions
diff --git a/graphics/rawtherapee/Makefile b/graphics/rawtherapee/Makefile
index b000fd498708..5e3d712accd6 100644
--- a/graphics/rawtherapee/Makefile
+++ b/graphics/rawtherapee/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= rawtherapee
-PORTVERSION= 3.0
-PORTREVISION= 3
+PORTVERSION= 4.0.2
+PORTREVISION= 0
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.SpringDaemons.com/soft/
@@ -19,7 +19,7 @@ LICENSE= GPLv3
LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
iptcdata.3:${PORTSDIR}/graphics/libiptcdata \
jpeg.11:${PORTSDIR}/graphics/jpeg \
- lcms.1:${PORTSDIR}/graphics/lcms \
+ lcms2.2:${PORTSDIR}/graphics/lcms2 \
png:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
sigc-2.0:${PORTSDIR}/devel/libsigc++20
@@ -29,6 +29,7 @@ USE_BZIP2= yes
USE_GNOME= gtk20 glib20 pkgconfig
USE_LDCONFIG= yes
CFLAGS+= -I${LOCALBASE}/include -fPIC ${PTHREAD_CFLAGS}
+CXXFLAGS+= -I${LOCALBASE}/include -fPIC ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CMAKE_ENV= CFLAGS="${CFLAGS}" \
LDFLAGS="${LDFLAGS}"
@@ -36,7 +37,9 @@ CMAKE_ARGS+= -DDOCDIR="${DOCSDIR}" \
-DCREDITSDIR="${DOCSDIR}" \
-DLICENCEDIR="${DOCSDIR}" \
-DDESKTOPDIR="${DESKTOPDIR}" \
- -DDATADIR="${DATADIR}"
+ -DDATADIR="${DATADIR}" \
+ -DCMAKE_C_FLAGS="${CFLAGS}" \
+ -DCMAKE_CXX_FLAGS="${CXXFLAGS}"
SUB_FILES= rawtherapee
SUB_LIST= RTDIR="${RTDIR}"
INSTALLS_ICONS= yes
@@ -52,6 +55,8 @@ OPTIONS= OPTIMIZED_CFLAGS "Use optimized CFLAGS" on \
.if !defined(WITHOUT_OPTIMIZED_CFLAGS)
CFLAGS+= -O3 -ffast-math -fexpensive-optimizations \
-funroll-loops -msse
+CXXFLAGS+= -O3 -ffast-math -fexpensive-optimizations \
+ -funroll-loops -msse
.endif
.endif
diff --git a/graphics/rawtherapee/distinfo b/graphics/rawtherapee/distinfo
index 7de940c55f5e..a538be60ea4b 100644
--- a/graphics/rawtherapee/distinfo
+++ b/graphics/rawtherapee/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rawtherapee-3.0.tar.bz2) = 80a8c668a639bb5f677f2798798ab3d39c42cfb19212e742960a1e79d7ea8264
-SIZE (rawtherapee-3.0.tar.bz2) = 20053492
+SHA256 (rawtherapee-4.0.2.tar.bz2) = 9a7af9a78dd6e84d0a236c6b92447d8844972318b203983743ba487533250e1a
+SIZE (rawtherapee-4.0.2.tar.bz2) = 29029897
diff --git a/graphics/rawtherapee/files/patch-About-Linux.cmake b/graphics/rawtherapee/files/patch-About-Linux.cmake
deleted file mode 100644
index e84b3afc44f4..000000000000
--- a/graphics/rawtherapee/files/patch-About-Linux.cmake
+++ /dev/null
@@ -1,31 +0,0 @@
---- About-Linux.cmake.orig 2011-07-30 14:05:38.000000000 -0700
-+++ About-Linux.cmake 2011-08-10 00:47:37.000000000 -0700
-@@ -1,27 +1,8 @@
- # cmakefile executed within a makefile target
-
--# we look for the hg command in this paths by order of preference
--find_file(HG_CMD hg)
--
--
--# the hg command is looked for again, at build time
--if (HG_CMD STREQUAL HG_CMD-NOTFOUND)
-- message(FATAL_ERROR "hg command not found!")
--else (HG_CMD STREQUAL HG_CMD-NOTFOUND)
-- message(STATUS "hg command found: ${HG_CMD}")
--endif (HG_CMD STREQUAL HG_CMD-NOTFOUND)
--
- set (OUT_FILE "${SRC_DIR}/AboutThisBuild.txt")
--set (SHELL "/bin/bash")
-+set (SHELL "/bin/sh")
- # there should be a better way of getting the compiler + compiler version, not restrained to Gcc
--execute_process(COMMAND gcc -dumpversion OUTPUT_VARIABLE GCC_VERSION OUTPUT_STRIP_TRAILING_WHITESPACE)
--execute_process(COMMAND ${HG_CMD} -R ${SRC_DIR} branch OUTPUT_VARIABLE HG_BRANCH OUTPUT_STRIP_TRAILING_WHITESPACE)
--execute_process(COMMAND ${HG_CMD} parents --template={latesttag}.{latesttagdistance} WORKING_DIRECTORY ${SRC_DIR} OUTPUT_VARIABLE HG_VERSION OUTPUT_STRIP_TRAILING_WHITESPACE)
--execute_process(COMMAND ${HG_CMD} parents --template={node|short} WORKING_DIRECTORY ${SRC_DIR} OUTPUT_VARIABLE HG_CHANGESET OUTPUT_STRIP_TRAILING_WHITESPACE)
--execute_process(COMMAND ${HG_CMD} parents --template={latesttagdistance} WORKING_DIRECTORY ${SRC_DIR} OUTPUT_VARIABLE HG_TAGDISTANCE OUTPUT_STRIP_TRAILING_WHITESPACE)
--if (CACHE_NAME_SUFFIX STREQUAL "")
-- execute_process(COMMAND ${HG_CMD} parents --template={latesttag} WORKING_DIRECTORY ${SRC_DIR} OUTPUT_VARIABLE CACHE_NAME_SUFFIX OUTPUT_STRIP_TRAILING_WHITESPACE)
--endif ()
-
- # build version.h from template
- configure_file (${SRC_DIR}/rtgui/version.h.in ${SRC_DIR}/rtgui/version.h)
diff --git a/graphics/rawtherapee/files/patch-CMakeLists.txt b/graphics/rawtherapee/files/patch-CMakeLists.txt
index 2c9296896324..ae25127fe8b7 100644
--- a/graphics/rawtherapee/files/patch-CMakeLists.txt
+++ b/graphics/rawtherapee/files/patch-CMakeLists.txt
@@ -1,33 +1,37 @@
---- CMakeLists.txt.orig 2011-07-30 14:05:38.000000000 -0700
-+++ CMakeLists.txt 2011-08-10 00:45:13.000000000 -0700
-@@ -250,17 +250,11 @@
- -P ${CMAKE_CURRENT_SOURCE_DIR}/About-Linux.cmake
- COMMENT "Creating the about file"
- )
-- find_file(HG_CMD hg)
-
- endif (WIN32)
-
- add_dependencies(AboutFile Debug Release MinSizeRel RelWithDebInfo)
-
-- if (HG_CMD STREQUAL HG_CMD-NOTFOUND)
-- message(FATAL_ERROR "hg command not found!")
-- else (HG_CMD STREQUAL HG_CMD-NOTFOUND)
-- message(STATUS "hg command found: ${HG_CMD}")
-- endif (HG_CMD STREQUAL HG_CMD-NOTFOUND)
-
- endif (AUTOMATED_BUILD_SYSTEM)
-
-@@ -322,9 +316,9 @@
- endif (OPENMP_FOUND)
- endif (OPTION_OMP)
-
--if (UNIX)
-- install (PROGRAMS rtstart DESTINATION ${BINDIR})
--endif (UNIX)
-+#if (UNIX)
-+# install (PROGRAMS rtstart DESTINATION ${BINDIR})
-+#endif (UNIX)
-
- install (FILES AUTHORS.txt DESTINATION ${CREDITSDIR})
- install (FILES LICENSE.txt DESTINATION ${LICENCEDIR})
+--- CMakeLists.txt.orig 2011-09-06 23:56:26.000000000 -0700
++++ CMakeLists.txt 2011-09-07 01:05:07.000000000 -0700
+@@ -224,7 +224,6 @@
+ -P ${CMAKE_CURRENT_SOURCE_DIR}/About-Windows.cmake
+ COMMENT "Creating the about file"
+ )
+- find_file(HG_CMD hg.exe HINTS ENV Path PATH_SUFFIXES ../)
+
+ elseif (APPLE)
+
+@@ -244,7 +243,6 @@
+ -P ${CMAKE_CURRENT_SOURCE_DIR}/About-Apple.cmake
+ COMMENT "Creating the about file"
+ )
+- find_file(HG_CMD hg PATHS "/opt/local/bin" "/usr/local/bin" "/usr/bin")
+ find_file(HG_CMD hg)
+
+ else (WIN32)
+@@ -265,18 +263,11 @@
+ -P ${CMAKE_CURRENT_SOURCE_DIR}/About-Linux.cmake
+ COMMENT "Creating the about file"
+ )
+- find_file(HG_CMD hg)
+
+ endif (WIN32)
+
+ add_dependencies(AboutFile Debug Release MinSizeRel RelWithDebInfo)
+
+- if (HG_CMD STREQUAL HG_CMD-NOTFOUND)
+- message(FATAL_ERROR "hg command not found!")
+- else (HG_CMD STREQUAL HG_CMD-NOTFOUND)
+- message(STATUS "hg command found: ${HG_CMD}")
+- endif (HG_CMD STREQUAL HG_CMD-NOTFOUND)
+-
+ endif (AUTOMATED_BUILD_SYSTEM)
+
+
diff --git a/graphics/rawtherapee/files/patch-rtengine_safegtk.cc b/graphics/rawtherapee/files/patch-rtengine_safegtk.cc
new file mode 100644
index 000000000000..3c9dcc42afe2
--- /dev/null
+++ b/graphics/rawtherapee/files/patch-rtengine_safegtk.cc
@@ -0,0 +1,47 @@
+--- rtengine/safegtk.cc.orig 2011-09-07 14:24:33.000000000 -0700
++++ rtengine/safegtk.cc 2011-09-07 14:25:11.000000000 -0700
+@@ -101,7 +101,7 @@
+ Glib::RefPtr<Gio::FileEnumerator> dirList;
+ if (dir) {
+ SAFE_ENUMERATOR_CODE_START
+- flist.push_back (FileMTimeInfo (removeExtension(info->get_name()), info->modification_time()));
++ flist.push_back (FileMTimeInfo (removeExtension(info->get_display_name()), info->modification_time()));
+ SAFE_ENUMERATOR_CODE_END;
+ }
+ }
+@@ -116,7 +116,7 @@
+ if (dir) {
+ if (!extensions) {
+ SAFE_ENUMERATOR_CODE_START
+- names.push_back (Glib::build_filename (directory, info->get_name()));
++ names.push_back (Glib::build_filename (directory, info->get_display_name()));
+ SAFE_ENUMERATOR_CODE_END;
+ }
+ else {
+@@ -127,7 +127,7 @@
+
+ SAFE_ENUMERATOR_CODE_START
+ // convert the current filename to lowercase in a new ustring
+- Glib::ustring fname = Glib::ustring(info->get_name()).lowercase();
++ Glib::ustring fname = Glib::ustring(info->get_display_name()).lowercase();
+
+ int pos = fname.find_last_of('.');
+ if (pos > -1 && pos < (fname.length()-1)) {
+@@ -138,7 +138,7 @@
+ // look out if it has one of the retained extensions
+ for (unsigned int i=0; i<lcExtensions.size(); i++) {
+ if (lcFileExt == lcExtensions[i]) {
+- names.push_back (Glib::build_filename (directory, info->get_name()));
++ names.push_back (Glib::build_filename (directory, info->get_display_name()));
+ break;
+ }
+ }
+@@ -159,7 +159,7 @@
+
+ SAFE_ENUMERATOR_CODE_START
+ if (info->get_file_type() == Gio::FILE_TYPE_DIRECTORY && (!info->is_hidden() || add_hidden))
+- subDirs.push_back (info->get_name());
++ subDirs.push_back (info->get_display_name());
+ SAFE_ENUMERATOR_CODE_END;
+ }
+ }
diff --git a/graphics/rawtherapee/pkg-plist b/graphics/rawtherapee/pkg-plist
index 43a514d9b7d8..eaf6e303c126 100644
--- a/graphics/rawtherapee/pkg-plist
+++ b/graphics/rawtherapee/pkg-plist
@@ -9,14 +9,30 @@ share/icons/hicolor/32x32/apps/rawtherapee.png
share/icons/hicolor/48x48/apps/rawtherapee.png
share/icons/hicolor/128x128/apps/rawtherapee.png
share/icons/hicolor/256x256/apps/rawtherapee.png
-%%DATADIR%%/images/wbpicker22.png
+%%DATADIR%%/images/FullScreen_exit.png
+%%DATADIR%%/images/PanelEnding_01.png
+%%DATADIR%%/images/addtagl.png
%%DATADIR%%/images/addtags.png
+%%DATADIR%%/images/beforeafter.png
%%DATADIR%%/images/cdrom.png
+%%DATADIR%%/images/cglabel0.png
+%%DATADIR%%/images/cglabel1.png
+%%DATADIR%%/images/cglabel2.png
+%%DATADIR%%/images/cglabel3.png
+%%DATADIR%%/images/cglabel4.png
+%%DATADIR%%/images/cglabel5.png
+%%DATADIR%%/images/clabel0.png
+%%DATADIR%%/images/clabel1.png
+%%DATADIR%%/images/clabel2.png
+%%DATADIR%%/images/clabel3.png
+%%DATADIR%%/images/clabel4.png
+%%DATADIR%%/images/clabel5.png
%%DATADIR%%/images/closedhand22.png
%%DATADIR%%/images/crop16.png
-%%DATADIR%%/images/hdd.png
+%%DATADIR%%/images/crop22.png
+%%DATADIR%%/images/crop_auto_22.png
%%DATADIR%%/images/cross22.png
-%%DATADIR%%/images/stock-flip-horizontal-16.png
+%%DATADIR%%/images/crossed_arrows_out_45_02.png
%%DATADIR%%/images/curveType-NURBS.png
%%DATADIR%%/images/curveType-controlPoints.png
%%DATADIR%%/images/curveType-flatLinear.png
@@ -26,25 +42,31 @@ share/icons/hicolor/256x256/apps/rawtherapee.png
%%DATADIR%%/images/curveType-unchanged.png
%%DATADIR%%/images/deltagl.png
%%DATADIR%%/images/deltags.png
-%%DATADIR%%/images/stock-flip-vertical-16.png
-%%DATADIR%%/images/stock-rotate-270-16.png
+%%DATADIR%%/images/distortion.png
+%%DATADIR%%/images/distortion_auto.png
%%DATADIR%%/images/down.png
-%%DATADIR%%/images/stock-rotate-90-16.png
-%%DATADIR%%/images/unrated.png
-%%DATADIR%%/images/red.png
-%%DATADIR%%/images/warnsh.png
+%%DATADIR%%/images/edited.png
+%%DATADIR%%/images/edited_10.png
+%%DATADIR%%/images/editedg_10.png
+%%DATADIR%%/images/editednot_10.png
+%%DATADIR%%/images/editednotg_10.png
%%DATADIR%%/images/empty.png
%%DATADIR%%/images/fileopen.png
%%DATADIR%%/images/filesave.png
%%DATADIR%%/images/filter.png
+%%DATADIR%%/images/filterclear.png
+%%DATADIR%%/images/filterclear_18.png
+%%DATADIR%%/images/filterclearg_18.png
%%DATADIR%%/images/flame22.png
%%DATADIR%%/images/floppy.png
%%DATADIR%%/images/folder.png
+%%DATADIR%%/images/folder_bw.png
%%DATADIR%%/images/folder_open.png
%%DATADIR%%/images/folder_open_r.png
%%DATADIR%%/images/folder_orange.png
%%DATADIR%%/images/folder_orange_open.png
%%DATADIR%%/images/folder_r.png
+%%DATADIR%%/images/fullscreen.png
%%DATADIR%%/images/gimp.png
%%DATADIR%%/images/grayrated.png
%%DATADIR%%/images/green.png
@@ -55,7 +77,14 @@ share/icons/hicolor/256x256/apps/rawtherapee.png
%%DATADIR%%/images/gtk-zoom-fit.png
%%DATADIR%%/images/gtk-zoom-in.png
%%DATADIR%%/images/gtk-zoom-out.png
+%%DATADIR%%/images/hdd.png
%%DATADIR%%/images/head.png
+%%DATADIR%%/images/histBar.png
+%%DATADIR%%/images/histBlue.png
+%%DATADIR%%/images/histGreen.png
+%%DATADIR%%/images/histRaw.png
+%%DATADIR%%/images/histRed.png
+%%DATADIR%%/images/histValue.png
%%DATADIR%%/images/horizontal.png
%%DATADIR%%/images/horizontals.png
%%DATADIR%%/images/icon-gears.png
@@ -66,48 +95,74 @@ share/icons/hicolor/256x256/apps/rawtherapee.png
%%DATADIR%%/images/list-remove.png
%%DATADIR%%/images/list-remove12r.png
%%DATADIR%%/images/logoicon16.png
-%%DATADIR%%/images/network.png
%%DATADIR%%/images/logoicon16b.png
%%DATADIR%%/images/logoicon32.png
+%%DATADIR%%/images/logoicon_wind_16.png
+%%DATADIR%%/images/network.png
+%%DATADIR%%/images/nocolorlabel.png
%%DATADIR%%/images/notrated.png
%%DATADIR%%/images/openhand.png
%%DATADIR%%/images/openhand22.png
+%%DATADIR%%/images/openhand_gray22.png
+%%DATADIR%%/images/panel_to_bottom.png
+%%DATADIR%%/images/panel_to_left.png
+%%DATADIR%%/images/panel_to_right.png
+%%DATADIR%%/images/panel_to_top.png
%%DATADIR%%/images/processing-pause.png
%%DATADIR%%/images/processing-play.png
%%DATADIR%%/images/processing.png
%%DATADIR%%/images/rated.png
+%%DATADIR%%/images/ratednot_10.png
+%%DATADIR%%/images/ratednotg_10.png
+%%DATADIR%%/images/red.png
+%%DATADIR%%/images/refresh_red.png
+%%DATADIR%%/images/refresh_white.png
%%DATADIR%%/images/resize.png
+%%DATADIR%%/images/right.png
+%%DATADIR%%/images/right_red.png
+%%DATADIR%%/images/save_hdd_01.png
%%DATADIR%%/images/saved.png
+%%DATADIR%%/images/saved_10.png
+%%DATADIR%%/images/savedg_10.png
+%%DATADIR%%/images/savednot_10.png
+%%DATADIR%%/images/savednotg_10.png
%%DATADIR%%/images/splash.png
%%DATADIR%%/images/stock-color-picker-gray-18.png
+%%DATADIR%%/images/stock-flip-horizontal-16.png
+%%DATADIR%%/images/stock-flip-vertical-16.png
%%DATADIR%%/images/stock-resize-16.png
+%%DATADIR%%/images/stock-rotate-270-16.png
+%%DATADIR%%/images/stock-rotate-90-16.png
%%DATADIR%%/images/stock-tool-color-picker-22.png
%%DATADIR%%/images/stock-tool-crop-16.png
%%DATADIR%%/images/stock-tool-crop-22.png
%%DATADIR%%/images/stock_clear_24.png
%%DATADIR%%/images/stock_down_arrow_24.png
-%%DATADIR%%/images/tail.png
%%DATADIR%%/images/stock_left_arrow_24.png
%%DATADIR%%/images/stock_right_arrow_24.png
%%DATADIR%%/images/stock_up_arrow_24.png
%%DATADIR%%/images/straighten16.png
%%DATADIR%%/images/straighten22.png
-%%DATADIR%%/images/beforeafter.png
-%%DATADIR%%/images/crop22.png
+%%DATADIR%%/images/tail.png
+%%DATADIR%%/images/toleftend.png
+%%DATADIR%%/images/torightend.png
%%DATADIR%%/images/trash-show-empty.png
%%DATADIR%%/images/trash-show-full.png
%%DATADIR%%/images/trash.png
-%%DATADIR%%/images/edited.png
+%%DATADIR%%/images/uncolorlabel.png
%%DATADIR%%/images/undelete.png
%%DATADIR%%/images/undo.png
-%%DATADIR%%/images/warnhl.png
+%%DATADIR%%/images/unrated.png
%%DATADIR%%/images/usbpendrive.png
%%DATADIR%%/images/vertical.png
%%DATADIR%%/images/verticals.png
+%%DATADIR%%/images/warnhl.png
+%%DATADIR%%/images/warnsh.png
%%DATADIR%%/images/wb22.png
%%DATADIR%%/images/wbpicker16.png
-%%DATADIR%%/images/addtagl.png
-%%DATADIR%%/languages/default
+%%DATADIR%%/images/wbpicker22.png
+%%DATADIR%%/images/x_10.png
+%%DATADIR%%/languages/Catala
%%DATADIR%%/languages/Chinese (Simplified)
%%DATADIR%%/languages/Chinese (Traditional)
%%DATADIR%%/languages/Czech
@@ -139,8 +194,8 @@ share/icons/hicolor/256x256/apps/rawtherapee.png
%%DATADIR%%/languages/Suomi
%%DATADIR%%/languages/Swedish
%%DATADIR%%/languages/Turkish
-%%DATADIR%%/languages/Catala
-%%DATADIR%%/profiles/Sepia-2.pp3
+%%DATADIR%%/languages/default
+%%DATADIR%%/profiles/BW-1.pp3
%%DATADIR%%/profiles/BW-2.pp3
%%DATADIR%%/profiles/Natural-1.pp3
%%DATADIR%%/profiles/Natural-2.pp3
@@ -154,15 +209,16 @@ share/icons/hicolor/256x256/apps/rawtherapee.png
%%DATADIR%%/profiles/default-ISO-medium.pp3
%%DATADIR%%/profiles/default.pp3
%%DATADIR%%/profiles/neutral.pp3
-%%DATADIR%%/profiles/Sepia-1.pp3
-%%DATADIR%%/profiles/BW-1.pp3
-%%DATADIR%%/themes/gray_textured/trough2.png
+%%DATADIR%%/sounds/BatchComplete.wav
+%%DATADIR%%/sounds/Empty.wav
+%%DATADIR%%/sounds/ProcessComplete.wav
%%DATADIR%%/themes/gray_textured/arrow-down-pre.png
%%DATADIR%%/themes/gray_textured/arrow-down.png
%%DATADIR%%/themes/gray_textured/arrow-left-ins.png
%%DATADIR%%/themes/gray_textured/arrow-left-pre.png
%%DATADIR%%/themes/gray_textured/arrow-left.png
%%DATADIR%%/themes/gray_textured/arrow-right-ins.png
+%%DATADIR%%/themes/gray_textured/trough2.png
%%DATADIR%%/themes/gray_textured/arrow-right-pre.png
%%DATADIR%%/themes/gray_textured/arrow-right.png
%%DATADIR%%/themes/gray_textured/arrow-up-ins.png
@@ -203,6 +259,7 @@ share/icons/hicolor/256x256/apps/rawtherapee.png
@dirrm %%DATADIR%%/images
@dirrm %%DATADIR%%/languages
@dirrm %%DATADIR%%/profiles
+@dirrm %%DATADIR%%/sounds
@dirrm %%DATADIR%%/themes/gray_textured
@dirrm %%DATADIR%%/themes
@dirrm %%DATADIR%%