aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/sdl_image
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2015-02-07 16:21:46 +0800
committermva <mva@FreeBSD.org>2015-02-07 16:21:46 +0800
commit09c0bef49f66ca04e86480dcee6c11cca5eeb8d3 (patch)
tree8ae14d26d40a7b08332da78aab120b21b052972d /graphics/sdl_image
parent81d14b760d27d6d5828faa59a83fe5c226385107 (diff)
downloadfreebsd-ports-gnome-09c0bef49f66ca04e86480dcee6c11cca5eeb8d3.tar.gz
freebsd-ports-gnome-09c0bef49f66ca04e86480dcee6c11cca5eeb8d3.tar.zst
freebsd-ports-gnome-09c0bef49f66ca04e86480dcee6c11cca5eeb8d3.zip
- Provide OPTION knobs for the LIB_DEPENDS of sdl_image and sdl2_image
PR: 195987 Submitted by: jbeich@
Diffstat (limited to 'graphics/sdl_image')
-rw-r--r--graphics/sdl_image/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/graphics/sdl_image/Makefile b/graphics/sdl_image/Makefile
index 84238bc32c74..91f340543b43 100644
--- a/graphics/sdl_image/Makefile
+++ b/graphics/sdl_image/Makefile
@@ -13,11 +13,6 @@ COMMENT= Simple library to load images of various formats as SDL surfaces
LICENSE= LGPL21
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng.so:${PORTSDIR}/graphics/png \
- libtiff.so:${PORTSDIR}/graphics/tiff \
- libwebp.so:${PORTSDIR}/graphics/webp
-
USES= gmake libtool pkgconfig pathfix
USE_SDL= sdl
GNU_CONFIGURE= yes
@@ -25,6 +20,18 @@ CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib -lm
USE_LDCONFIG= yes
+OPTIONS_DEFINE= JPEG PNG TIFF WEBP
+OPTIONS_DEFAULT=JPEG PNG TIFF WEBP
+
+JPEG_LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
+JPEG_CONFIGURE_ENABLE= jpg
+PNG_LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
+PNG_CONFIGURE_ENABLE= png
+TIFF_LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff
+TIFF_CONFIGURE_ENABLE= tif
+WEBP_LIB_DEPENDS= libwebp.so:${PORTSDIR}/graphics/webp
+WEBP_CONFIGURE_ENABLE= webp
+
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/.libs/showimage ${STAGEDIR}${PREFIX}/bin