aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/sdl_image
diff options
context:
space:
mode:
authordaichi <daichi@FreeBSD.org>2003-07-31 15:10:01 +0800
committerdaichi <daichi@FreeBSD.org>2003-07-31 15:10:01 +0800
commit3197425d15866368435648d8e94a19378c620cd4 (patch)
tree3739bfc2d7e67e09e5ef691a0be0656a92ed8821 /graphics/sdl_image
parent2f7bbd009e4b3e61f085d120ff4218d9e5a4c49b (diff)
downloadfreebsd-ports-gnome-3197425d15866368435648d8e94a19378c620cd4.tar.gz
freebsd-ports-gnome-3197425d15866368435648d8e94a19378c620cd4.tar.zst
freebsd-ports-gnome-3197425d15866368435648d8e94a19378c620cd4.zip
update graphics/sdl_image:
- Utilize USE_SDL - PERL -> REINPLACE_CMD PR: 55058 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Diffstat (limited to 'graphics/sdl_image')
-rw-r--r--graphics/sdl_image/Makefile28
1 files changed, 12 insertions, 16 deletions
diff --git a/graphics/sdl_image/Makefile b/graphics/sdl_image/Makefile
index 6b1af93208b2..a30ea26c655e 100644
--- a/graphics/sdl_image/Makefile
+++ b/graphics/sdl_image/Makefile
@@ -15,27 +15,23 @@ DISTNAME= SDL_image-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A simple library to load images of various formats as SDL surfaces
-LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff \
- jpeg.9:${PORTSDIR}/graphics/jpeg
+ tiff.4:${PORTSDIR}/graphics/tiff
-SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
-
-USE_LIBTOOL= yes
+USE_SDL= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
-INSTALLS_SHLIB= yes
-CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
- CPPFLAGS="-I${X11BASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lm"
+USE_LIBTOOL= yes
+LIBTOOLFLAGS= --disable-ltlibs --release-ignore
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lm"
CONFIGURE_ARGS= --enable-tif --enable-xcf
-
-post-extract:
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|-release \$$\(LT_RELEASE\)||g'
+INSTALLS_SHLIB= yes
post-configure:
- @${PERL} -pi -e 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
- ${WRKSRC}/libtool
+ @${REINPLACE_CMD} -e \
+ 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
+ ${WRKSRC}/libtool
.include <bsd.port.mk>