aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/sdl_image
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-07-10 01:43:11 +0800
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-07-10 01:43:11 +0800
commit9e5632dd661f75b5801706e55659a4da501e49b5 (patch)
tree1a0770d8cc1771f94f7777b9a986bb87029c35d9 /graphics/sdl_image
parent90c653ebbfee158880bc5fc4eb15ad057288510a (diff)
downloadfreebsd-ports-gnome-9e5632dd661f75b5801706e55659a4da501e49b5.tar.gz
freebsd-ports-gnome-9e5632dd661f75b5801706e55659a4da501e49b5.tar.zst
freebsd-ports-gnome-9e5632dd661f75b5801706e55659a4da501e49b5.zip
Apply a big libtool patch to allow porters to use the libtool installed by
the libtoolX ports instead of the one included with each port. Ports that set USE_LIBTOOL_VER=X will now use the ports version of libtool instead of the included version. To restore previous behavior, use the new macro, USE_INC_LIBTOOL_VER. Both macros accept the same argument: a libtool version. For example, to use the ports version of libtool-1.5, add the following to your Makefile: USE_LIBTOOL_VER= 15 To use the included version of libtool with extra hacks provided by libtool-1.5, add the following to your Makefile: USE_INC_LIBTOOL_VER= 15 With this change, ports that had to add additional libtool hacks to prevent .la files from being installed or to fix certain threading issues can now delete those hacks (after appropriate testing, of course). PR: 63944 Based on work by:eik and marcus Approved by: ade (autotools maintainer) Tested by: kris on pointyhat Bound to be hidden problems: You bet
Diffstat (limited to 'graphics/sdl_image')
-rw-r--r--graphics/sdl_image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/graphics/sdl_image/Makefile b/graphics/sdl_image/Makefile
index 52613b34ab4a..fddd7df73f14 100644
--- a/graphics/sdl_image/Makefile
+++ b/graphics/sdl_image/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
USE_SDL= sdl
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lm"