aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/sdl_ttf
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-10-14 16:54:54 +0800
committermarcus <marcus@FreeBSD.org>2006-10-14 16:54:54 +0800
commit0deb7538cc6a5ae90f4e3e4bdbfe6d0ab974aed8 (patch)
tree17937489af4c767844fc63b684ae3e7b31948812 /graphics/sdl_ttf
parente959473966b963953d63d5f00fae8751f2decf0f (diff)
downloadfreebsd-ports-gnome-0deb7538cc6a5ae90f4e3e4bdbfe6d0ab974aed8.tar.gz
freebsd-ports-gnome-0deb7538cc6a5ae90f4e3e4bdbfe6d0ab974aed8.tar.zst
freebsd-ports-gnome-0deb7538cc6a5ae90f4e3e4bdbfe6d0ab974aed8.zip
Chase the GNOME X11BASE to LOCALBASE move, and fix the build with the
new freetype2 where needed. Submitted by: mezz, ahze, pav, and many others Approved by: portmgr (implicit, kris)
Diffstat (limited to 'graphics/sdl_ttf')
-rw-r--r--graphics/sdl_ttf/Makefile1
-rw-r--r--graphics/sdl_ttf/files/patch-SDL_ttf.c19
2 files changed, 20 insertions, 0 deletions
diff --git a/graphics/sdl_ttf/Makefile b/graphics/sdl_ttf/Makefile
index 91acaa6da329..c355211a1e2d 100644
--- a/graphics/sdl_ttf/Makefile
+++ b/graphics/sdl_ttf/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sdl_ttf
PORTVERSION= 2.0.8
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://www.libsdl.org/projects/SDL_ttf/release/
DISTNAME= SDL_ttf-${PORTVERSION}
diff --git a/graphics/sdl_ttf/files/patch-SDL_ttf.c b/graphics/sdl_ttf/files/patch-SDL_ttf.c
new file mode 100644
index 000000000000..dbfadc22790f
--- /dev/null
+++ b/graphics/sdl_ttf/files/patch-SDL_ttf.c
@@ -0,0 +1,19 @@
+--- SDL_ttf.c.orig Mon May 1 05:26:17 2006
++++ SDL_ttf.c Sun Sep 24 15:46:44 2006
+@@ -48,7 +48,6 @@
+ #include <freetype/ftoutln.h>
+ #include <freetype/ttnameid.h>
+ */
+-#include <freetype/internal/ftobjs.h>
+
+ #ifndef FT_OPEN_STREAM
+ #define FT_OPEN_STREAM ft_open_stream
+@@ -278,7 +277,7 @@
+ }
+ memset(stream, 0, sizeof(*stream));
+
+- stream->memory = library->memory;
++ stream->memory = NULL;
+ stream->read = RWread;
+ stream->descriptor.pointer = src;
+ stream->pos = (unsigned long)position;