aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/swfdec/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2008-08-11 07:06:06 +0800
committermarcus <marcus@FreeBSD.org>2008-08-11 07:06:06 +0800
commit4d401ebf0513b9941b6316f771cd67888107084c (patch)
tree1e71e3944c73f20cf00e3a12875d0722582f1863 /graphics/swfdec/Makefile
parentee49f1ac460fd1229a06f89b2e0d648e08bbfe8e (diff)
downloadfreebsd-ports-gnome-4d401ebf0513b9941b6316f771cd67888107084c.tar.gz
freebsd-ports-gnome-4d401ebf0513b9941b6316f771cd67888107084c.tar.zst
freebsd-ports-gnome-4d401ebf0513b9941b6316f771cd67888107084c.zip
Only add the ffmpeg CPPFLAGS if not building with gstreamer.
Diffstat (limited to 'graphics/swfdec/Makefile')
-rw-r--r--graphics/swfdec/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/graphics/swfdec/Makefile b/graphics/swfdec/Makefile
index 8a352dde5927..951697ec5497 100644
--- a/graphics/swfdec/Makefile
+++ b/graphics/swfdec/Makefile
@@ -20,12 +20,14 @@ LIB_DEPENDS= oil-0.3.0:${PORTSDIR}/devel/liboil \
USE_GNOME= gnomehack gtk20
USE_AUTOTOOLS= libtool:15:env automake:19:env autoconf:261
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/ffmpeg" \
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="-Wl,-Bsymbolic -L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-audio=oss
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
+CPPFLAGS= -I${LOCALBASE}/include
+
OPTIONS= GSTREAMER "Support for decoding some codecs with GStreamer" off
PLIST_SUB= VERSION=${PORTVERSION:R}
@@ -38,6 +40,7 @@ USE_GSTREAMER= yes
LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg \
mad.2:${PORTSDIR}/audio/libmad
CONFIGURE_ARGS+= --disable-gstreamer --enable-ffmpeg --enable-mad
+CPPFLAGS+= -I${LOCALBASE}/include/ffmpeg
.endif
post-patch: