aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/swfdec/Makefile
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2003-05-19 08:14:18 +0800
committerpetef <petef@FreeBSD.org>2003-05-19 08:14:18 +0800
commitd0f6863181f92caf90ccb098abde01da3fae06b4 (patch)
tree4b624b8fa28945b729bb3dc5070c3b57faf5da49 /graphics/swfdec/Makefile
parentfed5d9ccbb045cfb3235b241c9f3ce7336d5f87a (diff)
downloadfreebsd-ports-gnome-d0f6863181f92caf90ccb098abde01da3fae06b4.tar.gz
freebsd-ports-gnome-d0f6863181f92caf90ccb098abde01da3fae06b4.tar.zst
freebsd-ports-gnome-d0f6863181f92caf90ccb098abde01da3fae06b4.zip
- install .pc file to the correct place
- use USE_GETOPT_LONG - sort pkg-plist correctly - bump PORTREVISION PR: 52136 Submitted by: Ports Fury
Diffstat (limited to 'graphics/swfdec/Makefile')
-rw-r--r--graphics/swfdec/Makefile18
1 files changed, 12 insertions, 6 deletions
diff --git a/graphics/swfdec/Makefile b/graphics/swfdec/Makefile
index 284dc2840852..48ea71394da2 100644
--- a/graphics/swfdec/Makefile
+++ b/graphics/swfdec/Makefile
@@ -8,6 +8,7 @@
PORTNAME= swfdec
PORTVERSION= 0.2.1
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,19 +16,24 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Flash Rendering Library
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
- mad.1:${PORTSDIR}/audio/mad \
- gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+ mad.1:${PORTSDIR}/audio/mad
+RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
USE_X_PREFIX= yes
+USE_GNOME= gnomehack gtk20 libartlgpl2
+USE_GETOPT_LONG= yes
USE_REINPLACE= yes
-USE_GNOME= gtk20 libartlgpl2
-SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} LDFLAGS="{LDFLAGS}
INSTALLS_SHLIB= yes
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
post-patch:
@${REINPLACE_CMD} -e "s|sdl-config|${SDL_CONFIG}|" ${WRKSRC}/configure
@${REINPLACE_CMD} -e "s|malloc\.h|stdlib.h|" ${WRKSRC}/libswfdec/jpeg/sl_types.h