aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/swfdec
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2008-03-24 11:52:36 +0800
committermarcus <marcus@FreeBSD.org>2008-03-24 11:52:36 +0800
commit7f7d1cea729a5815af0f4db6edfc5ba0f62a57e3 (patch)
tree862f96db414616c771eb64412d27d795591004f0 /graphics/swfdec
parent6c3349d5db64bb9ea320c30d23ba353e2f013754 (diff)
downloadfreebsd-ports-gnome-7f7d1cea729a5815af0f4db6edfc5ba0f62a57e3.tar.gz
freebsd-ports-gnome-7f7d1cea729a5815af0f4db6edfc5ba0f62a57e3.tar.zst
freebsd-ports-gnome-7f7d1cea729a5815af0f4db6edfc5ba0f62a57e3.zip
The FreeBSD GNOME team is proud to annunce the release of GNOME 2.22.0 for
FreeBSD. The official GNOME 2.22 release notes can be found at http://library.gnome.org/misc/release-notes/2.22/ . On the FreeBSD front, this release features an updated hal port with support for video4linux devices, DRM (Direct Rendering), and better support of removable media. Work is also underway to tie webkit more closely into GNOME. As part of the GNOME 2.22 upgrade, GStreamer received a rather large upgrade as well. Be sure to consult UPDATING on the proper steps to upgrade all of your GNOME ports. This release would not have been possible without the contributions and testing efforts of the following people: Pawel Worach kan edwin Peter Ulrich Kruppa J. W. Ballantine Yasuda Keisuke Andriy Gapon
Diffstat (limited to 'graphics/swfdec')
-rw-r--r--graphics/swfdec/Makefile9
-rw-r--r--graphics/swfdec/distinfo6
-rw-r--r--graphics/swfdec/files/patch-swfdec-gtk_swfdec_gtk_system.c16
-rw-r--r--graphics/swfdec/pkg-plist79
4 files changed, 68 insertions, 42 deletions
diff --git a/graphics/swfdec/Makefile b/graphics/swfdec/Makefile
index 727b46ad7eb3..cce4ee5d2919 100644
--- a/graphics/swfdec/Makefile
+++ b/graphics/swfdec/Makefile
@@ -7,15 +7,16 @@
#
PORTNAME= swfdec
-PORTVERSION= 0.5.5
+PORTVERSION= 0.6.0
+PORTREVISION= 1
CATEGORIES= graphics
-MASTER_SITES= http://swfdec.freedesktop.org/download/swfdec/0.5/
+MASTER_SITES= http://swfdec.freedesktop.org/download/swfdec/0.6/
MAINTAINER= alexbl@FreeBSD.org
COMMENT= Flash Rendering Library
-LIB_DEPENDS= oil-0.3.1:${PORTSDIR}/devel/liboil \
- soup-2.2.8:${PORTSDIR}/devel/libsoup
+LIB_DEPENDS= oil-0.3.0:${PORTSDIR}/devel/liboil \
+ soup-2.4.1:${PORTSDIR}/devel/libsoup
USE_GNOME= gnomehack gtk20
USE_AUTOTOOLS= libtool:15:env automake:19:env autoconf:261
diff --git a/graphics/swfdec/distinfo b/graphics/swfdec/distinfo
index 63f872cc7ce0..8359a495cd09 100644
--- a/graphics/swfdec/distinfo
+++ b/graphics/swfdec/distinfo
@@ -1,3 +1,3 @@
-MD5 (swfdec-0.5.5.tar.gz) = b988b014e210cee205aeccaca4d6a9a7
-SHA256 (swfdec-0.5.5.tar.gz) = 30b6f4f0ec424b60c91f8db272068f51cb3df204f6a65f155308389981bb99a6
-SIZE (swfdec-0.5.5.tar.gz) = 8667844
+MD5 (swfdec-0.6.0.tar.gz) = c012a5e6dd23558b86d2e08e2e43857b
+SHA256 (swfdec-0.6.0.tar.gz) = bd7c9068ce545ef75f8820b94f6b0954194ca5b106a53463bf9a6ed448fa057f
+SIZE (swfdec-0.6.0.tar.gz) = 8762575
diff --git a/graphics/swfdec/files/patch-swfdec-gtk_swfdec_gtk_system.c b/graphics/swfdec/files/patch-swfdec-gtk_swfdec_gtk_system.c
new file mode 100644
index 000000000000..2a62e63dee30
--- /dev/null
+++ b/graphics/swfdec/files/patch-swfdec-gtk_swfdec_gtk_system.c
@@ -0,0 +1,16 @@
+--- swfdec-gtk/swfdec_gtk_system.c.orig 2008-02-22 15:38:09.000000000 -0500
++++ swfdec-gtk/swfdec_gtk_system.c 2008-02-22 15:38:13.000000000 -0500
+@@ -114,8 +114,12 @@ swfdec_gtk_system_get_language (void)
+ static int
+ swfdec_gtk_system_get_utc_offset (void)
+ {
++ struct tm *t;
++ time_t tt;
+ tzset ();
+- return timezone / 60;
++ tt = time (NULL);
++ t = localtime (&tt);
++ return t->tm_gmtoff / 60;
+ }
+
+ /*** PUBLIC API ***/
diff --git a/graphics/swfdec/pkg-plist b/graphics/swfdec/pkg-plist
index ba94d5763aec..4bece92d530e 100644
--- a/graphics/swfdec/pkg-plist
+++ b/graphics/swfdec/pkg-plist
@@ -1,62 +1,71 @@
-include/swfdec-%%VERSION%%/libswfdec-gtk/swfdec-gtk.h
-include/swfdec-%%VERSION%%/libswfdec-gtk/swfdec_gtk_keys.h
-include/swfdec-%%VERSION%%/libswfdec-gtk/swfdec_gtk_loader.h
-include/swfdec-%%VERSION%%/libswfdec-gtk/swfdec_gtk_player.h
-include/swfdec-%%VERSION%%/libswfdec-gtk/swfdec_gtk_widget.h
-include/swfdec-%%VERSION%%/libswfdec/swfdec.h
-include/swfdec-%%VERSION%%/libswfdec/swfdec_as_array.h
-include/swfdec-%%VERSION%%/libswfdec/swfdec_as_context.h
-include/swfdec-%%VERSION%%/libswfdec/swfdec_as_debugger.h
-include/swfdec-%%VERSION%%/libswfdec/swfdec_as_frame.h
-include/swfdec-%%VERSION%%/libswfdec/swfdec_as_function.h
-include/swfdec-%%VERSION%%/libswfdec/swfdec_as_native_function.h
-include/swfdec-%%VERSION%%/libswfdec/swfdec_as_object.h
-include/swfdec-%%VERSION%%/libswfdec/swfdec_as_types.h
-include/swfdec-%%VERSION%%/libswfdec/swfdec_audio.h
-include/swfdec-%%VERSION%%/libswfdec/swfdec_buffer.h
-include/swfdec-%%VERSION%%/libswfdec/swfdec_enums.h
-include/swfdec-%%VERSION%%/libswfdec/swfdec_file_loader.h
-include/swfdec-%%VERSION%%/libswfdec/swfdec_keys.h
-include/swfdec-%%VERSION%%/libswfdec/swfdec_loader.h
-include/swfdec-%%VERSION%%/libswfdec/swfdec_player.h
-include/swfdec-%%VERSION%%/libswfdec/swfdec_rectangle.h
-include/swfdec-%%VERSION%%/libswfdec/swfdec_script.h
-include/swfdec-%%VERSION%%/libswfdec/swfdec_system.h
-include/swfdec-%%VERSION%%/libswfdec/swfdec_url.h
+include/swfdec-%%VERSION%%/swfdec-gtk/swfdec-gtk.h
+include/swfdec-%%VERSION%%/swfdec-gtk/swfdec_gtk_keys.h
+include/swfdec-%%VERSION%%/swfdec-gtk/swfdec_gtk_loader.h
+include/swfdec-%%VERSION%%/swfdec-gtk/swfdec_gtk_player.h
+include/swfdec-%%VERSION%%/swfdec-gtk/swfdec_gtk_socket.h
+include/swfdec-%%VERSION%%/swfdec-gtk/swfdec_gtk_system.h
+include/swfdec-%%VERSION%%/swfdec-gtk/swfdec_gtk_widget.h
+include/swfdec-%%VERSION%%/swfdec/swfdec.h
+include/swfdec-%%VERSION%%/swfdec/swfdec_as_array.h
+include/swfdec-%%VERSION%%/swfdec/swfdec_as_context.h
+include/swfdec-%%VERSION%%/swfdec/swfdec_as_debugger.h
+include/swfdec-%%VERSION%%/swfdec/swfdec_as_frame.h
+include/swfdec-%%VERSION%%/swfdec/swfdec_as_function.h
+include/swfdec-%%VERSION%%/swfdec/swfdec_as_native_function.h
+include/swfdec-%%VERSION%%/swfdec/swfdec_as_object.h
+include/swfdec-%%VERSION%%/swfdec/swfdec_as_types.h
+include/swfdec-%%VERSION%%/swfdec/swfdec_audio.h
+include/swfdec-%%VERSION%%/swfdec/swfdec_buffer.h
+include/swfdec-%%VERSION%%/swfdec/swfdec_enums.h
+include/swfdec-%%VERSION%%/swfdec/swfdec_file_loader.h
+include/swfdec-%%VERSION%%/swfdec/swfdec_keys.h
+include/swfdec-%%VERSION%%/swfdec/swfdec_loader.h
+include/swfdec-%%VERSION%%/swfdec/swfdec_player.h
+include/swfdec-%%VERSION%%/swfdec/swfdec_player_scripting.h
+include/swfdec-%%VERSION%%/swfdec/swfdec_rectangle.h
+include/swfdec-%%VERSION%%/swfdec/swfdec_script.h
+include/swfdec-%%VERSION%%/swfdec/swfdec_socket.h
+include/swfdec-%%VERSION%%/swfdec/swfdec_stream.h
+include/swfdec-%%VERSION%%/swfdec/swfdec_system.h
+include/swfdec-%%VERSION%%/swfdec/swfdec_url.h
lib/libswfdec-%%VERSION%%.a
lib/libswfdec-%%VERSION%%.la
lib/libswfdec-%%VERSION%%.so
-lib/libswfdec-%%VERSION%%.so.5
+lib/libswfdec-%%VERSION%%.so.90
lib/libswfdec-gtk-%%VERSION%%.a
lib/libswfdec-gtk-%%VERSION%%.la
lib/libswfdec-gtk-%%VERSION%%.so
-lib/libswfdec-gtk-%%VERSION%%.so.5
+lib/libswfdec-gtk-%%VERSION%%.so.90
libdata/pkgconfig/swfdec-%%VERSION%%.pc
libdata/pkgconfig/swfdec-gtk-%%VERSION%%.pc
+share/gtk-doc/html/swfdec/SwfdecAsArray.html
share/gtk-doc/html/swfdec/SwfdecAsContext.html
share/gtk-doc/html/swfdec/SwfdecAsDebugger.html
+share/gtk-doc/html/swfdec/SwfdecAsFrame.html
+share/gtk-doc/html/swfdec/SwfdecAsFunction.html
+share/gtk-doc/html/swfdec/SwfdecAsObject.html
share/gtk-doc/html/swfdec/SwfdecAudio.html
-share/gtk-doc/html/swfdec/SwfdecGtkLoader.html
share/gtk-doc/html/swfdec/SwfdecGtkPlayer.html
share/gtk-doc/html/swfdec/SwfdecGtkWidget.html
share/gtk-doc/html/swfdec/SwfdecLoader.html
share/gtk-doc/html/swfdec/SwfdecPlayer.html
+share/gtk-doc/html/swfdec/SwfdecPlayerScripting.html
+share/gtk-doc/html/swfdec/SwfdecSocket.html
+share/gtk-doc/html/swfdec/SwfdecStream.html
share/gtk-doc/html/swfdec/SwfdecSystem.html
share/gtk-doc/html/swfdec/ch01.html
share/gtk-doc/html/swfdec/ch02.html
share/gtk-doc/html/swfdec/ch03.html
+share/gtk-doc/html/swfdec/ch04.html
share/gtk-doc/html/swfdec/home.png
share/gtk-doc/html/swfdec/index.html
share/gtk-doc/html/swfdec/index.sgml
share/gtk-doc/html/swfdec/left.png
share/gtk-doc/html/swfdec/right.png
share/gtk-doc/html/swfdec/style.css
-share/gtk-doc/html/swfdec/swfdec-Enumerations.html
+share/gtk-doc/html/swfdec/swfdec-Enumerations-and-Types.html
+share/gtk-doc/html/swfdec/swfdec-Gtk-extension-objects.html
share/gtk-doc/html/swfdec/swfdec-Internals.html
-share/gtk-doc/html/swfdec/swfdec-SwfdecAsArray.html
-share/gtk-doc/html/swfdec/swfdec-SwfdecAsFrame.html
-share/gtk-doc/html/swfdec/swfdec-SwfdecAsFunction.html
-share/gtk-doc/html/swfdec/swfdec-SwfdecAsObject.html
share/gtk-doc/html/swfdec/swfdec-SwfdecAsValue.html
share/gtk-doc/html/swfdec/swfdec-SwfdecBuffer.html
share/gtk-doc/html/swfdec/swfdec-SwfdecRectangle.html
@@ -71,6 +80,6 @@ share/icons/hicolor/32x32/apps/swfdec.png
share/icons/hicolor/48x48/apps/swfdec.png
share/icons/hicolor/scalable/apps/swfdec.svg
@dirrm share/gtk-doc/html/swfdec
-@dirrm include/swfdec-%%VERSION%%/libswfdec-gtk
-@dirrm include/swfdec-%%VERSION%%/libswfdec
+@dirrm include/swfdec-%%VERSION%%/swfdec-gtk
+@dirrm include/swfdec-%%VERSION%%/swfdec
@dirrm include/swfdec-%%VERSION%%