aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/threeDS
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-01-19 03:28:48 +0800
committersobomax <sobomax@FreeBSD.org>2001-01-19 03:28:48 +0800
commit0bc4b4d220096e81a2c6de5e002c841ade496f82 (patch)
tree29bd6a1452abe4a37d09df194afddca7bced82d3 /graphics/threeDS
parent812d862957254eda5953ebc9449588150a4c86dd (diff)
downloadfreebsd-ports-gnome-0bc4b4d220096e81a2c6de5e002c841ade496f82.tar.gz
freebsd-ports-gnome-0bc4b4d220096e81a2c6de5e002c841ade496f82.tar.zst
freebsd-ports-gnome-0bc4b4d220096e81a2c6de5e002c841ade496f82.zip
Two fixes:
- Properly import PIL module; - don't try to do os.chdir() with empty argument.
Diffstat (limited to 'graphics/threeDS')
-rw-r--r--graphics/threeDS/Makefile1
-rw-r--r--graphics/threeDS/files/patch-threeDS.py24
2 files changed, 25 insertions, 0 deletions
diff --git a/graphics/threeDS/Makefile b/graphics/threeDS/Makefile
index a6c298d0a759..58229db5bc66 100644
--- a/graphics/threeDS/Makefile
+++ b/graphics/threeDS/Makefile
@@ -7,6 +7,7 @@
PORTNAME= threeDS
PORTVERSION= 0.2
+PORTREVISION= 1
CATEGORIES= graphics python
MASTER_SITES= http://www.demonseed.net/~jp/code/threeDS/
diff --git a/graphics/threeDS/files/patch-threeDS.py b/graphics/threeDS/files/patch-threeDS.py
new file mode 100644
index 000000000000..a593642562c2
--- /dev/null
+++ b/graphics/threeDS/files/patch-threeDS.py
@@ -0,0 +1,24 @@
+
+$FreeBSD$
+
+--- threeDS.py 2001/01/18 19:26:14 1.1
++++ threeDS.py 2001/01/18 19:26:19
+@@ -82,7 +82,7 @@
+ self.imgfile = readStr(f)
+ # print "texture: " + self.imgfile
+ try:
+- from Imaging import Image
++ from PIL import Image
+ except:
+ print 'Can\'t load texture without PIL!!'
+ continue
+@@ -370,7 +370,8 @@
+
+ def __init__(self, filename):
+ (path, filename) = os.path.split(filename)
+- os.chdir(path)
++ if path != '':
++ os.chdir(path)
+ f = open(filename, "rb")
+ if f is None:
+ print "error loading " + str(filename) + "."